Veracrypt und pm-suspend funktionieren nicht / Veracrypt and pm-suspend not working together

    • Veracrypt und pm-suspend funktionieren nicht / Veracrypt and pm-suspend not working together

      German:


      Hallo zusammen,
      ich bin ganz neu hier und dachte ich frage mal ganz nett nach ein bisschen Hilfe. ^^ Das ist mein erster Beitrag in einem Forum und ich versuche mal, mein Problem strukturiert wiederzugeben. Das Problem entsteht, wenn das System, mit eingehängten Veracrypt Dateisystemen, automatisch unterbrechen soll (Befehl -> pm-suspend).


      System:
      OS: OMV 3.0
      CPU: J4205
      RAM: 8GB
      HDD: 2 HDDs mit 2 Daten


      Fehlerverhalten:
      Das System hängt sich nach pm-suspend auf. Heißt, die Lüfter und das System, laufen noch aber es kann weder über das Netzwerk als auch über angeschlossene Geräte wie Monitor, Tastatur erreichen. Einzige Lösung ist der reset button.

      Veracrypt Einrichtung:
      Ich habe ein verschlüsseltes Laufwerk (ext4) erstellt und dieses mit einem Keyfile und einem Passwort gesichert. Eine PIM habe ich nicht vergeben. Nun wird diese Platte ohne Filesystem gemountet (veracrypt –filesystem=none VerschlüsseltesDateisystem). In der Web GUI von OMV taucht das Dateisystem nun auf und kann eingebunden werden.

      Solange dieses Dateisystem keine Daten enthält, funktioniert pm-suspend wunderbar. Nun habe ich Daten per mv in das Dateisystem verschoben. Genau jetzt funktioniert es nicht mehr, es tritt das Fehlverhalten ein.


      Lösungsansatz:

      Sowie im Systemlog als auch in den logs von pm-utils ist nichts aufgeführt, laut den logs war alles erfolgreich. Ich bin dann auf die komische Idee gekommen, die Daten erst über cp zu kopieren und dann zu testen, ob es funktioniert. Komischerweise hat dann alles funktioniert, ohne Probleme.

      Nun funktioniert das erste Dateisystem. Ich habe dann ein 2. Erstellt und diesmal per Samba mit Daten befüllt und bekomme wieder dasselbe Fehlverhalten.

      Ich habe schon vieles abgekürzt und es ist trotzdem so viel Text, in der Suchfunktion sowie überall anders im Internet konnte ich kein ähnliches Verhalten finden.

      Hat jemand eine Idee, woran dieses Verhalten liegen könnte?


      Englisch:


      Hello everybody,

      Im new to the community and since I could find any solution on the World Wide Web I am hoping that you could help me with my veracrypt error. The error occurs if a veracrypt volume is mounted and pm-suspend is executed.


      Error:
      The System is not suspending after pm-suspend. In fact, the fans are still running and it seems like it’s working but the system is not reachable and even with connected monitor and keyboard there is a black screen and the system cannot be fixed. Only fix is pressing the reset button.


      Veracrypt Setup:
      I created an encrypted Volume (ext4) with a password and an keyfile, without setting a PIM. Mounted the Filesystem with (veracrypt –filesystem=none VerschlüsseltesDateisystem) and added with the Web GUI of OMV.

      As long as there is no data on the encrypted volume, pm-suspend works fine. After moving data using the mv command, the error occurs after pm-suspend.


      Started the fixing:
      I searched in every log, syslog and the pm-utils logs, in their everything looks fine and no errors are documented. One Idea was to use the cp command instead mv to transfer the data, it’s strange but now there are no problems with pm-suspend and this volume mounted.

      So that my first volume is working fine, I created a second one on my second drive. This time I used Samba to transfer data. But with the second volume mounted I get the same error as described before.

      I tried to make a long story short and I cant find any information about this error anywhere else, so I would be very happy if someone could help me.