Disk Referenced and cannot chown

    • OMV 3.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Disk Referenced and cannot chown

      Hello there,
      i',m new here so bear with me,
      i just installed OMV 3 on my RasPi3 and i installed plexserver too
      i attached three usb hdds with a powered usb hub, using one of them for TimeMachine which works like a charm
      another one seems ok, but the last one which is the most important one to me and has a lot of videos (movies, tv show,..) which i want to use with plex seems to have a problem.
      first, it's shown as referenced in my filesystem tab, but i don't have any shared folder except my timemachine, and i don't have any users so no home directories, and nothing else
      second, i can't add it as my plex server database volume, cause when i apply the changes it shows a long error about trying to chown the disk and not being able because of operation not permitted
      i also tried to chown disk with CLI as root which i was not able to do,
      what is the problem?
    • no it's not NTFS, it's FAT32
      even if it was NTFS the chown should still work, right?

      By the way, i re installed the whole thing, started from scratch and still no luck.. the disk is no longer referenced but when i try to enable plex, it shows error about chown

      and it works just fine if i choose another one of my disk as database volume!!! how is that even possible?
    • I'm also thinking now about Plex. There was only one guy I knew of that was porting it for the RPis. He stopped working on it over a year ago. What instructions did you use to intsall plex?

      We see problems all the time when people are trying to use linux filesystem commands on non native linux filesystems. I would only recommend doing this on linux filesystems (e.g. ext4 or XFS).
    • tekkb wrote:

      I'm also thinking now about Plex. There was only one guy I knew of that was porting it for the RPis. He stopped working on it over a year ago. What instructions did you use to intsall plex?

      We see problems all the time when people are trying to use linux filesystem commands on non native linux filesystems. I would only recommend doing this on linux filesystems (e.g. ext4 or XFS).
      I installed Plex via the plugin provided in GUI..


      Anyway i Solved the problem and it had nothing to do with Plex!!! it's a problem that OpenMediaVault has with Fat32 format (vfat).

      just did this:

      Shell-Script

      1. sudo nano /etc/fstab



      and changed the line that OMV created for Fat32 formatted disk from:

      Shell-Script

      1. /dev/disk/by-label-Plex /srv/dev-disk-by-label-Plex vfat defaults,nofail 0 2
      to:


      Shell-Script

      1. /dev/disk/by-label-Plex /srv/dev-disk-by-label-Plex vfat auto,users,nofail,dmask=000,fmask=111 0 0
      and then:

      Shell-Script

      1. chmod 755 -R /srv/dev-disk-by-label-Plex
      2. chown USER -R /srv/dev-disk-by-label-Plex
      And then rebooted, and now it works just fine like my other disks that are formatted with Ext4, NTFS, HFS+