Communication Failure on all browsers except one

    • OMV 2.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Communication Failure on all browsers except one

      Hi I'm running OMV 2, after some upgrade I can login to my OMV GUI only from one browser (Chrome Win10), all other browsers have "Communication Failure" error. I don't know where to dig, can't find apache nor nginx logs.


      List of plugins

      Source Code

      1. root@tornadox-omv:/home/tornadox# dpkg -l | grep openm
      2. ii openmediavault 2.2.14 all Open network attached storage solution
      3. ii openmediavault-autoshutdown 1.0.8 all OpenMediaVault AutoShutdown Plugin
      4. ii openmediavault-backup 1.0.11 all backup plugin for OpenMediaVault.
      5. ii openmediavault-flashmemory 1.9.2 all folder2ram plugin for OpenMediaVault
      6. ii openmediavault-keyring 0.4 all GnuPG archive keys of the OpenMediaVault archive
      7. ii openmediavault-minidlna 1.1 all OpenMediaVault miniDLNA (DLNA server) plugin
      8. ii openmediavault-mpd 1.0.3 all OpenMediaVault MPD (Music Player Daemon) plugin
      9. ii openmediavault-netatalk 2.0 all OpenMediaVault netatalk (AppleTalk Protocol Suite) plugin
      10. ii openmediavault-omvextrasorg 2.13.9 all OMV-Extras.org Package Repositories for OpenMediaVault
      11. ii openmediavault-openvpnas 1.0.10 all OpenVPN Acess Server plugin for OpenMediaVault.
      12. ii openmediavault-plexmediaserver 1.0.15 all OpenMediaVault Plex Media Server plugin
      13. ii openmediavault-shairport 2.5.1 all OpenMediaVault shairport (AirPlay/RAOP receiver) plugin
      14. ii openmediavault-syncthing 1.9.2 all Syncthing plugin for OpenMediaVault.
      15. ii openmediavault-transmissionbt 1.4 all OpenMediaVault Transmission (BitTorrent client) plugin.
      16. ii openmediavault-virtualbox 1.3 all VirtualBox plugin for OpenMediaVault.
      17. ii openmediavault-webdav 2.0 all OpenMediaVault WebDAV plugin.
      18. ii openmediavault-wol 1.0.4 all OpenMediaVault WOL plugin
      Display All
    • Hi

      Apache you do not need!
      Try using the IP address and see if you are on the same network?
      You may have to delete the Browser cache.
      forum-bpi.de Visit on and help us, The Germany Forum :thumbsup:
      github.com/Wolf2000Pi
      Banana Pi /Armbian 3.4.109 / Openmediavault 2.x
      Banana Pi /Armbian 4.11.5-sunxi / Openmediavault 3.0.xx (Test)
      Dell Inspiron One 2205 | Openmediavault 3.0.xx / Kernel 4.7 (Test)

      The post was edited 1 time, last by The Master ().

    • Still doesn't help,

      here is what happens when I run omv-engined -d -f


      Source Code

      1. Child process forked (pid=3692)
      2. Executing RPC (service=UserMgmt, method=authUser, params={"username":"admin","password":"Ah70W2Z2cDVa"}, context={"username":"admin","role":1,"_SERVER":{"SERVER_PROTOCOL":"HTTP\/1.1","GATEWAY_INTERFACE":"CGI\/1.1","SERVER_SOFTWARE":"nginx\/1.2.1","REMOTE_ADDR":"::ffff:192.168.1.216","REMOTE_PORT":"60732","SERVER_ADDR":"::ffff:192.168.1.101","SERVER_PORT":"80","SERVER_NAME":"openmediavault-webgui","HTTPS":"","REDIRECT_STATUS":"200","HTTP_HOST":"192.168.1.101","HTTP_ORIGIN":"http:\/\/192.168.1.101","HTTP_USER_AGENT":"Mozilla\/5.0 (Macintosh; Intel Mac OS X 10_12_5) AppleWebKit\/603.2.4 (KHTML, like Gecko) Version\/10.1.1 Safari\/603.2.4","HTTP_CONTENT_TYPE":"application\/json","HTTP_REFERER":"http:\/\/192.168.1.101\/"}}) ...
      3. RPC response (service=UserMgmt, method=authUser): {"response":{"authenticated":true,"username":"admin"},"error":null}
      4. SIGCHLD received ...
      5. Child (pid=3692) terminated with exit code 0
      seems like password isn't sent to webgui
    • Here's part of history, none of this helped.


      Source Code

      1. 456 apt-get clean
      2. 457 rm -fv /var/lib/lists/packages.omv-extras.org_*
      3. 458 apt-get update
      4. 459 dpkg -l
      5. 461 apt-get remove openmediavault-omvextrasorg
      6. 462 wget http://omv-extras.org/openmediavault-omvextrasorg_latest_all.deb
      7. 463 dpkg -i openmediavault-omvextrasorg_latest_all.deb
      8. 464 apt-get update
      9. 466 omv-engined -df
      10. 467 useradd --groups users testuser
      11. 468 passwd testuser
      12. 469 omv-mkconf nginx
      13. 470 monit stop omv-engined
      14. 471 omv-engined -d -f
      15. 483 omv-mkconf nginx
      16. 484 omv-mkconf php5fpm
      17. 485 service nginx restart
      18. 486 service php5-fpm restart
      19. 487 shutdown -r now
      20. 488 omv-engined -d -f
      21. 489 apt-get install --reinstall openmediavault
      22. 495 apt-get install --reinstall php5-fpm
      23. 496 shutdown -r now
      Display All
      I've tried various solution, but still none helps.


      This is from a successful login

      Display Spoiler

      webserver
      zeroconf
      Child process forked (pid=15526)
      Executing RPC (service=UserMgmt, method=authUser, params={"username":"admin","password":"Ah70W2Z2cDVa"}, context={"username":"admin","role":1,"_SERVER":{"SERVER_PROTOCOL":"HTTP\/1.1","GATEWAY_INTERFACE":"CGI\/1.1","SERVER_SOFTWARE":"nginx\/1.2.1","REMOTE_ADDR":"::ffff:192.168.1.200","REMOTE_PORT":"3091","SERVER_ADDR":"::ffff:192.168.1.101","SERVER_PORT":"80","SERVER_NAME":"openmediavault-webgui","HTTPS":"","REDIRECT_STATUS":"200","HTTP_HOST":"192.168.1.101","HTTP_ORIGIN":"http:\/\/192.168.1.101","HTTP_USER_AGENT":"Mozilla\/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit\/537.36 (KHTML, like Gecko) Chrome\/60.0.3112.90 Safari\/537.36","HTTP_CONTENT_TYPE":"application\/json","HTTP_REFERER":"http:\/\/192.168.1.101\/"}}) ...
      RPC response (service=UserMgmt, method=authUser): {"response":{"authenticated":true,"username":"admin"},"error":null}
      SIGCHLD received ...
      Child (pid=15526) terminated with exit code 0
      Child process forked (pid=15530)
      Executing RPC (service=VirtualBox, method=getMachines, params={"start":0,"limit":25,"sortfield":null,"sortdir":null}, context={"username":"admin","role":1}) ...
      Child process forked (pid=15535)
      Child process forked (pid=15536)
      Child process forked (pid=15537)
      Executing RPC (service=Config, method=isDirty, params=null, context={"username":"admin","role":1}) ...
      RPC response (service=Config, method=isDirty): {"response":false,"error":null}
      SIGCHLD received ...
      Child (pid=15535) terminated with exit code 0
      Executing RPC (service=Services, method=getStatus, params=[], context={"username":"admin","role":1}) ...
      Executing RPC (service=VirtualBox, method=getSettings, params=null, context={"username":"admin","role":1}) ...
      RPC response (service=VirtualBox, method=getSettings): {"response":{"enable":true,"machines.sharedfolderref":"2f97ca57-c5cb-440b-8da4-1b0ade5f29a6","enable_advanced":true,"show_tab":true},"error":null}
      Child process forked (pid=15538)
      Executing RPC (service=System, method=getInformation, params=[], context={"username":"admin","role":1}) ...
      SIGCHLD received ...
      Child (pid=15537) terminated with exit code 0
      RPC response (service=VirtualBox, method=getMachines): {"response":{"total":4,"data":[{"uuid":"8aea4676-c3f8-4796-badd-6cf1e1bce136","name":"omv","state":"PoweredOff","startupMode":"manual","OSTypeId":"Debian_64","sessionState":"Unlocked"},{"uuid":"95c6fb56-9226-45ee-bcde-e56ee5a1e7cc","name":"Windows 7","state":"PoweredOff","startupMode":"manual","OSTypeId":"Windows7","sessionState":"Unlocked"},{"uuid":"8ec294a9-186b-43eb-b9b0-fc13df32d2d5","name":"Ubuntu-Compile-box","state":"PoweredOff","startupMode":"","OSTypeId":"Ubuntu_64","sessionState":"Unlocked"},{"uuid":"4be50057-6c89-4b5f-83a5-9cdee0827030","name":"windows XP","state":"PoweredOff","startupMode":"manual","OSTypeId":"WindowsXP","sessionState":"Unlocked"}]},"error":null}
      SIGCHLD received ...
      Child (pid=15530) terminated with exit code 0
      RPC response (service=Services, method=getStatus): {"response":{"total":17,"data":[{"name":"afp","title":"Apple Filing","enabled":true,"running":true},{"name":"autoshutdown","title":"AutoShutdown","enabled":true,"running":true},{"name":"ftp","title":"FTP","enabled":false,"running":false},{"name":"minidlna","title":"MiniDLNA","enabled":true,"running":true},{"name":"mpd","title":"MPD","enabled":true,"running":true},{"name":"nfs","title":"NFS","enabled":false,"running":false},{"name":"openvpnas","title":"OpenVPN AS","enabled":true,"running":true},{"name":"PlexMediaServer","title":"PlexMediaServer","enabled":true,"running":true},{"name":"rsyncd","title":"RSync server","enabled":false,"running":false},{"name":"samba","title":"SMB\/CIFS","enabled":true,"running":true},{"name":"shairport","title":"Shairport","enabled":true,"running":true},{"name":"snmp","title":"SNMP","enabled":false,"running":false},{"name":"ssh","title":"SSH","enabled":true,"running":true},{"name":"Syncthing","title":"Syncthing","enabled":true,"running":true},{"name":"tftp","title":"TFTP","enabled":false,"running":false},{"name":"transmissionbt","title":"BitTorrent","enabled":true,"running":true},{"name":"virtualbox","title":"VirtualBox WebService","enabled":true,"running":true}]},"error":null}
      SIGCHLD received ...
      Child (pid=15536) terminated with exit code 0
      RPC response (service=System, method=getInformation): {"response":[{"name":"Hostname","value":"tornadox-omv.lan","type":"string","index":0},{"name":"Version","value":"2.2.14 (Stone burner)","type":"string","index":1},{"name":"Processor","value":"AMD E-350D APU with Radeon(tm) HD Graphics","type":"string","index":2},{"name":"Kernel","value":"Linux 3.2.0-4-amd64","type":"string","index":3},{"name":"System time","value":"\u043f\u0442, 11-\u0441\u0435\u0440-2017 14:00:31 +0300","type":"string","index":4},{"name":"Uptime","value":"0 days 1 hour 5 minutes 24 seconds","type":"string","index":5},{"name":"Load average","value":"1.07, 0.85, 0.92","type":"string","index":6},{"name":"CPU usage","value":{"text":"52%","value":52.763819095477},"type":"progress","index":7},{"name":"Memory usage","value":{"text":"10% of 7.72 GiB","value":10},"type":"progress","index":8}],"error":null}
      SIGCHLD received ...
      Child (pid=15538) terminated with exit code 0

      ^CSIGINT received ...
    • Although there is the config.xml but you can not rely on it and there are also problems.
      I do it so I make myself screenshot of the most important things that is the only good solution.
      Otherwise it is just a basement
      Sorry my English is Google
      forum-bpi.de Visit on and help us, The Germany Forum :thumbsup:
      github.com/Wolf2000Pi
      Banana Pi /Armbian 3.4.109 / Openmediavault 2.x
      Banana Pi /Armbian 4.11.5-sunxi / Openmediavault 3.0.xx (Test)
      Dell Inspiron One 2205 | Openmediavault 3.0.xx / Kernel 4.7 (Test)