RAID5 after new installation

    • OMV 2.x
    • Resolved
    • Upgrade 2.x -> 3.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • RAID5 after new installation

      Hello,
      I currently have OMV installed (2.X) and got several issue (dependencies etc...).
      System is installed on USB stick, and i have 4 other disks (RAID5).

      Instead of doing an update, I'd rather reinstall the system entirely to get back on a clean system.

      Is it safe, if I install the new OMV (on USB stick) and then reconnect my 4 disks ?
      Will RAID be seen ? Do I risk losing my data ? I'm afraid that RAID will launch a rebuild :/

      Thanks
      OMV 2.2.14 (Stone burner)
      HP ProLiant MicroServer Gen8 G1610T - 8GB ECC - 4x Seagate BarraCuda 2TB (RAID5)

      Ride safe V
    • Kamiz wrote:

      Will RAID be seen ? Do I risk losing my data ? I'm afraid that RAID will launch a rebuild
      There are several threads here in the forum, where people get problems with RAID after reinstalling - and how they have fixed it.

      In any case I suggest to make a full data backup before. All other is Russian roulette.
      OMV 3.0.78 (Gray style)
      ASRock Rack C2550D4I - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1)- Fractal Design Node 304
    • Here's what I plan to do:
      - Full system backup (clonezilla).
      - Disconnection of the 4 disks.
      - Installation of the new system (OMV 3.X).
      - I turn off the system then I connect my 4 disks.

      If my RAID is recognized, so much the better !
      If my RAID is not recognized, I turn off the system before it rebuilds RAID, then I restore my system (OMV 2.X) done with Clonezilla.

      In this way, do I risk losing my data ?
      The problem is that I do not have enough storage to back up my 6TB of data.

      Thanks
      OMV 2.2.14 (Stone burner)
      HP ProLiant MicroServer Gen8 G1610T - 8GB ECC - 4x Seagate BarraCuda 2TB (RAID5)

      Ride safe V

      The post was edited 1 time, last by Kamiz ().

    • Kamiz wrote:

      In this way, do I risk losing my data ?
      It is possible that raid won't re-assemble even with restoring your OMV 2.x install. Some people have lost their array just rebooting.

      Kamiz wrote:

      The problem is that I do not have enough storage to back up my 6TB of data.
      Just remember raid is not backup...
      omv 4.0.5 arrakis | 64 bit | 4.12 backports kernel | omvextrasorg 4.0.4
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • cabrio_leo wrote:

      Kamiz wrote:

      Will RAID be seen ? Do I risk losing my data ? I'm afraid that RAID will launch a rebuild
      There are several threads here in the forum, where people get problems with RAID after reinstalling - and how they have fixed it.
      In any case I suggest to make a full data backup before. All other is Russian roulette.
      Okay, so I'll stay on that version. I would upgrade when I have enough storage to back up the contents of my RAID.

      I just want to install Docker plugin, but my kernel is too old, and my system will not boot if I install backports kernel (Target filesystem doesn't have /sbin/init).
      This is mainly why I want to upgrade to OMV 3.X. :/
      OMV 2.2.14 (Stone burner)
      HP ProLiant MicroServer Gen8 G1610T - 8GB ECC - 4x Seagate BarraCuda 2TB (RAID5)

      Ride safe V

      The post was edited 3 times, last by Kamiz ().