USB PICe Card that worked in 2.x not working in 3.x

    • OMV 3.x
    • Resolved
    • USB PICe Card that worked in 2.x not working in 3.x

      I did a fresh install of OMV3.x, and the PCIe card that was working in 2.x is no longer working in 3.

      The main thing I am seeing is USB Bus 1 deregistered, but I cannot find anything useful about this message.

      This is vmware on a dell server with the VIA PCIe device assigned to the OMV vm.

      Source Code

      1. root@openmediavault:~# dmesg | grep -i usb
      2. [ 0.744334] ACPI: bus type USB registered
      3. [ 0.744357] usbcore: registered new interface driver usbfs
      4. [ 0.744366] usbcore: registered new interface driver hub
      5. [ 0.744381] usbcore: registered new device driver usb
      6. [ 0.746219] xhci_hcd 0000:0b:00.0: new USB bus registered, assigned bus number 1
      7. [ 0.781380] xhci_hcd 0000:0b:00.0: USB bus 1 deregistered

      Source Code

      1. root@openmediavault:~# lsusb -v
      2. unable to initialize libusb: -99

      Source Code

      1. 0b:00.0 USB controller: VIA Technologies, Inc. Device 3483 (rev 01) (prog-if 30 [XHCI])
      2. Subsystem: VIA Technologies, Inc. Device 3483
      3. Physical Slot: 192
      4. Flags: fast devsel, IRQ 19
      5. Memory at fd3ff000 (64-bit, non-prefetchable) [size=4K]
      6. Capabilities: [80] Power Management version 3
      7. Capabilities: [90] MSI: Enable- Count=1/1 Maskable- 64bit+
      8. Capabilities: [c4] Express Endpoint, MSI 00
      9. Capabilities: [100] Advanced Error Reporting
    • One of the following things caused the error to go away:

      1) Shut down Dell Server
      2) Opened it up, checked all the connections
      3) Changed PCIe slots
      4) Booted, enabled passthrough, rebooted
      6) Profit. Well, it works again. I am going to chalk this up to VMWare weirdness of some sort - I meant to be more methodical but the server also has the VM with the router on it, and umm, other forces at home were not happy.