webgui problems aufter upgrade from 2.2.6 to 3.0.84

    • OMV 3.x
    • Resolved
    • Upgrade 2.x -> 3.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • webgui problems aufter upgrade from 2.2.6 to 3.0.84

      Hi,

      i upgrade my system today. after restarting i cant get login in webgui. only one i get is:

      Fehler #0:exception 'OMV\Rpc\Exception' with message 'Failed to connect to socket: No such file or directory' in /usr/share/php/openmediavault/rpc/rpc.inc:140Stack trace:#0 /var/www/openmediavault/rpc/session.inc(56): OMV\Rpc\Rpc::call('UserMgmt', 'authUser', Array, Array, 2, true)#1 [internal function]: OMVRpcServiceSession->login(Array, Array)#2 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)#3 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('login', Array, Array)#4 /usr/share/php/openmediavault/rpc/proxy/json.inc(95): OMV\Rpc\Rpc::call('Session', 'login', Array, Array, 3)#5 /var/www/openmediavault/rpc.php(45): OMV\Rpc\Proxy\Json->handle()#6 {main}

      i searched around web but i cant get any idea where the problem is. has anyone a idea?
      Thanx.
    • ii libgnutls-openssl27:amd64 3.3.8-6+deb8u7 amd64 GNU TLS library - OpenSSL wrapper
      ii libltdl7:amd64 2.4.2-1.11+b1 amd64 System independent dlopen wrapper for GNU libtool
      ii lsof 4.86+dfsg-1 amd64 Utility to list open files
      ii openmediavault 3.0.86 all Open network attached storage solution
      ii openmediavault-backup 3.6 all backup plugin for OpenMediaVault.
      ii openmediavault-clamav 3.3.3 all OpenMediaVault ClamAV plugin
      ii openmediavault-fail2ban 1.1.5 all OpenMediaVault Fail2ban plugin
      ii openmediavault-keyring 1.0 all GnuPG archive keys of the OpenMediaVault archive
      ii openmediavault-links 1.5 all OpenMediaVault links plugin
      ii openmediavault-luksencryption 3.0.2 all OpenMediaVault LUKS encryption plugin
      ii openmediavault-route 3.1.4 all OpenMediaVault IP routing table plugin
      ii openmediavault-rsnapshot 3.9 all OpenMediaVault rsnapshot backup plugin.
      ii openmediavault-usbbackup 3.2.20 all OpenMediaVault USB/eSATA backup plugin
      ii openmediavault-wol 3.2 all OpenMediaVault WOL plugin
      ii openssh-blacklist-extra 0.4.1+nmu1 all list of non-default blacklisted OpenSSH RSA and DSA keys
      ii openssh-client 1:6.7p1-5+deb8u3 amd64 secure shell (SSH) client, for secure access to remote machines
      ii openssh-server 1:6.7p1-5+deb8u3 amd64 secure shell (SSH) server, for secure access from remote machines
      ii openssh-sftp-server 1:6.7p1-5+deb8u3 amd64 secure shell (SSH) sftp server module, for SFTP access from remote machines
      ii openssl 1.0.1t-1+deb8u6 amd64 Secure Sockets Layer toolkit - cryptographic utility
    • dholdi wrote:

      Now the webgui just displays the omv logo which is clickable and takes me to the main website.
      Sounds like your browser cache needs to be cleared.
      omv 4.0.14 arrakis | 64 bit | 4.13 backports kernel | omvextrasorg 4.1.1
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • Try a different browser? Post a screenshot of what you are seeing. Also, post the output of: dpkg -l | grep openm
      omv 4.0.14 arrakis | 64 bit | 4.13 backports kernel | omvextrasorg 4.1.1
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • dholdi wrote:

      I don't have it attached to a monitor at the moment so will post the results you ask for at weekend.
      Can't you login via ssh?
      omv 4.0.14 arrakis | 64 bit | 4.13 backports kernel | omvextrasorg 4.1.1
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • Worked out how to SSH and this is the result from the command rycoeaaron asked for

      root@OMV3:~# dpkg -l | grep openm
      iU openmediavault 3.0.87 all Open network attached storage solution
      ii openmediavault-deluge 3.2 all OpenMediaVault Deluged plugin
      ii openmediavault-keyring 1.0 all GnuPG archive keys of the OpenMediaVault archive
      ii openmediavault-mumble 3.0.4 all Mumble server plugin for OpenMediaVault.
      ii openmediavault-omvextrasorg 3.4.25 all OMV-Extras.org Package Repositories for OpenMediaVault
      ii openmediavault-plexmediaserver 3.8.1 all OpenMediaVault Plex Media Server plugin

      Thanks
    • Thanks for sticking with me,

      root@OMV3:~# apt-get -f install
      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      0 upgraded, 0 newly installed, 0 to remove and 142 not upgraded.
      2 not fully installed or removed.
      After this operation, 0 B of additional disk space will be used.
      Setting up libjs-extjs6 (6.2.0.981-1) ...
      chmod: cannot access ‘/usr/share/javascript/extjs5/*’: No such file or directory
      dpkg: error processing package libjs-extjs6 (--configure):
      subprocess installed post-installation script returned error exit status 1
      dpkg: dependency problems prevent configuration of openmediavault:
      openmediavault depends on libjs-extjs6 (>= 6.2); however:
      Package libjs-extjs6 is not configured yet.
      dpkg: error processing package openmediavault (--configure):
      dependency problems - leaving unconfigured
      Errors were encountered while processing:
      libjs-extjs6
      openmediavault
      E: Sub-process /usr/bin/dpkg returned an error code (1)
      root@OMV3:~#
    • Don't know what happened but 2 posts I put in here last night around midnight are missing.
      One was to let you know that from the above I worked out that libjs-extjs6 was not installed properly so reinstalled that and webgui is now back :D
      The other was to thank rycoeaaron and Wolf2000 for their assistance, it was much appreciated.
      I haven't tried the commands Wolf2000 has suggested above, are they still worth running ?