After cold reboot samba share disappeared from network

    • Resolved
    • OMV 3.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • After cold reboot samba share disappeared from network

      Hi folks.

      I'm having a weird issue with my omv installation never experienced anything like that.
      I was playing around with my little nas with omv and the autoshutdown plugin/wake on lan, after a shutdown and reboot everything went bad.

      The hard disk with the samba shares disappeared from my network.

      I tried to troubleshoot it without success, what is even weird is that omv weblogin tells me the filesystem is mounted and everything is working fine, moreover if I ssh into my server looking for the mounted drive it's there in the /srv/ directory as it should be and I can see all the files (so I guess is not a problem of hard disk being dead, also is 0day new so..)

      I tried also to force umount the hard disk with umount -l /srv/dev-ecc.ecc. and mount again everything went fine, but still I can't access samba on network.

      I thought was an issue with iptables but I checked all the rules and they seems all fine.

      I'm out of ideas..any help would be great!


      some specs:

      omv 3.0.86 (erasmus)
      kernel: 4.9.0-0.bpo.3-amd64

      sda1 ext4 = SSD CORSAIR Force LS -> omv os
      sdb1 xfs = WD red 2 tb -> nas files (samba share plex movies and ecc. calibre and transmission download folder) this is the hard disk I'm having issues with
      sdc1 btrfs = WD blue 1 tb -> backup
      sdd1 xfs = WD blue 2 tb -> snapraid parity

      Everything were smooth before the autoshutdown\wake on lan test and now I don't know what did went wrong any ideas? ?(

      The post was edited 2 times, last by Wek ().

    • After playing with a bit more it seems everything went back as it should 8|

      Looking around the forum I found this thread OMV loss configuration not really my issue, but somewhat similar to the outcome so I just run the command suggeste by ryecoaaron

      ryecoaaron wrote:

      DIdn't see it. People don't use the spoiler type very often


      Not sure why your mntent entry is gone since it exists in fstab. Here is what I would do:


      omv-mkconf fstab
      reboot
      The drive shouldn't be mounted now so mount the filesystem in the web interface
      create new shared folders.

      After reboot everything seems normal.

      This is really strange I can't imagine for the life of me what did happened, about the topic what does omv-mkconf fstab really does to fstab? I tried to look at the code, but I didn't really understood it, I'm trying to figure out what was the matter.

      Any thoughts or hints in the right direction on this?

      The post was edited 2 times, last by Wek ().

    • New shtudown and reboot t's happening again X/ .
      The samba share doesn't appear on network and again I can see the hard disk mounted through the ssh and files are there....

      Anybody have ever experienced this?

      Could it be the wd red 2 tb hard disk faulty?! (S.M.A.R.T. seems ok though o.O).

      This time neither @ryecoaaron method of omv-mkconf fstab seems to work out to bring samba back.
      It also seems not related with the wd red nor the xfs filesystem, I tried to create different share on different hard disks with different filesystems and samba is still not reachable by my other computers on the network...

      So it seems a samba problem indeed, still can't understand what's going on

      The post was edited 2 times, last by Wek ().