Cannot install/update unmet dependency

    • Resolved
    • OMV 3.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Cannot install/update unmet dependency

      Hi, i am trying to install Node.js but i am getting the unmet dependency error, even though i have the dependency updated it still does not work.
      A friend suggested to purge and reinstall " libjs-jssip" but i didn't want to do it since i don't know what it does.

      Source Code

      1. S****3@openmediavault:~$ sudo apt-get install Node.JS
      2. Reading package lists... Done
      3. Building dependency tree
      4. Reading state information... Done
      5. Note, selecting 'node-json-stringify-safe' for regex 'Node.JS'
      6. Note, selecting 'node-jsconfig' for regex 'Node.JS'
      7. Note, selecting 'node-jscoverage' for regex 'Node.JS'
      8. Note, selecting 'node-jsv' for regex 'Node.JS'
      9. Note, selecting 'node-jssip' for regex 'Node.JS'
      10. Some packages could not be installed. This may mean that you have
      11. requested an impossible situation or if you are using the unstable
      12. distribution that some required packages have not yet been created
      13. or been moved out of Incoming.
      14. The following information may help to resolve the situation:
      15. The following packages have unmet dependencies:
      16. node-jssip : Depends: libjs-jssip (= 0.6.34-5~bpo8+1) but 0.4.0.20140212.1-3 is to be installed
      17. E: Unable to correct problems, you have held broken packages.
      18. S****3@openmediavault:~$ sudo apt-get -f install
      19. Reading package lists... Done
      20. Building dependency tree
      21. Reading state information... Done
      22. 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
      23. S****3@openmediavault:~$ sudo apt-get install libjs-jssip
      24. Reading package lists... Done
      25. Building dependency tree
      26. Reading state information... Done
      27. libjs-jssip is already the newest version.
      28. 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
      Display All
    • node-jssip is only available in the backports repo and it has a dependency on libjs-jssip from backports. So, you need to tell it to install that version.
      apt-get install libjs-jssip=0.6.34-5~bpo8+1
      omv 4.1.4 arrakis | 64 bit | 4.15 backports kernel | omvextrasorg 4.1.3
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please read this before posting a question.
      Please don't PM for support... Too many PMs!
    • ryecoaaron wrote:

      node-jssip is only available in the backports repo and it has a dependency on libjs-jssip from backports. So, you need to tell it to install that version.
      apt-get install libjs-jssip=0.6.34-5~bpo8+1
      Just tried it and it installed libjs-jssip, then i tried apt-get install node.js and it did install as well, but when i tried installing "nodejs" before "node.js" it said it was already installed.
      so "nodejs" & "node.js" are two different things ?
    • shant1993 wrote:

      Just tried it and it installed libjs-jssip, then i tried apt-get install node.js and it did install as well, but when i tried installing "nodejs" before "node.js" it said it was already installed.
      so "nodejs" & "node.js" are two different things ?
      They have different version numbers. That is about all I know since I don't use either.
      omv 4.1.4 arrakis | 64 bit | 4.15 backports kernel | omvextrasorg 4.1.3
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please read this before posting a question.
      Please don't PM for support... Too many PMs!