Plex permissions Issues

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Plex permissions Issues

      I started having weird file permissions errors with plex recently, prior to that it had been working fine for months.

      Any way to fix this I tried uninstalling plex and reinstalling but when I try to reinstall I get this error:
      Failed to execute XPath query '//services/plexmediaserver'.


      Error #0:
      exception 'OMV\Config\DatabaseException' with message 'Failed to execute XPath query '//services/plexmediaserver'.' in /usr/share/php/openmediavault/config/database.inc:78
      Stack trace:
      #0 /usr/share/openmediavault/engined/module/plexmediaserver.inc(58): OMV\Config\Database->get('conf.service.pl...')
      #1 /usr/share/openmediavault/engined/rpc/services.inc(56): OMVModulePlexMediaServer->getStatus()
      #2 [internal function]: OMVRpcServiceServices->getStatus(Array, Array)
      #3 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)
      #4 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('getStatus', Array, Array)
      #5 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Services', 'getStatus', Array, Array, 1)
      #6 {main}


      Any ideas how to repair this? I've tried purging plex and also removing the plex user, before trying to reinstall.

      Thanks

      EDIT:
      I'm using Mergerfs and Snapraid if that makes a difference, and I had been storing my Plex DB on my Mergerfs pool.

      The post was edited 1 time, last by danoldlib ().

    • dpkg -l | grep openm:

      ii openmediavault 3.0.86 all Open network attached storage solution
      ii openmediavault-apttool 3.4 all apt tool plugin for OpenMediaVault.
      ii openmediavault-backup 3.6 all backup plugin for OpenMediaVault.
      ii openmediavault-couchpotato 3.2.2 all OpenMediaVault CouchPotatoServer plugin
      ii openmediavault-docker-gui 3.1.8 amd64 OpenMediaVault plugin for Docker
      ii openmediavault-downloader 3.6.2 all OpenMediaVault downloader plugin
      ii openmediavault-keyring 1.0 all GnuPG archive keys of the OpenMediaVault archive
      ii openmediavault-omvextrasorg 3.4.26 all OMV-Extras.org Package Repositories for OpenMediaVault
      iU openmediavault-plexmediaserver 3.8.1 all OpenMediaVault Plex Media Server plugin
      ii openmediavault-remotedesktop 3.6 all Remote desktop plugin for OpenMediaVault.
      ii openmediavault-remotemount 3.0.10 all Remote mount plugin for OpenMediaVault.
      ii openmediavault-resetperms 3.3 all Reset Permissions
      ii openmediavault-snapraid 3.7.1 all snapraid plugin for OpenMediaVault.
      ii openmediavault-subsonic 3.1.1 all Subsonic is a web-based music streamer, jukebox and Podcast receiver,
      ii openmediavault-unionfilesystems 3.1.17 all Union filesystems plugin for OpenMediaVault.
      ii openmediavault-usbbackup 3.2.20 all OpenMediaVault USB/eSATA backup plugin
      ii openmediavault-virtualbox 3.0.7 all VirtualBox plugin for OpenMediaVault.


      omv-showkey plexmediaserver:

      I get no result from this command, maybe because I have plex uninstalled?

      The only thing I can think of that I was doing when this happened was trying to get the Webtools plugin working with plex.
    • The plugin is not completely installed. A dependency may be missing. What does it say when you do this command?

      apt-get -f install

      Is plexmediaserver installed?

      dpkg -l | grep plex

      Also, run this ccmmand to make sure you have a repo enabled to download the plexmediaserver package:

      apt-cache policy plexmediaserver

      The post was edited 1 time, last by tekkb ().

    • So apt-get -f install gives me this:


      root@openmediavault:~# apt-get -f install
      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
      2 not fully installed or removed.
      After this operation, 0 B of additional disk space will be used.
      Setting up plexmediaserver (1.7.5.4035-313f93718) ...
      Job for plexmediaserver.service failed. See 'systemctl status plexmediaserver.service' and 'journalctl -xn' for details.
      dpkg: error processing package plexmediaserver (--configure):
      subprocess installed post-installation script returned error exit status 1
      dpkg: dependency problems prevent configuration of openmediavault-plexmediaserver:
      openmediavault-plexmediaserver depends on plexmediaserver | plexmediaserver-installer; however:
      Package plexmediaserver is not configured yet.
      Package plexmediaserver-installer is not installed.

      dpkg: error processing package openmediavault-plexmediaserver (--configure):
      dependency problems - leaving unconfigured
      Errors were encountered while processing:
      plexmediaserver
      openmediavault-plexmediaserver
      E: Sub-process /usr/bin/dpkg returned an error code (1)


      And systemd status for plex is:
      root@openmediavault:~# systemctl status plexmediaserver.service -l
      ● plexmediaserver.service - Plex Media Server for Linux
      Loaded: loaded (/lib/systemd/system/plexmediaserver.service; enabled)
      Active: failed (Result: start-limit) since Thu 2017-08-10 06:08:32 EDT; 9min ago
      Process: 20172 ExecStartPre=/bin/sh -c /usr/bin/test -d "${PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR}" || /bin/mkdir -p "${PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR}" (code=exited, status=1/FAILURE)

      Aug 10 06:08:26 openmediavault systemd[1]: Failed to start Plex Media Server for Linux.
      Aug 10 06:08:26 openmediavault systemd[1]: Unit plexmediaserver.service entered failed state.
      Aug 10 06:08:32 openmediavault systemd[1]: plexmediaserver.service holdoff time over, scheduling restart.
      Aug 10 06:08:32 openmediavault systemd[1]: Stopping Plex Media Server for Linux...
      Aug 10 06:08:32 openmediavault systemd[1]: Starting Plex Media Server for Linux...
      Aug 10 06:08:32 openmediavault systemd[1]: plexmediaserver.service start request repeated too quickly, refusing to start.
      Aug 10 06:08:32 openmediavault systemd[1]: Failed to start Plex Media Server for Linux.
      Aug 10 06:08:32 openmediavault systemd[1]: Unit plexmediaserver.service entered failed state.




      Plexmediaserver and openmediavault-plexmediaserver still show up when I run dpkg -l | plex
      even after running apt remove plexmediaserver.

      I'm quite confused..
    • Plex is definitely uninstalled. I tried disabling the plex repo and enabling it. Also tried rebooting multiple times. Everytime I try to reinstall plex I get:

      root@openmediavault:~# apt install plexmediaserver
      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      The following NEW packages will be installed:
      plexmediaserver
      0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
      Need to get 0 B/107 MB of archives.
      After this operation, 232 MB of additional disk space will be used.
      Selecting previously unselected package plexmediaserver.
      (Reading database ... 71755 files and directories currently installed.)
      Preparing to unpack .../plexmediaserver_1.7.5.4035-313f93718_amd64.deb ...
      Unpacking plexmediaserver (1.7.5.4035-313f93718) ...
      Processing triggers for systemd (215-17+deb8u7) ...
      Processing triggers for desktop-file-utils (0.22-1) ...
      Processing triggers for mime-support (3.58) ...
      Setting up plexmediaserver (1.7.5.4035-313f93718) ...
      Created symlink from /etc/systemd/system/multi-user.target.wants/plexmediaserver.service to /lib/systemd/system/plexmediaserver.service.
      Job for plexmediaserver.service failed. See 'systemctl status plexmediaserver.service' and 'journalctl -xn' for details.
      dpkg: error processing package plexmediaserver (--configure):
      subprocess installed post-installation script returned error exit status 1
      Errors were encountered while processing:
      plexmediaserver
      E: Sub-process /usr/bin/dpkg returned an error code (1)