HP microserver Gen10

    • hp_user wrote:

      I wonder, what version of Linux is HP referring to, when they provide the A340 version for download. For sure the realtime HW thermal alert sounds interesting.
      I tried it so far under their latest ClearOS - community (free) edition, but does not work.


      It should work on any linux. I've tested debian, the updater works fine there. Just extract their ZIP file and/or any *.rpm files. While you can install RPM with alien, there's no need: The extracted files work fine without install.
      Just follow the instructions (run "Lnx/flashbios.sh") and enjoy. I've only ever done this a) from shell and b) as root, so YMMV:

      Shell-Script

      1. $ unzip System_BIOS_v_ZA10A350_for_MicroServer_Gen10_Linux.zip
      2. Archive: System_BIOS_v_ZA10A350_for_MicroServer_Gen10_Linux.zip
      3. creating: System_BIOS_v_ZA10A350_for_MicroServer_Gen10_Linux/
      4. inflating: System_BIOS_v_ZA10A350_for_MicroServer_Gen10_Linux/Instruction.txt
      5. creating: System_BIOS_v_ZA10A350_for_MicroServer_Gen10_Linux/Lnx/
      6. inflating: System_BIOS_v_ZA10A350_for_MicroServer_Gen10_Linux/Lnx/afulnx_32
      7. inflating: System_BIOS_v_ZA10A350_for_MicroServer_Gen10_Linux/Lnx/afulnx_64
      8. inflating: System_BIOS_v_ZA10A350_for_MicroServer_Gen10_Linux/Lnx/flashbios.sh
      9. inflating: System_BIOS_v_ZA10A350_for_MicroServer_Gen10_Linux/Lnx/readme32.txt
      10. inflating: System_BIOS_v_ZA10A350_for_MicroServer_Gen10_Linux/Lnx/readme32_afulnx.txt
      11. inflating: System_BIOS_v_ZA10A350_for_MicroServer_Gen10_Linux/Lnx/readme64.txt
      12. inflating: System_BIOS_v_ZA10A350_for_MicroServer_Gen10_Linux/Lnx/readme64_afulnx.txt
      13. inflating: System_BIOS_v_ZA10A350_for_MicroServer_Gen10_Linux/releasenote.txt
      14. inflating: System_BIOS_v_ZA10A350_for_MicroServer_Gen10_Linux/ZA10A350.rom
      15. $ cd System_BIOS_v_ZA10A350_for_MicroServer_Gen10_Linux/Lnx
      16. $ chmod u+x flashbios.sh afulnx_32 afulnx_64
      17. $ sudo ./flashbios.sh
      18. +---------------------------------------------------------------------------+
      19. | AMI Firmware Update Utility v5.08.02.1189 |
      20. | Copyright (C)2016 American Megatrends Inc. All Rights Reserved. |
      21. +---------------------------------------------------------------------------+
      22. Reading flash ............... done
      23. - FFS checksums ......... ok
      24. Erasing Boot Block .......... done
      25. Updating Boot Block ......... done
      26. Verifying Boot Block ........ done
      27. Erasing Main Block .......... done
      28. Updating Main Block ......... done
      29. Verifying Main Block ........ done
      30. Erasing NVRAM Block ......... done
      31. Updating NVRAM Block ........ done
      32. Verifying NVRAM Block ....... done
      33. Erasing NCB Block ........... done
      34. Updating NCB Block .......... done
      35. Verifying NCB Block ......... done
      36. $
      Display All


      On other news, HPE released a new UEFI version, I've updated the post accordingly.

      This is marked as an critical update - all users are "required" to install it.
      Two rules of success in life:
      1. Don't tell people everything you know.

      The post was edited 2 times, last by qwertz123: Added code block with flashing example. ().

    • Hello guys!

      Has any one tried to install windows7 on microserver gen10?
      I made installation USB with Rufus, and successfully booted.
      However, during the booting process, win7 installer requires some unnamed driver to continue installation.
      I downloaded AMD chip drivers from hpe site, and tried to insert drivers, but I couldn’t specify which drivers are correct.
      Please help....

      Izenizen
    • izenizen wrote:

      Hello guys!

      Has any one tried to install windows7 on microserver gen10?
      I made installation USB with Rufus, and successfully booted.
      However, during the booting process, win7 installer requires some unnamed driver to continue installation.
      I downloaded AMD chip drivers from hpe site, and tried to insert drivers, but I couldn’t specify which drivers are correct.
      Please help....

      Izenizen
      I'm sorry i think you have to test each one but W7 has it's own driver downloadable you shoult test all of them, or supply more info about it.