• OMV 3.x (stable)

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.


      • Install LDAP Plugin
      • Fill up Directory Service section
      • Open terminal and follow the instructions here at wiki.debian.org/LDAP/NSS
      • List of users and groups shows up when I type the command

      Source Code

      1. # getent passwd
      2. # getent group
      3. # ldapsearch -h <ldapserver> -b dc=<your>,dc=<domain> -x uid=<username>
      4. # /usr/sbin/omv-rpc "UserMgmt" "getUserList" '{"start":0,"limit":null,"sortfield":null,"sortdir":null}'
      5. # /usr/sbin/omv-rpc "UserMgmt" "getGroupList" '{"start":0,"limit":25,"sortfield":"name","sortdir":"ASC"}'
      • But when I logged in at WebGUI, the list of GROUP was shown but the USER would throw “Communication Failure”
      • Went to Shared Folders to check if user’s will show in ACL’s Permission and it did! Not in Privileges tho :3

      What seems to be the problem? I have tried this and that but always having trouble midway of the tutorial.

      PS: Also, I cannot access the Shares in nautilus whenever I enabled the Directory Service / LDAP.

      FreeIPA v4.04
      OMV v3.0.87 (Erasmus)
      LDAP-Plugin v3.1.6

      • Screen Shot 2017-09-06 at 4.53.03 PM.png

        31.3 kB, 419×169, viewed 60 times

      The post was edited 1 time, last by kyou ().

    • The user id does have to be above 1000 to be displayed in the web interface.
      omv 4.1.1 arrakis | 64 bit | 4.14 backports kernel | omvextrasorg 4.1.2
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please read this before posting a question.
      Please don't PM for support... Too many PMs!
    • Hi. I cannot logged in at samba share using ldap auth. Can access webgui but prompt "session not authenticated" after.

      Samba share is working fine before I configure the ldap..

      I also changed the /etc/samba/smb.conf , smbpasswd -W and systemctl restart smbd

      Source Code

      1. passdb backend = ldapsam:ldap://<ldap_ip>:389
      2. ldap suffix = dc=domain,dc=com
      3. ldap admin dn = uid=omv.nas,cn=users,cn=accounts,dc=domain,dc=com
      4. ldap user suffix = ou=Users
      5. ldap group suffix = ou=Groups
      6. ldap ssl = off
      7. ldap passwd sync = yes
      Enabled FTP and my LDAP Auth works..
      • Screen Shot 2017-10-04 at 11.06.47 AM.png

        100.76 kB, 1,366×505, viewed 96 times
      • MacOS.png

        38.03 kB, 426×282, viewed 86 times
      • Ubuntu.png

        101.14 kB, 756×539, viewed 88 times
      • Win.png

        97.16 kB, 751×519, viewed 84 times

      The post was edited 4 times, last by kyou ().