Add disk to my RAID5 array

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Add disk to my RAID5 array

      Hi guys,

      I have an OpenMediaVault NAS configured with 4 WD Red 4TB in a RAID5 array.
      I want to add 2 new disks to this array and unfortunately I cannot find how to do it.
      I physically installed the disks in the server and start the NAS.
      I click on Grow button in the RAID management tab but my disks were shown in spare in the details (below the details with one added disk, I decided to unplug the other one to perform the extension with one disk at a time...).
      I have read several posts and it seems that a command line can solve this issue (mdadm --grow...) but I don't know where to enter this command.
      If I connect a screen and a keyboard to my server I have a login line but if I enter my login and pswd the page actualize and ask me again login and pswd.
      I am a complete beginner in NAS and Linux in general so I hope that someone can help me :)

      Thank you in advance!

      Version : 1.2
      Creation Time : Fri Dec 9 01:30:37 2016
      Raid Level : raid5
      Array Size : 8790405120 (8383.18 GiB 9001.37 GB)
      Used Dev Size : 2930135040 (2794.39 GiB 3000.46 GB)
      Raid Devices : 4
      Total Devices : 5
      Persistence : Superblock is persistent

      Intent Bitmap : Internal

      Update Time : Sun Aug 27 01:12:16 2017
      State : clean
      Active Devices : 4
      Working Devices : 5
      Failed Devices : 0
      Spare Devices : 1

      Layout : left-symmetric
      Chunk Size : 512K

      Name : NASnicoOMV:Cube2 (local to host NASnicoOMV)
      UUID : f8b8f2fc:ef76fb8d:d603eeee:ca66164c
      Events : 10022

      Number Major Minor RaidDevice State
      0 8 0 0 active sync /dev/sda
      1 8 16 1 active sync /dev/sdb
      2 8 32 2 active sync /dev/sdc
      3 8 48 3 active sync /dev/sdd

      4 8 64 - spare /dev/sde
    • aemathien wrote:

      If I connect a screen and a keyboard to my server I have a login line but if I enter my login and pswd the page actualize and ask me again login and pswd.
      username: root
      password: the password you have selected for user "root" during installation of OMV

      These credentials are different from the ones you are using for the GUI (user: admin/password: different pwd)

      If you are new to Linux be very carefull with the terminal. You can create a lot of damage.
      BananaPi - armbian - OMV4.x | Asrock Q1900DC-ITX - 16GB - 2x Seagate ST3000VN000 - 1x Intenso SSD 120GB - OMV3.x 64bit
    • Users Online 1

      1 Guest