UPS service not running

    • OMV 3.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • UPS service not running

      Hi guys,

      Suddenly my UPS isn't running anymore.
      I've tried different USB port, but no luck.

      Cyber Power System CP1350AVRLCD

      Here's the log:

      Source Code

      1. Aug 30 19:54:11 server upsd[10599]: User monmaster@127.0.0.1 logged out from UPS [CP1350AVRLCD]
      2. Aug 30 19:54:11 server upsmon[10621]: upsmon parent: read
      3. Aug 30 19:54:44 server upsd[3876]: fopen /var/run/nut/upsd.pid: No such file or directory
      4. Aug 30 19:54:44 server upsd[3876]: listening on 127.0.0.1 port 3493
      5. Aug 30 19:54:44 server upsd[3876]: listening on 127.0.0.1 port 3493
      6. Aug 30 19:54:44 server upsd[3876]: Connected to UPS [CP1350AVRLCD]: usbhid-ups-CP1350AVRLCD
      7. Aug 30 19:54:44 server upsd[3876]: Connected to UPS [CP1350AVRLCD]: usbhid-ups-CP1350AVRLCD
      8. Aug 30 19:54:44 server upsd[3891]: Startup successful
      9. Aug 30 19:54:44 server upsmon[3892]: fopen /var/run/nut/upsmon.pid: No such file or directory
      10. Aug 30 19:54:44 server upsmon[3892]: UPS: CP1350AVRLCD@localhost (master) (power value 1)
      11. Aug 30 19:54:44 server upsmon[3892]: Using power down flag file /etc/killpower
      12. Aug 30 19:54:44 server upsmon[3898]: Startup successful
      13. Aug 30 19:54:44 server upsmon[3926]: Init SSL without certificate database
      14. Aug 30 19:54:44 server upsd[3891]: User monmaster@127.0.0.1 logged into UPS [CP1350AVRLCD]
      Display All

      Driver config:


      Source Code

      1. driver = usbhid-ups
      2. port = auto
      3. vendorid = 0764
      4. pollinterval = 60
      OMV v3.0
      Asus Z97-A/3.1; i3-4370
      32GB RAM Corsair Vengeance Pro
      4x3TB RAID10
    • I didn´t see any errors here. upsd and upsmon are reporting "Startup successful". What do you mean exactely?

      The messages with the missing *.pid-files, I have it in my logs also. But my UPS is running without problems.
      OMV 3.0.78 (Gray style)
      ASRock Rack C2550D4I - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1)- Fractal Design Node 304
    • What happens, if you stop the UPS service (in the plugin), save it, then enable and save it again?

      What is the answer of service --status-all |grep nut

      It should be like this, if the UPS is connected and powered on:

      [ + ] nut-client
      [ + ] nut-server
      OMV 3.0.78 (Gray style)
      ASRock Rack C2550D4I - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1)- Fractal Design Node 304

      The post was edited 1 time, last by cabrio_leo ().

    • It wouldn't let be stop service.


      Source Code

      1. Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; systemctl start collectd 2>&1' with exit code '1': Job for collectd.service failed because the control process exited with error code. See "systemctl status collectd.service" and "journalctl -xe" for details.
      This is the error when I click on the UPS service tab:



      Source Code

      1. Error #0:
      2. exception 'OMV\ExecException' with message 'Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; upsc 'CP1350C' 2>&1' with exit code '1': Error: Connection failure: Connection refused' in /usr/share/php/openmediavault/system/process.inc:175
      3. Stack trace:
      4. #0 /usr/share/openmediavault/engined/rpc/nut.inc(100): OMV\System\Process->execute(Array)
      5. #1 [internal function]: OMVRpcServiceNetworkUPSTools->getStats(NULL, Array)
      6. #2 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)
      7. #3 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('getStats', NULL, Array)
      8. #4 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Nut', 'getStats', NULL, Array, 1)
      9. #5 {main}
      10. #2 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)
      11. #3 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('getStats', NULL, Array)
      12. #4 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Nut', 'getStats', NULL, Array, 1)
      13. #5 {main}
      Display All



      Here's the result:

      Source Code

      1. [ + ] nut-client
      2. [ + ] nut-server
      OMV v3.0
      Asus Z97-A/3.1; i3-4370
      32GB RAM Corsair Vengeance Pro
      4x3TB RAID10

      The post was edited 1 time, last by tinh_x7 ().

    • tinh_x7 wrote:

      exception 'OMV\ExecException' with message 'Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; upsc 'CP1350C' 2>&1' with exit code '1': Error: Connection failure: Connection refused' in /usr/share/php/openmediavault/system/process.inc:175
      In my experience it is problematic to start or stop the UPS service in the plugin, when the UPS is not physically connected. According to the error message I would assume that the NAS is connected to the UPS via USB, but the UPS is refusing the connection.

      Did you change settings of the UPS? Did you change the communication port from USB to serial connection for example or something like that? You wrote wou have tried several USB ports (on the NAS), so for me the problem is UPS related.
      OMV 3.0.78 (Gray style)
      ASRock Rack C2550D4I - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1)- Fractal Design Node 304
    • The only thing I add to the settings were these:
      1. vendorid = 0764
      2. pollinterval = 60


      I've tried apt-get remove and purge the plugins via CLI, but it seem the GUI plugin still there.

      And now it seems the service isn't running:

      sudo service --status-all |grep nut
      [ - ]nut-client
      [ - ]nut-server
      OMV v3.0
      Asus Z97-A/3.1; i3-4370
      32GB RAM Corsair Vengeance Pro
      4x3TB RAID10

      The post was edited 3 times, last by tinh_x7 ().