OMV & Bind9 - Network issue?

    • OMV & Bind9 - Network issue?

      Hi
      since June 2017 I run an OMV Server on a HP Proliant Mini Gen8 Box.
      Everything went fine - since yesterday...

      On the OMV Box I run the following services:
      - Apple Fileshare
      - SMB (Win Fileshare)
      - Plex
      - Docker (IoBroker for Homeautomation)
      - DNS (Bind9 resolving loacl domain "myhouse.local")
      - DHCP (Getting the Zoo of Pads, Phones, Laptops, etc under control)
      - Webmin (I am used to Webmin because of my two Webservers - so I installed that one for DNS/DHCP Mgmt.)

      I do NOT run the DNS/DHCP Plugin of OMV!

      Yesterday my local Intenet Provider had a short break out due to the weather (sunken cable infrastructre down the road).

      That shouldn't bother me...

      When the Network was online again all my networks settings where gone and bind9 is now unable to resolve internaly - and that was possible until yesterday... .

      I rebooted the OMV Box because of the issue, that I could not reach it. Than the truble starts.
      During login on the terminal the "welcome" message stated, that no network interface was available. Short look with ifconfig showed only loopback and the docker network.
      Checking /etc/network/interfaces revealed an "empty" interfaces file (only loopback inside).

      I was able to startup the eth0 with IP-Address and Netmask manually and I added the "missing" configuration of eth0 (static, given IP-Address, Netmask) to the interface file.
      Also the "hosts" files was not as I left it behind. My choosen Hostname was only pointing to 127.0.0.1 and not to the given static IP-Adress.

      First Question Block:
      - What Network configuration is OMV using? The "classic" one descibed above or a more modern one like the network-manager?
      - What settings in the OMV-Webadmin change which bit in the networksettings?
      - How should I setup multiple hostnames l OMV, NS1 (Nameserver)) in OMV?
      - What could cause the described effect?

      After reboot everthing was fine and I can reach the server by it's IP Adress but NOT by its name(s).
      Bind9 is only resolving external adresses (all nessesary zones are there). DHCP is providing IP-Adresses...
      But Bind9 is NOT resolving the local adresses inside "myhouse.local"...

      Second Block:
      - What did I overlooked regarding network settings that causes the bind9 missbehaviour?
      - Where/what else to check?
      - Could it be possible that OMV got stock somewhere in writing down the configurations, crashed and leaved empty or cleaned up files behind?
      - Or is it not possible to run webmin and other stuff in parallel to OMV? (Shouldn't be an issue?)

      Regards,
      Axel