OMV 3 for ODROID-XU4/HC1/HC2/MC1

    • I've finally got this working as expected... Really enjoying the functionality of the HC1 unit.

      PLEX seems to work 90% of the time.. I've got a few issues I assume are bandwidth/transcoding related. streaming to a chromecast, so I might need to get an AppleTV for bitstreaming from x264 (4k for 265)

      Upgrading from 3 to 4 was giving me problems, but I think they were all related to the upgrade tool stopping half way, so it was in a working, but confused state...
      I'm hoping a pure 4.x installation IMG is built soon so we don't need to spend the hour plus time upgrading debian from Jessie to Stretch
    • Good morning!
      yesterday i got my new HC1. But I did not manage to boot it correct.

      - I use Etcher to flash "OMV_3_0_92_Odroidxu4_4.9.61.img.xz" to a 16GB (new) SD Card (1x time flashed with my Mac , 1x time with win7)
      - try to boot. Blue light is flashing; after some time it stop flashing ... and it boot again.
      - on DHCP Server and with Networksniffer I was not able to see any IP
      - Network Link is amber
      - I also try "Armbian_5.37_Odroidxu4_Ubuntu_xenial_next_4.9.71" (same Issue)
      Any Ideas how I can troubleshoot without a screen?
      (sorry for my bad Eng)
    • Thank you for the fast response!
      I used another Cable -> same Issue
      I used another Port on the Switch (fritzbox) -> same Issue
      I used a testnetwork with just a Router and PC -> same Issue
      I config the Switch port to use only 100mbit (then the led turn green on HC1) -> same Issue

      direct cabel between HC1 and PC nothing in wireshark.
      try to mount the SD Card on the MAC (but I think the Filesystem is not supported; hoped to see some logs)
      I was able to see two Partitions on the Card (67 MB and 860MB..)

      Hm I running out of Idea's :)

      The post was edited 1 time, last by Seb ().

    • no USB / ETH Dongle available.
      And I don't have such a serial adapter for the Board :(

      If I attach a HDD it's spinning on at the time the blue light flashing (2/3 per sec flashing)

      I see do following options:
      - Image do not have the correct NIC driver?
      - NIC of the hc1 have an Hardware Issue
      - I am stupid (what can be :) and doing something wrong

      Is ther a way without the Serial Consol to get Information out of it?
      (booting wit a Linux and check some log's)

      otherwise I will send it back to Pollin.
    • EDIT: Nevermind, problem solved by flashing the sd card again... (or maybe the odroid's sd card slot has bad contacts?). Anyway, it works now.

      Hello!

      I just signed up since I have a similar problem with my Odroid HC1 with OMV3.0.92_Odroidxu4.
      The board turns on, the blue LED lights up. After a few seconds, the LED goes out, then flashes shortly 3-4 times, then the process repeats from the beginning. Yellow Ethernet LED lights up solid and flashes only 2-3 times.

      It does not seem to be a hardware issue!
      My hardware runs perfectly fine if I use armbian's image.

      - OMV image checksum was correct, I used dd on the img file inside the archive. Did not try etcher yet.
      - Power should suffice, measured 5.05V (when HC1 was not connected) - and I did not attach a HDD yet.
      - LAN cable is fine, works on a Raspberry PI.
      - SD card is fine, as I said, it works with armbian.

      I also do not have a serial cable. Is there anything I can do to find out what's wrong with the OMV image?


      Thank you,

      elvenbone

      The post was edited 2 times, last by elvenbone ().

    • elvenbone wrote:

      I used dd on the img file inside the archive. Did not try etcher yet
      That's a great recipe to run into troubles as you did. If you again used dd I would start from scratch. It's really a pretty bad idea to just TRY to write data to an SD card WITHOUT VERIFY. Since data pretty often gets corrupted while writing it to a card (card reader problems in addition to the usual SD card problems. Only use Etcher. Always)
    • Hello there.

      I am writing this post because i need some advice. Please tkaiser give me some advice.

      I want to make a domestic NAS (max 10 concurrent connections), but i am not sure what option to choose. In this moment i have a prototype with a 'orange pi plus' running OMV 3 (armbian).
      I have a docker farm running some containers (at bootup):

      - Tor proxy.
      - BIND Open Source DNS Server.
      - Portainer.
      - Plex server.
      - ORGANIZR.

      And others not running at bootup (deluge, nbzget, etc).

      In this moment i want a solution than can run OVM and some docker containers with RAID 1+0 or preferably RAID 5 capabilities.

      I want:

      - Armbian;
      - OVM;
      - RAID 5 or 1+0;
      - min 4 GB RAM (preferably ECC);
      - ARM architecture preferably (low tdp).
      - SATA interface;
      - USB 3;
      - Gigabit interface;

      There are some premade solutions that are arriving to the market like:

      - Gnubee Personal cloud 1 and 2 -> Limited RAM and low cpu profile.
      - Helios4 -> I think 2GB of RAM ECC its not enouph for my needs.

      Some solutions i am studing:

      - A SolidRun SBC with 2 GHz (ARM OR intel) and 4GB RAM (ECC) -> Expensive.
      - ASRock motherboard with socket 1151 and a intel xeon cpu (ebay) -> Expensive and with a higher TDP.

      What is the best solution ? What are the new sbc's that will arrive on the market in 2018 that will fill my needs ?

      Can i have a stable SBC based solution ? For me its the best solution because of the low TDP.

      Thank you and best regards.

      The post was edited 1 time, last by Th3On3 ().

    • If you pull the power plug when the HC-2 is still running all sorts of strange things can happen. No good idea.

      If you properly shutdown the HC-2 and pull the plug then all your configuration will be still there. If you have no battery for your RTC it might need some time, until the HC-2 synchronises the clock after a reboot again.
      Odroid HC2 - armbian - Seagate ST4000DM004 - OMV4.x
      Asrock Q1900DC-ITX - 16GB - 2x Seagate ST3000VN000 - Intenso SSD 120GB - OMV4.x
      :!: Backup - Solutions to common problems - OMV setup videos - OMV4 Documentation - user guide :!:
    • Just to inform you..
      After some days I got a new HC1 and the Issue was still present. (some Pages back in this subject)
      [no IP request; blinking blue LED]
      thank to TKaiser!

      My last try was to replace (the new) SD Card with a different one (from my mobile)...
      And ... This one is working perfectly... (and flashing in the same way)..
      IP was requested.. OMV is now working fine!
      cool stuff.

      Now I play around with Plex and miniDLNA...
      Searching only a good "Gallery for android "
      I Rsynch only PICs to the HC1 that should be searchable and fast browse able.

      Plex look not to bad.. But I don't like the external Auth. (and the Andorid App need a plex pass)
      miniDLNA with Bubble App is ok but Image rotation and speed is not that good...
      Owncloud still need to test..

      Any suggestions what is worth a look?
    • Hi!

      I find the Odroid HC2 a very good idea for creating a small, energy saving NAS device.

      Now to my question:

      The Case is designed as stackable device. This means i can e.g. buy 2 or 4 of the HC2 devices and equip them with harddisks.

      Do i have to install omv on each of the devices ?

      How can i manage to access to all the data on the disks from one central point / interface ?

      How do you do that ?

      Thank you in advance.

      Greets Karl