Antivirus won't scan

    • OMV 3.x (stable)
    • Resolved
    • Antivirus won't scan

      I was trying to scan one of my shares with the anivirus plugin and I got an error instead. This is the very first time I try scan anything. The settings are pretty much the defaults.
      Here's the text part since I can't get all of it in the window no matter how wide I make it.

      Error #0:exception 'OMV\ExecException' with message 'Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; export SHELL=/bin/sh; sudo --shell --non-interactive -- /var/lib/openmediavault/cron.d/clamdscan-46cbfa84-ff4a-41fe-aaaa-fb49d0813bf9 2>&1' with exit code '127': /bin/sh: 1: /var/lib/openmediavault/cron.d/clamdscan-46cbfa84-ff4a-41fe-aaaa-fb49d0813bf9: not found' in /usr/share/openmediavault/engined/rpc/ trace:#0 /usr/share/php/openmediavault/rpc/ OMVRpcServiceClamAV->{closure}('/tmp/bgstatusVQ...', '/tmp/bgoutputYX...')#1 /usr/share/openmediavault/engined/rpc/ OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure))#2 [internal function]: OMVRpcServiceClamAV->executeJob(Array, Array)#3 /usr/share/php/openmediavault/rpc/ call_user_func_array(Array, Array)#4 /usr/share/php/openmediavault/rpc/ OMV\Rpc\ServiceAbstract->callMethod('executeJob', Array, Array)#5 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('ClamAV', 'executeJob', Array, Array, 1)#6 {main}
      • antivirus.PNG

        55.63 kB, 1,107×665, viewed 48 times
    • Try to rebuild the configuration via CLI


      1. # omv-mkconf clamav
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • Thank you! I tried that before stopping the service and after. Neither worked, but this was my fault. I apparently forgot to enable job after creating it. I just noticed this and changed it. Everything worked fine after that. Man, I'm feeling old today. LOL. So for those are are just starting to use this, make sure that little circle is green before you start the scan.
    • Users Online 1

      1 Guest