OpenMediaVault - ExtPlorer (rights problems..)

    • OMV 2.x
    • OpenMediaVault - ExtPlorer (rights problems..)

      Hello there.

      First of all, sorry for my english.

      I installed this week-end OpenMediaVault (omv_2.0.15_rpi_rpi2.img.gz) because someone gave me a Raspberry 1.

      Instead of taking my USB Key all the time, etc, I wanted to create a little server at home so I could access it from everywhere.

      I would also love to allow my wife's friend to share their lessons from classes instead of using anything else.

      I installed extPlorer from the plugin page.

      Problem is:

      - I can login (admin/openmediavault) to extplorer
      - I can change my password
      - I can create users
      - I can navigate

      BUT... ?(

      - I can't delete anything
      - I can't create any files/folder (so creating user is useless since I can't create any folder..)
      - I can't upload any files..
      - I can't right click / chmod any folder..

      I tried to give "extplorer" every rights there's in the list (users) but still doesn't work...

      I've been looking on Internet for hours since I started using OMV. Didn't find any good/full tutorial either.

      If any of you has a solution, i'd love it. Thanks a lot! :/

      PS: Special question if one of you knows why: I tried to install the omv_2.2.1_rpi2_rpi3.img.gz version (just to test), it worked, but It didn't create a 3rd partition with free space..

      The post was edited 1 time, last by Misurugi ().

    • Hello. Thank you for your answer.

      What can I do then? Because what's the point to have extPlorer if we can't do anything with it? There must be a solution I think? ^^

      About Groups / users, I tried this (please see files attached)

      Maybe there's another solution to access files from Internet, instead of ExtPlorer? I tried OwnCloud but it's very laggy on Rasp 1..

      Too bad there are no real tutoriels for this.
      • Capture.JPG

        18.06 kB, 334×185, viewed 251 times
      • Capture2.JPG

        34.55 kB, 408×465, viewed 186 times
    • i guess the plugin was more intended as a viewer than a full file explorer, the full root is dir is there, you can easily trash your system. You can probably hack the configuration php file socket to run as root if you want.…nf/php5fpm.d/90-extplorer

      Also rpi1 as a nas? There are better choices around these days in the arm village.
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10 broadcast channel
      openmediavault discord server
    • Misurugi wrote:

      What can I do then? Because what's the point to have extPlorer if we can't do anything with it?
      You can do something with it. By default, files on data drives should owned by the users group. The extplorer user is in the users group. So, you should be able to do something with those files. If extplorer used root, then could do something with any file but that is a problem in my opinion. That is one of the reasons I didn't port the plugin.

      Misurugi wrote:

      Maybe there's another solution to access files from Internet, instead of ExtPlorer?
      Enable ssh, open the ssh port in your firewall and use winscp. Then you can choose which user accesses the files.

      Misurugi wrote:

      Too bad there are no real tutoriels for this.
      You wouldn't be happy with any of them because a php app shouldn't run as root which means the app probably couldn't do everything you wanted.
      omv 4.1.17 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13 plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Okay so guys, I did it. Here is what I did, in case someone found this thread from Google and has the same problem.

      1st: Check what your folders/users are. I used putty and did this:

      - cd /
      - ls -la (Just in order to check all the folders and who has the rights on them (normally, you'll see only "root")
      - cut -d: -f1 /etc/passwd (You also need to check, with this. If you have "extplorer" as user. if you installed the plugin, you must have it)

      2nd: Create a new folder that will be used by extplorer. I created in the main directory a folder named "partage" (share in french), then:

      - mkdir partage (creates the folder)
      - sudo chown extplorer: partage (this line will give "extplorer" the full power on the folder "partage" (or whatever you named it). Someone on askubuntu said you could use "setfacl -m u:username:rwx myfolder" so it just sets permissions for specific users, without changing the ownership of the directory. But I didn't test it.

      3nd: Now you can create/delete/modify anything inside that "partage" folder, and only into this one. For exemple, you can create inside this one a folder name "files"

      4nd: You can now create a new user (for example "roberto") and give him "/partage/files" in "home directory" (or "home folder", I don't know the english translation), and let "http://localhost" as "root path". I gave my users "Modify & Change password"

      5nd: Open the port 443 (I created a certificate so I can use httpS) and then you can access it, from outside, with the adress
      6nd: You can now connect with roberto / hispassword, he'll only see what's inside "/partage/files" and will be able to create, delete, download, upload.. :)

      I'm just trying to help with what I did. I don't know if what I did was the good way or whatever. So like everyone on Internet i'd say "Do it on your own risk" :P If some people read this and want to add some things, or say if I did something wrong, please do it :)

      But i'm glad it FINALLY works for me!

      The post was edited 1 time, last by Misurugi ().