Plex doesn't start after update

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Plex doesn't start after update

      New

      Hi,

      I'm new to OMV, and I'm encountering troubles after Plex's last update as it do not start.

      Here's what I get from the command line when I look at plexmediaserver status:

      Source Code

      1. root@HOMENAS:~# service plexmediaserver status
      2. ● plexmediaserver.service - Plex Media Server for Linux
      3. Loaded: loaded (/lib/systemd/system/plexmediaserver.service; enabled)
      4. Drop-In: /etc/systemd/system/plexmediaserver.service.d
      5. └─db_folder.conf
      6. Active: failed (Result: start-limit) since mar. 2017-09-12 18:32:12 CEST; 2min 16s ago
      7. Process: 1049 ExecStart=/bin/sh -c LD_LIBRARY_PATH=/usr/lib/plexmediaserver "/usr/lib/plex mediaserver/Plex Media Server" (code=exited, status=127)
      8. Process: 1046 ExecStartPre=/bin/sh -c /usr/bin/test -d "${PLEX_MEDIA_SERVER_APPLICATION_SU PPORT_DIR}" || /bin/mkdir -p "${PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR}" (code=exited, st atus=0/SUCCESS)
      9. Main PID: 1049 (code=exited, status=127)
      10. sept. 12 18:32:07 HOMENAS systemd[1]: plexmediaserver.service: main process exited, co...n/a
      11. sept. 12 18:32:07 HOMENAS systemd[1]: Unit plexmediaserver.service entered failed state.
      12. sept. 12 18:32:12 HOMENAS systemd[1]: plexmediaserver.service holdoff time over, sched...rt.
      13. sept. 12 18:32:12 HOMENAS systemd[1]: Stopping Plex Media Server for Linux...
      14. sept. 12 18:32:12 HOMENAS systemd[1]: Starting Plex Media Server for Linux...
      15. sept. 12 18:32:12 HOMENAS systemd[1]: plexmediaserver.service start request repeated t...rt.
      16. sept. 12 18:32:12 HOMENAS systemd[1]: Failed to start Plex Media Server for Linux.
      17. sept. 12 18:32:12 HOMENAS systemd[1]: Unit plexmediaserver.service entered failed state.
      18. Hint: Some lines were ellipsized, use -l to show in full.
      Display All

      I'm running OMV on a USB Key.

      Thanks
    • Plex doesn't start after update

      New

      I updated from the OMV update tab.

      Don't know wether it helps but I first installed plex with command line because I had trouble making update with OMV web UI.

      Each time I tried to update from 3.086 to to 3.088 I got disconnected from the web UI with a software failure message and had to reboot the nas. After that I had plenty of errors. I tried several times to reinstall OMV, changed the USB key, tried to update with command line it was always the same result. I finally installed OMV without making last updates and installed Plex with command line to avoid new errors. Everything was working fine until I updated Plex with the web UI.

      Envoyé de mon SM-G901F en utilisant Tapatalk
    • New

      Fafa00Hoth wrote:

      So what should I do next?
      Not sure. I don't use plex and when I try to install it, it just works.
      omv 4.0.5 arrakis | 64 bit | 4.12 backports kernel | omvextrasorg 4.0.2
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • New

      mkpd wrote:

      I am just guessing but are your permissions correct for the Plex user for your plex library folder? "/usr/lib/plex mediaserver/Plex Media Server"

      Also is the folder "/usr/lib/plex mediaserver/Plex Media Server" correct for your library?
      maybe the update changed the permissions, why not?

      I had several troubles installing omv and trying to update (this never worked on my computer always had to reinstall), so I decided to change for Ubuntu Server.

      My main purpose is to have a reliable media server for my whole home, and for now it is running fine.

      I want to thank you both ryecoaaron and you for taking time to answer me.