Can't create shares on fresh install after failed upgrade

    • OMV 3.x (stable)
    • Resolved
    • Upgrade 2.x -> 3.x
    • Can't create shares on fresh install after failed upgrade

      I tried to upgrade from the last build of to Erasmus last night but due to some hiccups I decided to just go ahead and fresh install.

      I just did so and upon trying to create shares, I get the following:

      Source Code

      1. Error #0:
      2. exception 'OMV\Config\DatabaseException' with message 'Failed to execute XPath query '//system/shares/sharedfolder[uuid='fa4b1c66-ef79-11e5-87a0-0002b3a176b4']'.' in /usr/share/php/openmediavault/config/
      3. Stack trace:
      4. #0 /usr/share/openmediavault/engined/rpc/ OMV\Config\Database->get('conf.system.sha...', 'fa4b1c66-ef79-1...')
      5. #1 [internal function]: OMVRpcServiceShareMgmt->get(Array, Array)
      6. #2 /usr/share/php/openmediavault/rpc/ call_user_func_array(Array, Array)
      7. #3 /usr/share/php/openmediavault/rpc/ OMV\Rpc\ServiceAbstract->callMethod('get', Array, Array)
      8. #4 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('ShareMgmt', 'get', Array, Array, 1)
      9. #5 {main}

      I get this as soon as I click 'add' in the shared folder part of the WebGUI.


      I reinstalled again, this time I didn't even reconnect my raid arrays. This is a totally fresh install with zero config changes. I am still seeing the same error.

      I also noticed that just clicking on the Network tab in the WebGUI gives me this error as well:

      Source Code

      1. Error
      2. : The value is not an object.
      3. Error #0:
      4. exception 'OMV\Json\SchemaValidationException' with message ': The value is not an object.' in /usr/share/php/openmediavault/json/
      5. Stack trace:
      6. #0 /usr/share/php/openmediavault/json/ OMV\Json\Schema->validateObject(Array, Array, '')
      7. #1 /usr/share/php/openmediavault/json/ OMV\Json\Schema->validateType(Array, Array, '')
      8. #2 /usr/share/php/openmediavault/rpc/ OMV\Json\Schema->validate('[]')
      9. #3 /usr/share/php/openmediavault/rpc/ OMV\Rpc\ParamsValidator->validate('[]')
      10. #4 /usr/share/openmediavault/engined/rpc/ OMV\Rpc\ServiceAbstract->validateMethodParams(Array, 'rpc.common.obje...')
      11. #5 [internal function]: OMVRpcServiceZeroconf->get(Array, Array)
      12. #6 /usr/share/php/openmediavault/rpc/ call_user_func_array(Array, Array)
      13. #7 /usr/share/php/openmediavault/rpc/ OMV\Rpc\ServiceAbstract->callMethod('get', Array, Array)
      14. #8 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Zeroconf', 'get', Array, Array, 1)
      15. #9 {main}
      Display All

      I'm at a loss.

      Any ideas?

      The post was edited 1 time, last by pntless: Added note about reinstalling again and second error I found. ().

    • Users Online 1

      1 Guest