nmbd and smbd do not run at start up

    • OMV 3.x (stable)
    • nmbd and smbd do not run at start up

      I've just done a fresh install of OMV onto a USB flash drive for a mini ITX system with 2 drives. Install went fine and everything was up and running. After creating the RAID I set up my shared folders but samba was not working and the share was not appearing in smbtree. I checked through my config line for line with another I found online and couldn't find anything that'd cause it not to work. I finally, after many hours, decided to look at the processes running and noticed smbd was not there. I ran nmdb and smbd and then it finally worked and the Windows machine could access the shares. I've used crontab to run the program(s) at start up.

      The OMV web GUI of course says that SMB/GIFS is running in the services tab when it isn't. I don't know if something messed up on the install but I haven't messed with any other config files and have only installed firmware for the LAN adapter.

      EDIT: Just saw another thread about the same issue: SAMBA not starting automatically, ok if started manually

      Done the same and it fixed it also. Apologies, this thread can be locked it needed to.

      The post was edited 1 time, last by rozzy85 ().

    • Afraid not as this is my first time using OMV. I installed it using a USB-CDROM to USB flash drive. Initially set my IP to static but then realised you could do it via the web GUI and then went on to creating the RAID config. It's only a basic setup with the mini-itx board, 2 HDDs, flash drive and the LAN cable connected.