OMV 4 now in Beta but no offical news?

    • OMV 4.x
    • Resolved
    • Upgrade 3.x -> 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Volker did post this - openmediavault.org/?p=2178 That is kind of official isn't it?

      No ISO yet. OMV 3.x to 4.x upgrades work well or you could install Debian Stretch then OMV. Not all plugins are ready yet though.

      Source Code

      1. echo "deb http://packages.openmediavault.org/public arrakis main" > /etc/apt/sources.list.d/openmediavault.list
      2. apt-get update
      3. apt-get install openmediavault-keyring postfix
      4. apt-get update
      5. apt-get install openmediavault
      6. omv-initsystem
      omv 4.1.9 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.9
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Skaronator wrote:

      Saw this post already a month ago but doesn't mention, that you can already give v4 a try.
      I guess we just interpreted OMV 3.x being maintenance mode differently. Maybe he was waiting for more omv-extras plugins to be ready? "Official" posts also make lots of people upgrade. I don't think any of us are ready for that yet.
      omv 4.1.9 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.9
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • If OMV4 is ready then it will be announced, until then no blog post or other information will be announced about new packages for version 4. OMV3 is still maintained but without new features.
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • ryecoaaron wrote:

      echo "deb packages.openmediavault.org/public arrakis main" > /etc/apt/sources.list.d/openmediavault.list
      apt-get update
      apt does not allow installing from unsigned repositories, so

      Source Code

      1. echo "deb [ allow-insecure=yes ] http://packages.openmediavault.org/public arrakis main" > /etc/apt/sources.list.d/openmediavault.list
      2. apt-get update
      3. ...
      will do the trick, till 4.0.6 arrives.
      but be aware to reset it, when the repo is signed!
    • Just chiming in

      I upgraded to Arrakis yesterday. overall went well and everything is working fine, A little bumpy, collectd and rrdcached has had error in syslog but omv-mkconf took care of that. no other issues I can say were related to openmediavault

      Only issue I can report at this time is the on the webui on the services page, the running indicator for UPS is red. however NUT seems to be working normally, so no big deal. could be something I did, but worth noting

      thanks to everyone on the OMV team
    • Hi
      There is no download you can upgrade OMV3 with

      omv-release-upgrade

      Or install on a Debian 9 environment
      forum-bpi.de Visit on and help us, The Germany Forum :thumbsup:
      github.com/Wolf2000Pi
      Banana Pi /Armbian 3.4.109 / Openmediavault 2.x
      Banana Pi /Armbian 4.11.5-sunxi / Openmediavault 3.0.xx (Test)
      Dell Inspiron One 2205 | Openmediavault 3.0.xx / Kernel 4.7 (Test)
    • root@nas:~# dpkg -l | grep openm
      ii libopenmpt0:amd64 0.2.7386~beta20.3-3+deb9u2 amd64 module music library based on OpenMPT -- shared library
      ii openmediavault 4.0.8-1 all openmediavault - The open network attached storage solution
      ii openmediavault-backup 3.6 all backup plugin for OpenMediaVault.
      ii openmediavault-clamav 4.1-1 all OpenMediaVault ClamAV plugin
      rc openmediavault-extplorer 1.0.3 all OpenMediaVault eXtplorer plugin
      ii openmediavault-forkeddaapd 4.0-1 all OpenMediaVault forked-daapd (DAAP server) plugin
      ii openmediavault-keyring 1.0 all GnuPG archive keys of the OpenMediaVault archive
      ii openmediavault-minidlna 3.3.11 all OpenMediaVault miniDLNA (DLNA server) plugin
      ii openmediavault-netatalk 4.0.1-1 all OpenMediaVault netatalk (AppleTalk Protocol Suite) plugin
      ii openmediavault-omvextrasorg 4.1.0 all OMV-Extras.org Package Repositories for OpenMediaVault
      ic openmediavault-sickbeard 3.2.2 all OpenMediaVault Sick Beard plugin
      rc openmediavault-usbbackup 1.0.2 all OpenMediaVault USB/eSATA backup plugin

      Seems i have the OMV extras for 4.x i have deleting and reinstalled what i could do in GUI, don't know if there is still some issues with this list. Missing the transmission but i saw the remark about dockers, never used that so need to check that out.

      The post was edited 1 time, last by ArmandH ().

    • Hi guys,

      Is there an issue with dockers on 4.x ?
      I'm not able to get any image installed, docker gui plugin is enabled and i have used a directory called docky on my disk raid.

      root@nas:/media/fac202db-49d5-4dba-92b0-bee63109d140/docky# ls -lrt
      total 80
      drwx------+ 2 root root 4096 Nov 3 09:16 containers
      drwx------+ 4 root root 4096 Nov 3 09:16 plugins
      drwx------+ 3 root root 4096 Nov 3 09:16 image
      drwx------+ 2 root root 4096 Nov 3 09:16 volumes
      drwx------+ 2 root root 4096 Nov 3 09:16 trust
      drwxr-x---+ 3 root root 4096 Nov 3 09:16 network
      drwx------+ 2 root root 4096 Nov 3 09:16 swarm
      drwx------+ 2 root root 4096 Nov 3 09:16 builder
      drwx------+ 2 root root 4096 Nov 3 09:16 tmp
      drwx------+ 3 root root 4096 Nov 3 09:16 overlay2

      As you see the framework has been copied well, but when i search for example for transmission i get the popup but when pressing start i only see a fast refresh of the dock page and the popup start button of transmission come back, nothing installed. Can this be a rights issue?

      UPDATE: i tried chmod -R 777 docky , still no luck, nothing able to pull

      CLI test works and after doing this on CLI it shows up in the GUI, but i'm not able to pull anything in GUI, don't know if this is an 4.x issue or known issue, not able to find info, any help appreciated.

      root@nas:/media/fac202db-49d5-4dba-92b0-bee63109d140/docky# docker run hello-world
      Unable to find image 'hello-world:latest' locally
      latest: Pulling from library/hello-world
      5b0f327be733: Pull complete
      Digest: sha256:175735360662078abd70dacb73c5518d5b3ae7c1ed069d22def5da57c3e917d6
      Status: Downloaded newer image for hello-world:latest


      Hello from Docker!
      This message shows that your installation appears to be working correctly.


      To generate this message, Docker took the following steps:
      1. The Docker client contacted the Docker daemon.
      2. The Docker daemon pulled the "hello-world" image from the Docker Hub.
      3. The Docker daemon created a new container from that image which runs the
      executable that produces the output you are currently reading.
      4. The Docker daemon streamed that output to the Docker client, which sent it
      to your terminal.


      To try something more ambitious, you can run an Ubuntu container with:
      $ docker run -it ubuntu bash


      Share images, automate workflows, and more with a free Docker ID:
      cloud.docker.com/


      For more examples and ideas, visit:
      docs.docker.com/engine/userguide/

      The post was edited 3 times, last by ArmandH ().