Protocol "http" not supported or disabled in libcurl

    • OMV 3.x (stable)

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Protocol "http" not supported or disabled in libcurl

      Ok so had to do a complete reformat , everything setup sound untill i i try and install emby vai cmd line as there is no app Protocol "http" not supported or disabled in libcurl, could this be a bug OMV 3.0.86

      Tried to reinstall curl etc but nothing works.

      Regards

      #m
    • OMV is Debian and OMV doesn't even install curl. This isn't an OMV problem. I just tried on a system and http works fine. If you have a .netrc setup, it will *warn* you about no protocol but it shouldn't stop it from working.
      omv 4.0.16 arrakis | 64 bit | 4.14 backports kernel | omvextrasorg 4.1.2
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • Hi no .netrc , all i am doing is , fresh install of 3.0.88 , update OMV setup shares then apt-get install emby-server , now under each http url it goes to get a download file as there are 207 mono/emby etc it gives me that error .

      Cant be a bad install no as it gets all the apt-get update / upgrade files ok , im lost , i get that OMV does not install curl but i must be doing something wrong (even though this is the same steps i have taken on ONV for ages
    • It doesn't help that you have the mono-project repo enabled but I don't know why you have http disabled. What kind of system? What is the output of: dpkg -l | grep -E "curl|apt"
      omv 4.0.16 arrakis | 64 bit | 4.14 backports kernel | omvextrasorg 4.1.2
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • Source Code

      1. root@openmediavault:~# dpkg -l | grep -E "curl|apt"
      2. ii apt 1.0.9.8.4 amd64 commandline package manager
      3. ii apt-transport-https 1.0.9.8.4 amd64 https download transport for APT
      4. ii apt-utils 1.0.9.8.4 amd64 package management related utility programs
      5. ii cron-apt 0.9.2 all automatic update of packages using apt-get
      6. ii firmware-myricom 20161130-3~bpo8+1 all Binary firmware for Myri-10G Ethernet adapters
      7. ii firmware-realtek 20161130-3~bpo8+1 all Binary firmware for Realtek wired/wifi/BT adapters
      8. ii firmware-ti-connectivity 20161130-3~bpo8+1 all Binary firmware for TI Connectivity wifi and BT/FM/GPS adapters
      9. ii libapt-inst1.5:amd64 1.0.9.8.4 amd64 deb package format runtime library
      10. ii libapt-pkg4.12:amd64 1.0.9.8.4 amd64 package management runtime library
      11. ii libcurl3-gnutls:amd64 7.38.0-4+deb8u5 amd64 easy-to-use client-side URL transfer library (GnuTLS flavour)
      12. ii python-apt-common 0.9.3.12 all Python interface to libapt-pkg (locales)
      13. ii python3-apt 0.9.3.12 amd64 Python 3 interface to libapt-pkg
      14. root@openmediavault:~#
      Display All
      Linux openmediavault 4.9.0-0.bpo.3-amd64 #1 SMP Debian 4.9.30-2+deb9u2~bpo8+1 (2017-06-27) x86_64 GNU/Linux
      Intel Core 2 4400 2Ghz
      4GB DDR

      Never had this before , the mono comes from download.opensuse.org/repositories i do not have its own repo installed everything emby needs to run comes from download.opensuse.org/repositories
    • Other than the main curl package not being installed, I don't see any differences. Try installing curl - apt-get install curl
      omv 4.0.16 arrakis | 64 bit | 4.14 backports kernel | omvextrasorg 4.1.2
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • Hi

      Output is

      Source Code

      1. root@openmediavault:~# dpkg --verify | egrep -v -i "/etc/|/boot/|cache"
      2. ??5?????? /lib/systemd/system/sickbeard.service
      3. ??5?????? /var/lib/smartmontools/drivedb/drivedb.h
      4. ??5?????? /lib/firmware/iwlwifi-8000C-22.ucode
      5. ??5?????? /usr/lib/python2.7/config-x86_64-linux-gnu/libpython2.7.a
    • markeagles4 wrote:

      /usr/lib/python2.7/config-x86_64-linux-gnu/libpython2.7.a

      This file listed as modified doesn't look right. Can you please post output from

      Source Code

      1. ldd /usr/lib/python2.7/config-x86_64-linux-gnu/libpython2.7.a
      2. dpkg -S /usr/lib/python2.7/config-x86_64-linux-gnu/libpython2.7.a
      The 2nd call will name the package libpython2.7.a is part of, I would try to reinstall this package anyway and then check again.

      Ah, 'reinstalling' might involve downloading the package from the appropriate server and using 'dpkg -i' then. A web search for 'debian jessie libpython2.7 amd64 download' should do the job...
    • Ok so now

      Source Code

      1. root@openmediavault:~# ldd /usr/lib/python2.7/config-x86_64-linux-gnu/libpython2.7.a
      2. not a dynamic executable


      Source Code

      1. root@openmediavault:~# dpkg -S /usr/lib/python2.7/config-x86_64-linux-gnu/libpython2.7.a
      2. libpython2.7-dev:amd64: /usr/lib/python2.7/config-x86_64-linux-gnu/libpython2.7.a
      Will try and reinstall package now