OMV2 -> OMV3 -> OMV4 Upgrade - little bug and fix

    • OMV 4.x
    • Resolved
    • Upgrade 3.x -> 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • OMV2 -> OMV3 -> OMV4 Upgrade - little bug and fix

      Hi!

      Have a little box to play around. That box was still on OMV2.
      As I wanted to test OMV4 I decided to Upgrade it from 2 to 3 to 4.
      Went pretty good - just the last upgrade step - from 3 to 4 had a little problem.

      After a reboot I got the "502 Bad Gateway" error.

      After a quick look in the logs I discovered that nginx is trying to access php-fpm on a wrong socket.

      The file /etc/nginx/sites-available/openmediavault-webgui references to

      fastcgi_pass unix:/var/run/php-fpm5-openmediavault-webgui.sock
      after the upgrade. But it should reference to
      fastcgi_pass unix:/var/run/php-fpm-openmediavault-webgui.sock

      instead.

      Don't know where this happened on that upgrade path - but as OMV3 was accessible pretty normal I think it happened on the update from 3 to 4.

      regards
      Lukas
    • Just for the record. Did an upgrade from 3.0.88 to 4.0.5 on a RPi which worked flawlessly itself. After reboot "502 Bad Gateway" error when trying to access the UI. The above was not the culprit since:

      Source Code

      1. root@raspberrypi:~# grep fastcgi_pass /etc/nginx/sites-available/openmediavault-webgui
      2. fastcgi_pass unix:/var/run/php5-fpm-openmediavault-webgui.sock;


      I then simply called omv-firstaid --> Configure web control panel --> No settings change --> ok, web UI works now. Since I'm an idiot I forgot to make a snapshot to compare before/after. So asking for guidance now, maybe omv-firstaid keeps a log of changes?

      Edit: At least parts of the brain work still so I did the same again after omv-firstaid and now it looks like this:

      Source Code

      1. root@raspberrypi:~# grep fastcgi_pass /etc/nginx/sites-available/openmediavault-webgui
      2. fastcgi_pass unix:/var/run/php-fpm-openmediavault-webgui.sock;
    • tkaiser wrote:

      After reboot "502 Bad Gateway" error when trying to access the UI
      This is fixed in 4.0.6 - github.com/openmediavault/open…d37cb6e853ef57bb8bff1fe75. omv-mkconf nginx is basically called by omv-firstaid which corrects sock line you found.
      omv 4.1.11 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • I just upgraded from OMV3 to OMV4, and I tried with above methods, but still can't access to the webpage.
      It showing a blank page.



      Source Code

      1. sudo omv-mkconf nginx
      2. Site configuration file 'openmediavault-pxe' is already enabled.
      Edit: I uninstalled Pxe, still same issue.
      OMV v4.0
      Asus Z97-A/3.1; i3-4370
      32GB RAM Corsair Vengeance Pro
      4x3TB RAID10