script not working after sabnzb upgrade

    • OMV 2.x
    • script not working after sabnzb upgrade

      New problem after upgrade to latest version of Sabnzb. The script no longer processes my TV downloads. I get the following error message in my sabnzb details page:

      Exit(-1) Cannot run script /media/nasdisk/Storage/downloads/scripts/

      I haven't made any changes to my setup, the scripts are in the right place, and have the right permissions. Don't know why this is no longer working. Any ideas??
    • Bit more info. From the log:

      2017-10-02 21:27:29,726::DEBUG::[newsunpack:189] Failed script /media/nasdisk/Storage/downloads/scripts/, Traceback:
      Traceback (most recent call last):
      File "/opt/SABnzbd/<USERNAME>/", line 166, in external_processing
      startupinfo=stup, env=env, creationflags=creationflags)
      File "/usr/lib/python2.7/", line 679, in __init__
      errread, errwrite)
      File "/usr/lib/python2.7/", line 1259, in _execute_child
      raise child_exception
      OSError: [Errno 13] Permission denied

      Here is the output when I run ls -la on the scripts files:

      drwxrwxrwx+ 3 nobody nogroup 4096 Oct 4 2014 .
      drwxrwxrwx+ 7 nobody nogroup 4096 Sep 8 2013 ..
      -rwxrwxrwx+ 1 root root 83 Sep 8 2013 autoProcessTV.cfg
      -rwxrwxrwx+ 1 root root 3134 Sep 8 2013
      -rwxrwxrwx+ 1 sabnzbd users 3101 Oct 4 2014 autoProcessTV.pyc
      drwxrwxrwx+ 2 nobody nogroup 4096 Sep 8 2013 backupsofolkd
      -rwxrwxrwx+ 1 root root 979 Sep 8 2013
      -rwxrwxrwx+ 1 root root 1051 Oct 2 21:51

      The post was edited 2 times, last by yds: more info ().

    • It appears it is mounted as noexec.

      /dev/md127 on /media/nasdisk type ext4 (rw,noexec,relatime,user_xattr,acl,barrier=1,stripe=384,data=ordered,jqfmt=vfsv0,usrjquota=aquota.user,,_netdev)

      I haven't made any changes to the disk or mount since I did the sabnzbd upgrade, so not sure why access the the scripts would have changed.

      The disk is a raid array. How do I go about changing it to automatically mount with exec privileges?
    • So instead of changing the media drive to mount with exec, I instead copied over the sab scripts to my /usr/local/bin directory (as was another suggestion in the link in my previous post. Made sure they had full execute permissions. Did a test, and worked.

      I'd still like to know what could have possible changed by my upgrade of Sabnzb. I had used the scripts in the directory on my \media mount for years, and never had an issue. Surely the Sabnzb upgrade didn't cause permissions on the \medal to be changed??
    • subzero79 wrote:

      How’s that possible that your disk is mounted as /media/nasdisk? And not uuid or dev-disk-byid-label?
      Yes, it actually does have a uuid, not what I show as "nasdisk". I just replaced my uuid long string in my previous posts with "nasdisk" in its place for brevity. Sorry if this threw you off.

      I don't understand your second post though. I haven't done any manual mounting (not that I recall anyway). The output I showed above is that OMV gave me after running the "mount" command on the commandline.
    • Ok. I understand. The noexec flag has been around for quite some time.
      Maybe sabnzb changed how it executed the scripts. Calling it directly from the file.
      I know this can happen in shell, where the file has no execution but if you run

      /bin/sh -x it will still run the commands inside. You can find many answers on this in stackoverflow or serverfault I don’t if that’s the case for python, since I really don’t use it.
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10 broadcast channel
      openmediavault discord server
    • Users Online 1

      1 Guest