Suddenly OMV 3 needs 5 mins to boot

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Suddenly OMV 3 needs 5 mins to boot

      Hi!

      Suddenly i got a problem with my OMV build. Everything was working just fine until yesterday.

      Now my System needs nearly 5 minutes to boot up. After booting I got 2 mails from OMV...

      First:

      Source Code

      1. Does not exist Service collectd
      2. Date: Wed, 18 Oct 2017 07:47:10
      3. Action: restart
      4. Host: openmediavault
      5. Description: process is not running
      6. Your faithful employee,
      7. Monit

      Second:

      Source Code

      1. Execution failed Service collectd
      2. Date: Wed, 18 Oct 2017 07:47:40
      3. Action: alert
      4. Host: openmediavault
      5. Description: failed to start (exit status 0) -- no output
      6. Your faithful employee,
      7. Monit
      I attached Boot and Syslog!

      If you need any infos...pls let me know.

      Hope to get this fixed.

      From Suspend the system is online within a few seconds.

      The Pictures show the boot process and the time it stands still



      Files
      • boot.txt

        (169.9 kB, downloaded 21 times, last: )
      • syslog.zip

        (80.62 kB, downloaded 14 times, last: )

      The post was edited 1 time, last by epicfail ().

    • Seems the problem is not fixed yet. Again, my rig, needs 5 mins to boot up.

      Tried to reconfigure the network interface with omv-firstaid...got an error message

      Source Code

      1. ERROR: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; systemctl start 'networking' 2>&1' with exit code '1': Job for networking.service failed because the control process exited with error code.
      2. See "systemctl status networking.service" and "journalctl -xe" for details.


      Output of the two files mentioned above

      Source Code

      1. root@openmediavault:~# systemctl status networking.service
      2. ● networking.service - Raise network interfaces
      3. Loaded: loaded (/lib/systemd/system/networking.service; enabled; vendor preset: enabled)
      4. Drop-In: /run/systemd/generator/networking.service.d
      5. └─50-insserv.conf-$network.conf
      6. Active: failed (Result: exit-code) since Don 2017-10-19 11:10:02 CEST; 1min 51s ago
      7. Docs: man:interfaces(5)
      8. Main PID: 14300 (code=exited, status=1/FAILURE)
      9. Okt 19 11:10:02 openmediavault dhclient[14321]: DHCPACK from 192.168.1.1
      10. Okt 19 11:10:02 openmediavault ifup[14300]: RTNETLINK answers: File exists
      11. Okt 19 11:10:02 openmediavault ifup[14300]: bound to 192.168.1.105 -- renewal in 2147483648 seconds.
      12. Okt 19 11:10:02 openmediavault ifup[14300]: ifquery: recursion detected for interface eth0 in post-up phase
      13. Okt 19 11:10:02 openmediavault ifup[14300]: run-parts: /etc/network/if-up.d/openmediavault-issue exited with return code 1
      14. Okt 19 11:10:02 openmediavault ifup[14300]: Failed to bring up eth0.
      15. Okt 19 11:10:02 openmediavault systemd[1]: networking.service: Main process exited, code=exited, status=1/FAILURE
      16. Okt 19 11:10:02 openmediavault systemd[1]: Failed to start Raise network interfaces.
      17. Okt 19 11:10:02 openmediavault systemd[1]: networking.service: Unit entered failed state.
      18. Okt 19 11:10:02 openmediavault systemd[1]: networking.service: Failed with result 'exit-code'.
      Display All

      Source Code

      1. root@openmediavault:~# journalctl -xe
      2. Okt 19 11:10:02 openmediavault ifup[14300]: Failed to bring up eth0.
      3. Okt 19 11:10:02 openmediavault systemd[1]: Reloading.
      4. Okt 19 11:10:02 openmediavault systemd[1]: networking.service: Main process exited, code=exited, status=1/FAILURE
      5. Okt 19 11:10:02 openmediavault systemd[1]: Failed to start Raise network interfaces.
      6. -- Subject: Unit networking.service has failed
      7. -- Defined-By: systemd
      8. -- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
      9. --
      10. -- Unit networking.service has failed.
      11. --
      12. -- The result is failed.
      13. Okt 19 11:10:02 openmediavault systemd[1]: networking.service: Unit entered failed state.
      14. Okt 19 11:10:02 openmediavault systemd[1]: networking.service: Failed with result 'exit-code'.
      15. Okt 19 11:10:02 openmediavault /omv-firstaid[13780]: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export
      16. See "systemctl status networking.service" and "journalctl -xe" for details.
      17. Okt 19 11:10:08 openmediavault sshd[12738]: pam_unix(sshd:session): session closed for user root
      18. Okt 19 11:10:28 openmediavault monit[2622]: 'collectd' failed to start (exit status 0) -- no output
      19. Okt 19 11:10:28 openmediavault postfix/smtpd[13765]: connect from localhost[127.0.0.1]
      20. Okt 19 11:10:28 openmediavault postfix/smtpd[13765]: EF5B71C: client=localhost[127.0.0.1]
      21. Okt 19 11:10:29 openmediavault postfix/cleanup[13767]: EF5B71C: message-id=<1508404228.2095082435@openmediavault>
      22. Okt 19 11:10:29 openmediavault postfix/qmgr[13639]: EF5B71C: from=<nas.openmediavault@gmx.at>, size=731, nrcpt=2 (queue active)
      23. Okt 19 11:10:29 openmediavault postfix/smtpd[13765]: disconnect from localhost[127.0.0.1]
      24. Okt 19 11:10:29 openmediavault postfix/pipe[13768]: EF5B71C: to=<openmediavault-notification@localhost.localdomain>, relay=omvnotificationfilter, delay=0.08, de
      25. Okt 19 11:10:29 openmediavault postfix/smtp[13732]: EF5B71C: replace: header Subject: monit alert -- Execution failed collectd: Subject: [Openmediavault.local]
      26. Okt 19 11:10:30 openmediavault postfix/smtp[13732]: EF5B71C: to=<michael.brunner@sbg.at>, relay=mail.gmx.at[212.227.17.168]:587, delay=1.1, delays=0.05/0/0.77/0
      27. Okt 19 11:10:30 openmediavault postfix/qmgr[13639]: EF5B71C: removed
      28. Okt 19 11:10:59 openmediavault monit[2622]: 'collectd' process is not running
      29. Okt 19 11:10:59 openmediavault monit[2622]: 'collectd' trying to restart
      30. Okt 19 11:10:59 openmediavault monit[2622]: 'collectd' start: '/bin/systemctl start collectd'
      31. Okt 19 11:11:01 openmediavault CRON[14496]: pam_unix(cron:session): session opened for user root by (uid=0)
      32. Okt 19 11:11:01 openmediavault CRON[14497]: (root) CMD ( test -x /usr/sbin/wakealarm && /usr/sbin/wakealarm > /dev/null 2>&1)
      33. Okt 19 11:11:01 openmediavault wakealarm[14498]: INFO - Current alarm: 2017-10-22 18:00:00
      34. Okt 19 11:11:01 openmediavault wakealarm[14498]: INFO - Next alarm: 2017-10-22 18:00:00
      35. Okt 19 11:11:01 openmediavault wakealarm[14498]: WARNING - No alarm to be set.
      36. Okt 19 11:11:01 openmediavault CRON[14496]: pam_unix(cron:session): session closed for user root
      37. Okt 19 11:11:29 openmediavault monit[2622]: 'collectd' failed to start (exit status 0) -- no output
      38. Okt 19 11:11:53 openmediavault sshd[14509]: Accepted publickey for root from 192.168.1.100 port 64680 ssh2: RSA 02:34:ec:9c:71:e3:9d:8b:99:88:23:df:45:c6:04:ec
      39. Okt 19 11:11:53 openmediavault sshd[14509]: pam_unix(sshd:session): session opened for user root by (uid=0)
      40. Okt 19 11:11:59 openmediavault monit[2622]: 'collectd' process is not running
      41. Okt 19 11:11:59 openmediavault monit[2622]: 'collectd' trying to restart
      42. Okt 19 11:11:59 openmediavault monit[2622]: 'collectd' start: '/bin/systemctl start collectd'
      43. Okt 19 11:12:01 openmediavault CRON[14525]: pam_unix(cron:session): session opened for user root by (uid=0)
      44. Okt 19 11:12:01 openmediavault CRON[14526]: (root) CMD ( test -x /usr/sbin/wakealarm && /usr/sbin/wakealarm > /dev/null 2>&1)
      45. Okt 19 11:12:01 openmediavault wakealarm[14527]: INFO - Current alarm: 2017-10-22 18:00:00
      46. Okt 19 11:12:01 openmediavault wakealarm[14527]: INFO - Next alarm: 2017-10-22 18:00:00
      47. Okt 19 11:12:01 openmediavault wakealarm[14527]: WARNING - No alarm to be set.
      48. Okt 19 11:12:01 openmediavault CRON[14525]: pam_unix(cron:session): session closed for user root
      49. lines 1471-1517/1517 (END)
      Display All
      Is there a way to reinstall openmediavault without losing my config? Or anything else to fix this problem.
    • filledk wrote:

      what happens if you run command:

      ifconfig

      ????

      Source Code

      1. root@openmediavault:~# ifconfig
      2. docker0 Link encap:Ethernet Hardware Adresse 02:42:7d:21:98:de
      3. inet Adresse:172.17.0.1 Bcast:0.0.0.0 Maske:255.255.0.0
      4. UP BROADCAST MULTICAST MTU:1500 Metrik:1
      5. RX packets:0 errors:0 dropped:0 overruns:0 frame:0
      6. TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
      7. Kollisionen:0 Sendewarteschlangenlänge:0
      8. RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
      9. eth0 Link encap:Ethernet Hardware Adresse d0:50:99:22:9b:86
      10. inet Adresse:192.168.1.105 Bcast:192.168.1.255 Maske:255.255.255.0
      11. UP BROADCAST RUNNING MULTICAST MTU:1500 Metrik:1
      12. RX packets:6215342 errors:0 dropped:0 overruns:0 frame:0
      13. TX packets:15806913 errors:0 dropped:0 overruns:0 carrier:0
      14. Kollisionen:0 Sendewarteschlangenlänge:1000
      15. RX bytes:4742126946 (4.4 GiB) TX bytes:22330633169 (20.7 GiB)
      16. lo Link encap:Lokale Schleife
      17. inet Adresse:127.0.0.1 Maske:255.0.0.0
      18. inet6-Adresse: ::1/128 Gültigkeitsbereich:Maschine
      19. UP LOOPBACK RUNNING MTU:65536 Metrik:1
      20. RX packets:40218 errors:0 dropped:0 overruns:0 frame:0
      21. TX packets:40218 errors:0 dropped:0 overruns:0 carrier:0
      22. Kollisionen:0 Sendewarteschlangenlänge:1
      23. RX bytes:21984490 (20.9 MiB) TX bytes:21984490 (20.9 MiB)
      Display All
      This is the output when the NAS is running.
    • Disabled Docker and its still the same.... ;(

      Inside of the interfaces file:

      Source Code

      1. # The loopback network interface
      2. auto lo
      3. iface lo inet loopback
      4. # eth0 network interface
      5. auto eth0
      6. allow-hotplug eth0
      7. iface eth0 inet dhcp
      8. pre-down ethtool -s $IFACE wol g
      9. iface eth0 inet6 manual
      10. pre-down ip -6 addr flush dev $IFACE
      Display All
      As attachment the actual boot and syslog...also again got 2 mails regarding collectd....see first post.
      Files
      • boot.txt

        (145.51 kB, downloaded 16 times, last: )
      • syslog.zip

        (63.48 kB, downloaded 13 times, last: )
    • Then i get this:

      Source Code

      1. Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; systemctl start 'networking' 2>&1' with exit code '1': Job for networking.service failed because the control process exited with error code. See "systemctl status networking.service" and "journalctl -xe" for details.



      Details:

      Source Code

      1. Fehler #0:
      2. exception 'OMV\ExecException' with message 'Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; systemctl start 'networking' 2>&1' with exit code '1': Job for networking.service failed because the control process exited with error code.
      3. See "systemctl status networking.service" and "journalctl -xe" for details.' in /usr/share/php/openmediavault/system/process.inc:175
      4. Stack trace:
      5. #0 /usr/share/php/openmediavault/system/systemctl.inc(86): OMV\System\Process->execute(Array, 1)
      6. #1 /usr/share/php/openmediavault/system/systemctl.inc(146): OMV\System\SystemCtl->exec('start', NULL, false)
      7. #2 /usr/share/openmediavault/engined/module/networking.inc(44): OMV\System\SystemCtl->start()
      8. #3 /usr/share/openmediavault/engined/rpc/config.inc(194): OMVModuleNetworking->startService()
      9. #4 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)
      10. #5 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)
      11. #6 /usr/share/php/openmediavault/rpc/serviceabstract.inc(150): OMV\Rpc\ServiceAbstract->callMethod('applyChanges', Array, Array)
      12. #7 /usr/share/php/openmediavault/rpc/serviceabstract.inc(528): OMV\Rpc\ServiceAbstract->OMV\Rpc\{closure}('/tmp/bgstatusAA...', '/tmp/bgoutputDO...')
      13. #8 /usr/share/php/openmediavault/rpc/serviceabstract.inc(151): OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure))
      14. #9 /usr/share/openmediavault/engined/rpc/config.inc(213): OMV\Rpc\ServiceAbstract->callMethodBg('applyChanges', Array, Array)
      15. #10 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array)
      16. #11 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)
      17. #12 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('applyChangesBg', Array, Array)
      18. #13 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Config', 'applyChangesBg', Array, Array, 1)
      19. #14 {main}
      Display All

      Output of the 2 files:

      Source Code

      1. root@openmediavault:~# systemctl status networking.service
      2. ● networking.service - Raise network interfaces
      3. Loaded: loaded (/lib/systemd/system/networking.service; enabled; vendor preset: enabled)
      4. Drop-In: /run/systemd/generator/networking.service.d
      5. └─50-insserv.conf-$network.conf
      6. Active: failed (Result: exit-code) since Mon 2017-10-23 15:08:16 CEST; 1min 28s ago
      7. Docs: man:interfaces(5)
      8. Main PID: 6622 (code=exited, status=1/FAILURE)
      9. Okt 23 15:08:16 openmediavault systemd[1]: Starting Raise network interfaces...
      10. Okt 23 15:08:16 openmediavault ifup[6622]: RTNETLINK answers: File exists
      11. Okt 23 15:08:16 openmediavault ifup[6622]: Failed to bring up eth0.
      12. Okt 23 15:08:16 openmediavault systemd[1]: networking.service: Main process exited, code=exited, status=1/FAILURE
      13. Okt 23 15:08:16 openmediavault systemd[1]: Failed to start Raise network interfaces.
      14. Okt 23 15:08:16 openmediavault systemd[1]: networking.service: Unit entered failed state.
      15. Okt 23 15:08:16 openmediavault systemd[1]: networking.service: Failed with result 'exit-code'.
      Display All

      Brainfuck Source Code

      1. root@openmediavault:~# journalctl -xe
      2. -- Unit networking.service has begun starting up.
      3. Okt 23 15:08:16 openmediavault ifup[6622]: RTNETLINK answers: File exists
      4. Okt 23 15:08:16 openmediavault ifup[6622]: Failed to bring up eth0.
      5. Okt 23 15:08:16 openmediavault systemd[1]: Reloading.
      6. Okt 23 15:08:16 openmediavault systemd[1]: networking.service: Main process exited, code=exited, status=1/FAILURE
      7. Okt 23 15:08:16 openmediavault systemd[1]: Failed to start Raise network interfaces.
      8. -- Subject: Unit networking.service has failed
      9. -- Defined-By: systemd
      10. -- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
      11. --
      12. -- Unit networking.service has failed.
      13. --
      14. -- The result is failed.
      15. Okt 23 15:08:16 openmediavault systemd[1]: networking.service: Unit entered failed state.
      16. Okt 23 15:08:16 openmediavault systemd[1]: networking.service: Failed with result 'exit-code'.
      17. Okt 23 15:08:36 openmediavault monit[2511]: 'collectd' process is not running
      18. Okt 23 15:08:36 openmediavault monit[2511]: 'collectd' trying to restart
      19. Okt 23 15:08:36 openmediavault monit[2511]: 'collectd' start: '/bin/systemctl start collectd'
      20. Okt 23 15:09:01 openmediavault logger[6714]: autoshutdown[2419]: INFO: '------------------------------------------------------'
      21. Okt 23 15:09:01 openmediavault logger[6716]: autoshutdown[2419]: INFO: ' new supervision cycle started - check active hosts or processes'
      22. Okt 23 15:09:01 openmediavault logger[6722]: autoshutdown[2419]: INFO: ' Checking the time: stay up or shutdown ...'
      23. Okt 23 15:09:01 openmediavault logger[6724]: autoshutdown[2419]: INFO: ' System is in Shutdown-Range. Do further checks ...'
      24. Okt 23 15:09:01 openmediavault logger[6727]: autoshutdown[2419]: INFO: ' retrieve list of active IPs for 'eth0' ...'
      25. Okt 23 15:09:01 openmediavault CRON[6734]: pam_unix(cron:session): session opened for user root by (uid=0)
      26. Okt 23 15:09:01 openmediavault CRON[6733]: pam_unix(cron:session): session opened for user root by (uid=0)
      27. Okt 23 15:09:01 openmediavault CRON[6735]: (root) CMD ( test -x /usr/sbin/wakealarm && /usr/sbin/wakealarm > /dev/null 2>&1)
      28. Okt 23 15:09:01 openmediavault CRON[6736]: (root) CMD ( [ -x /usr/lib/php5/sessionclean ] && /usr/lib/php5/sessionclean)
      29. Okt 23 15:09:01 openmediavault wakealarm[6738]: INFO - Current alarm: 2017-10-29 18:00:00
      30. Okt 23 15:09:01 openmediavault wakealarm[6738]: INFO - Next alarm: 2017-10-29 18:00:00
      31. Okt 23 15:09:01 openmediavault wakealarm[6738]: WARNING - No alarm to be set.
      32. Okt 23 15:09:01 openmediavault CRON[6733]: pam_unix(cron:session): session closed for user root
      33. Okt 23 15:09:01 openmediavault CRON[6734]: pam_unix(cron:session): session closed for user root
      34. Okt 23 15:09:02 openmediavault logger[6782]: autoshutdown[2419]: INFO: ' Found IP 192.168.1.100 as active host.'
      35. Okt 23 15:09:02 openmediavault logger[6784]: autoshutdown[2419]: INFO: ' sleep for 600s.'
      36. Okt 23 15:09:06 openmediavault monit[2511]: 'collectd' failed to start (exit status 0) -- no output
      37. Okt 23 15:09:35 openmediavault sshd[6795]: Accepted publickey for root from 192.168.1.100 port 62755 ssh2: RSA 02:34:ec:9c:71:e3:9d:8b:99:88:23:df:45:c6:04:ec
      38. Okt 23 15:09:35 openmediavault sshd[6795]: pam_unix(sshd:session): session opened for user root by (uid=0)
      39. Okt 23 15:09:36 openmediavault monit[2511]: 'collectd' process is not running
      40. Okt 23 15:09:36 openmediavault monit[2511]: 'collectd' trying to restart
      41. Okt 23 15:09:36 openmediavault monit[2511]: 'collectd' start: '/bin/systemctl start collectd'
      42. Okt 23 15:10:01 openmediavault CRON[6815]: pam_unix(cron:session): session opened for user root by (uid=0)
      43. Okt 23 15:10:01 openmediavault CRON[6816]: (root) CMD ( test -x /usr/sbin/wakealarm && /usr/sbin/wakealarm > /dev/null 2>&1)
      44. Okt 23 15:10:01 openmediavault wakealarm[6817]: INFO - Current alarm: 2017-10-29 18:00:00
      45. Okt 23 15:10:01 openmediavault wakealarm[6817]: INFO - Next alarm: 2017-10-29 18:00:00
      46. Okt 23 15:10:01 openmediavault wakealarm[6817]: WARNING - No alarm to be set.
      47. Okt 23 15:10:01 openmediavault CRON[6815]: pam_unix(cron:session): session closed for user root
      48. Okt 23 15:10:07 openmediavault monit[2511]: 'collectd' failed to start (exit status 0) -- no output
      Display All
    • Logs don't say much about what's going on, could be the card failing or maybe the kernel module r8169 is not working properly.

      You can try and install the official realtek driver (r8168) instead of using the kernel tree one (r8169)

      unixblogger.com/2016/08/11/how…68-working-updated-guide/

      debian now provides a dkms package from realtek source tar so you should use the first method.

      Check with apt-cache policy r8168-dkms


      A common recommend is to whenever you can, use intel nic cards
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10
      telegram.me/openmediavault broadcast channel
      openmediavault discord server
    • Suddenly OMV 3 needs 5 mins to boot

      I can try this but the question is why this happens frim one day to another. Everything was just working fine for about an year. I think something is messed up in Devian itself or openmediavault. Is there someway to chekc the systemfiles? Or is there a way to reinstall everything without losing my config...especially from Docker?

      Gesendet von meinem LG-H815 mit Tapatalk
    • You can reinstall but Omv will need to be reconfigured manually. Docker should be fine as long as folder maps remain the same in the host side.
      You can do a checkup of the hash checksums of files from packages do see if there is any data corruption there.
      Also can you clarify into what kind of media is Omv installed ?
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10
      telegram.me/openmediavault broadcast channel
      openmediavault discord server
    • Thats the output of dpkg --verify:

      Source Code

      1. root@openmediavault:~# dpkg --verify
      2. ??5?????? c /etc/default/docker
      3. ??5?????? c /etc/cron-apt/config
      4. ??5?????? c /etc/watchdog.conf
      5. ??5?????? c /etc/default/monit
      6. ??5?????? c /etc/monit/monitrc
      7. ??5?????? c /etc/ntp.conf
      8. ??5?????? c /etc/collectd/collectd.conf
      9. ??5?????? c /etc/hdparm.conf
      10. ??5?????? c /etc/default/smartmontools
      11. ??5?????? c /etc/smartd.conf
      12. ??5?????? c /etc/cron.daily/mdadm
      13. ??5?????? c /etc/default/avahi-daemon
      14. ??5?????? c /etc/avahi/avahi-daemon.conf
      15. ??5?????? c /etc/issue
      16. ??5?????? c /etc/default/acpid
      17. ??5?????? c /etc/default/collectd
      18. ??5?????? c /etc/systemd/timesyncd.conf
      19. ??5?????? c /etc/default/rrdcached
      20. ??5?????? c /etc/default/halt
      21. ??5?????? c /etc/default/openmediavault
      Display All
    • epicfail wrote:

      Thats the output of dpkg --verify
      Looks fine, your installation is intact and you should really start to focus on the usual suspects (hardware) instead of software all the time. When there are 'interface bring up' issues the first thing to do is to check for interconnection problems at the hardware layer (always search/test from bottom to top)
      'OMV problems' with XU4 and Cloudshell 2? Nope, read this first. 'OMV problems' with Cloudshell 1? Nope, just Ohm's law or queue size.