Neuinstallation OMV3.x auf BananaPI M1

    • Resolved
    • OMV 3.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Neuinstallation OMV3.x auf BananaPI M1

      Hallo,
      Da meine SD-Karte defekt ist, möchte ich gerne eine Neuinstallation auf meinem BananaPI M1
      durchführen. Das aktuelle Image "OMV_3_0_87_Bananapi_4.12.9.img" funktioniert bei mir nicht:
      egal welchen Diskwriter (unter Windows) ich nehme, das Image wird erfolgreich geschrieben, aber am
      BananaPi rührt sich nichts. Hat sich etwas am Vorgang einer Neuinstallation geändert? Vor enigen Wochen
      konnte ich das damals aktuelle Image erfolgreich booten. Auch das empfohlene Etcher-Tool erzeugt mir
      keine bottfähige SD-Karte. Habe es mit diversen 4GB und 8GB Modellen probiert.

      Was mache ich falsch?
    • Hallo Long.one

      Ich glaube du hast die Stromversorg an dem OTG angesteckt.
      Du musst den usb neben der SATA nehmen!
      forum-bpi.de Visit on and help us, The Germany Forum :thumbsup:
      github.com/Wolf2000Pi
      Banana Pi /Armbian 3.4.109 / Openmediavault 2.x
      Banana Pi /Armbian 4.11.5-sunxi / Openmediavault 3.0.xx (Test)
      Dell Inspiron One 2205 | Openmediavault 3.0.xx / Kernel 4.7 (Test)
    • Hat sich sonst was auf der Banane geändert.
      Hast du die SD-Karten vorher Formatiert?
      Ist dein Netzteil stark genug 2,5 Amp..
      forum-bpi.de Visit on and help us, The Germany Forum :thumbsup:
      github.com/Wolf2000Pi
      Banana Pi /Armbian 3.4.109 / Openmediavault 2.x
      Banana Pi /Armbian 4.11.5-sunxi / Openmediavault 3.0.xx (Test)
      Dell Inspiron One 2205 | Openmediavault 3.0.xx / Kernel 4.7 (Test)
    • ich habe verschiede SDs und Bananen ausprobiert. Netzteil hat auch 2,5A. Aber die Formatierung habe ich nicht gemacht. Muss die SD
      mit z.B. mit diskpart komplett gelöscht und neu formatiert werden? Wenn ja mit FAT32? Die SDs hatten vorher diverse Raspi und Linux
      Images drauf...
    • ich habe die SD mit diskpart soeben gelöscht und neu formartiert (fat). Selbes Ergebnis - bootet nicht. Ich werde jetzt noch den SDFormatter bemühen.
      Sehr seltsam.....
      Vielleicht ist das Image ja defekt. Hat jemand die Möglichkeit das Image herunterzuladen und in seinen BananPI M1 mal auszuprobieren?
    • Hast du es von hier downloadet: sourceforge.net/projects/openm…s/Other%20armhf%20images/
      Hast du es auch entpackt?
      forum-bpi.de Visit on and help us, The Germany Forum :thumbsup:
      github.com/Wolf2000Pi
      Banana Pi /Armbian 3.4.109 / Openmediavault 2.x
      Banana Pi /Armbian 4.11.5-sunxi / Openmediavault 3.0.xx (Test)
      Dell Inspiron One 2205 | Openmediavault 3.0.xx / Kernel 4.7 (Test)
    • ja - genau von dieser Quelle, und ja - auch entpackt. Habe das selbe Vorhaben ja schon ein paar mal erfolgreich gemacht in letzter Zeit.

      Lade gerade das Image noch einmal herunter.... Aber Hoffung habe ich so recht nicht mehr. Die beiden Partitionen der SD lassen sich übrigens
      in einem Linuxsystem einwandfrei mounten und durchsuchen. Habe nur keine Ahnung wie ich checke ob die eine Linuxpartition bootbar ist...
    • Leider auch mit dem erneutem Download kein Erfolg. Eine mit Linux-Mint erstellte SD bootet auch nicht. Ich gebe auf! :(

      Bevor ich den Thread schließe: hat jemand Zeit und Lust selbst mal mit seinem BananPi M1 das Image zu testen?

      Ich lade gerade ein Image für den Raspi runter und werde einen letzten Versuch mit einem Raspberry machen. Nur um
      sicherzustellen dass ich nicht völlig verwirrt bin.....
    • long.one wrote:

      hat jemand Zeit und Lust selbst mal mit seinem BananPi M1 das Image zu testen?
      Das Image ist von mir weit mehr als fünf mal getestet worden und funktioniert. Der SD-Formatter ist nutzloser Schwachsinn, wenn Du nicht die einzig sinnige Funktion (ERASE CMD38) nutzt. Das Image hat auch nur eine Partition, d.h. wenn Du zwei Partitionen siehst, hast Du jedenfalls mal nicht das aktuelle Image auf Karte gebannt.
    • Neuinstallation OMV3.x auf BananaPI M1

      SD-Formatter ist nutzloser Schwachsinn ??
      Bist du dir sicher?

      Gesendet von meinem SM-G935F mit Tapatalk
      forum-bpi.de Visit on and help us, The Germany Forum :thumbsup:
      github.com/Wolf2000Pi
      Banana Pi /Armbian 3.4.109 / Openmediavault 2.x
      Banana Pi /Armbian 4.11.5-sunxi / Openmediavault 3.0.xx (Test)
      Dell Inspiron One 2205 | Openmediavault 3.0.xx / Kernel 4.7 (Test)
    • Wolf2000 wrote:

      SD-Formatter ist nutzloser Schwachsinn ??
      Exakt mit der einen Ausnahme wie bereits geschrieben: "die einzig sinnige Funktion (ERASE CMD38)" . Wenn man das Programm nutzt, dann nur um die Karte zu TRIMMEN (d.h. dem Kartencontroller mitzuteilen, dass alle Pages als leer betrachtet werden können). D.h. immer schön 'FULL (Erase)' und nie 'QUICK' auswählen, weil Letzeres schlichtweg nur Schwachsinn ist, denn was soll es denn bitte sehr bringen, einen Partitionstabelle auf ein Medium zu schreiben, wenn im nächsten Moment eh alles überschrieben wird?

      Der einzige Grund, warum dieser Schwachsinn überall empfohlen wird, ist weil der gammelige Bootloader des Raspberry Pi mit nichts anderem als FAT umgehen kann, alle SD-Karten ab 32GB aber ab Werk mit exFAT formatiert sind (Bestandteil der SDXD-Spezifikation) und daher die Rasperry-Leute einfach generell empfehlen, alle Karten vor Inbetriebnahme mit FAT32 zu formatieren, damit der NOOBS-Bootloader anschließend aufgebracht werden kann (selbst mit Raspbian ist das 'Vorformatieren' nur ein elender Schwachsinn, weil Raspbian selbst anschl. die Partitionstabelle überschreibt!)

      Raspberry + NOOBS + SD-Karte größer/gleich 32GB --> SD-Formatter nötig. Für alle anderen Devices und OS-Images: natürlich nicht, weil sinnlose Zeitverschwendung außer man möchte die Karte komplett zurücksetzen (ERASE CMD38)!
    • long.one wrote:

      Da beim BPI M1 nur eine Partition nach dem flashen auf der SD sein darf, verwende ich also das falsche Image.
      Nö, ich hab leider Quatsch geschrieben. Tschuldigung. Hatte vergessen, dass das Image inzwischen auf btrfs basiert also eine kleine ext4 boot Partition und eine große btrfs-Partition drauf ist.

      Wenn sich das 'Nicht funktionieren' darin äußert, dass nix auf einem angeschlossenen Monitor angezeigt wird... das scheint normal zu sein (keine Ahnung warum, werd das auch nicht prüfen). Das Image braucht eine Netzwerkverbindung beim ersten Start, weil die Installation finalisiert wird und nach paar Minuten rebootet sich der Banana und ist dann per Netzwerk erreichbar. Wenn Fritzboxen oder andere gute Router im Einsatz, sollte ein 'ping bananapi' nach paar Minuten funktionieren.
    • tkaiser wrote:


      Wenn sich das 'Nicht funktionieren' darin äußert, dass nix auf einem angeschlossenen Monitor angezeigt wird... das scheint normal zu sein (keine Ahnung warum, werd das auch nicht prüfen). Das Image braucht eine Netzwerkverbindung beim ersten Start, weil die Installation finalisiert wird und nach paar Minuten rebootet sich der Banana und ist dann per Netzwerk erreichbar.

      ja so ist es. einfach 10 Minuten warten und dann ist OMV per WEB Gui erreichbar. Es wäre nett das im Readme zu vermerken. Ich formatiere und installiere seit gestern Mittag...

      Vielen Dank für die Unterstützung.