Windows 10 gives errors trying to connect to a omv samba share

    • OMV 3.x
    • Resolved
    • Windows 10 gives errors trying to connect to a omv samba share

      I have some weird issues with omv samba share, and some windows 10 machines of a client, randomly when they try to connect to a samba share of omv, when those machine come up fresh from boot or when they connect with a username and then try to reconnect with another username or again when one user try to connect with same username and passowrd from 2 different pc at the same time.
      Of course those are all different errors, so I will try my best to enumerate them and if you know how to fix them that would be great!

      • Windows on startup seems to not find the server anymore and throws the error in the attachment, with the error code 0x80070035, sometimes after a while it works again like it should, sometime it requires a reboot to make samba work properly. (the network is not mapped the user accesses it through the network folder, I remember windows 7 had problem with networks share and you have to force save credentials through the manager, does windows10 has something similar?)
      • An user has two different pc, he tries to connect to the samba share with the same username\password at same time but it gives errors until he disconnects one of the two. (I don't use windows so I don't know if it's windows or something on omv preventing it, but on my home I have a mac and a debian system I connect both of them at the same time with same username\password and the share works like it should, am I missing something or some samba settings?! I thought it should work like that as default..I mean linux should manage them as same user connecting to the server so why one is accepted and the other refused?!)
      • If a user is connected with one username\password to a samba share and try to connect to another share on the same nas with a different user and password it works, but when the same user try to go back and connect with the previous username\password it fails with the error ...the user could not have the right permissions... (that of course has on the server)

      For what is worth all the shares has been set with admin and group with the access\write permissions and others with none but all the users accessing the nas has users\password created on the server so everything should work fine, actually it does when windows decide to not cry about anything it just random errors any ideas?!

      If you need other info please tell me I will provide them thanks.
      • samba_error.png

        19.74 kB, 516×129, viewed 260 times
    • I will try it, but I guess will not work I was looking for the error code and saw tons and tons of same windows error with users apparently microsoft fucked up again with samba share I will see if I can solve it through activating netbios\tcp on the lan as I saw many of them solve it like that..

      If you have any other suggestion fire away
    • @donh after some tests, it seems that I've fixed the issue at least those pc didn't complain about since yesterday.

      None of the fix proposed about the error fixed it neither the netbios tcp\ip setting.
      The thing that I changed that seems to work, was a trick I used on windows 7 too and it is to go through the credential manager of window, delete all the Windows Credentials created automatically, and create a new one from scratch, giving username password and server on the respective fields.
      In this manner windows creates an enterprise persistence with them, after that the pc stops to complain and it works out of the box with the samba share on every subsequent reboot.

      Thought to share it with you, because I didn't see this fix in your thread, so maybe it's worth to know for you as well
    • @donh sure here it is pretty straight forward.

      Sometime windows acts weird if you just save user password to a share through the popup window that appears once you select a new share.
      The thing is windows almost always forget the password or has confusion about how password get saved, especially on windows7 and windows10 (there is a bug never solved).

      So the right way to set a persistent share (no need to type user\pass everytime on reboot) is thorugh credential manager.

      To do that just pres windows key and type Credential Manager on the search bar and open it (the icon is the one of a safe)
      Icons\disposition of icons varies between windows versions but it's pretty simple to understad.

      At the credential manager opening you may see a list of server you saved, despite that the Persistence value is wrong, so to have a real persistent and consistent password saved on boot you just need to recreate the credential you are after:

      1. Select the Share you saved if present on the credential manager expand the menu and select Remove from vault. (after that of course the user\password of the share will be deleted)
      2. Click on Add a Windows credential
      3. On the new page on Internet or network address just put the address of your share ex. \\ThisIsMyShare or the IP if you prefer ex. \\
      4. User name and password are self explanatory after that click on Ok
      5. After that you will see the new entry will be created and the new entry has Persistence: Enterprise (if that is the result you did it right otherwise just restart from point 1.)
      6. Enjoy your new share correctly configured in widnows
    • Users Online 1

      1 Guest