OMVextras - URbackup Server 3.0 on Debian Stretch (version 9)

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • OMVextras - URbackup Server 3.0 on Debian Stretch (version 9)

      Dear all,

      I am just playing around with OMV 4.0.8.
      Everything is working very fine (some small interface bugs, but... hey, it's an alpha ;) )

      I ran into a problem with the omvextras-plugin urbackup-server 3.0.
      It seems, that the versioning scheme of libcryp++9 has changed - it is now libcrypt++6 (and before it was libcrypt++9v5)...
      I installed libcrypt++6 manually, but the plugin still needs libcrypt++9 as a dependency.

      Does anyone have a suggestion, how to easily solve this problem?`

      Thanks for your support!

      Cheers, Markus

      Here you find the original error message:

      Shell-Script

      1. Reading package lists...
      2. >>> *************** Error ***************
      3. Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; export DEBIAN_FRONTEND=noninteractive; apt-get --yes --allow-downgrades --allow-change-held-packages --fix-missing --allow-unauthenticated --reinstall install openmediavault-urbackup-server 2>&1' with exit code '100': Reading package lists...
      4. Building dependency tree...
      5. Reading state information...
      6. Some packages could not be installed. This may mean that you have
      7. requested an impossible situation or if you are using the unstable
      8. distribution that some required packages have not yet been created
      9. or been moved out of Incoming.
      10. The following information may help to resolve the situation:
      11. The following packages have unmet dependencies:
      12. openmediavault-urbackup-server : Depends: libcrypto++9 but it is not installable
      13. Depends: urbackup-server but it is not going to be installed
      14. E: Unable to correct problems, you have held broken packages.
      15. <<< *************************************
      Display All
    • mbach wrote:

      Does anyone have a suggestion, how to easily solve this problem?`
      I will look at the plugin.
      omv 4.1.11 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • mbach wrote:

      Thanks! That would be a great help.
      I can't really fix this since the urbackup package requires libcrypto++9 as well and that package isn't available in Debian Stretch. I guess I will have to see if I can build libcrypto++9 on stretch.
      omv 4.1.11 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • themadman206 wrote:

      Any Update? I just tried this on OMV-4.0.10 and its still giving the same errors.
      Nope. On my list of things to fix, this is pretty low since it works fine on OMV 3.x.
      omv 4.1.11 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!