Rsync local job only running when it is called from webui

    • OMV 3.x
    • Resolved
    • Rsync local job only running when it is called from webui

      Hello,

      I am trying to create Rsync local job on my rpi 3 through web ui. I want to run the job every 1 minute. I was able to create job but it is running only when it is called manually through 'Run' option and not automatically every minute. May be I have messed up something with the job schedule. I am attaching here with the screenshot from web ui and config.xml entry for the job. I have checked for Rsync logs in 'Diagnostics > System Logs > Rsync - jobs' but it is only showing logs for which I have manually run from web ui.

      XML Source Code

      1. <job>
      2. <uuid></uuid>
      3. <enable>1</enable>
      4. <sendemail>0</sendemail>
      5. <comment></comment>
      6. <type>local</type>
      7. <src>
      8. <sharedfolderref></sharedfolderref>
      9. <uri></uri>
      10. </src>
      11. <dest>
      12. <sharedfolderref></sharedfolderref>
      13. <uri></uri>
      14. </dest>
      15. <minute>1</minute>
      16. <everynminute>1</everynminute>
      17. <hour>*</hour>
      18. <everynhour>0</everynhour>
      19. <month>*</month>
      20. <dayofmonth>*</dayofmonth>
      21. <everyndayofmonth>0</everyndayofmonth>
      22. <dayofweek>*</dayofweek>
      23. <recursive>1</recursive>
      24. <times>1</times>
      25. <compress>0</compress>
      26. <archive>1</archive>
      27. <delete>1</delete>
      28. <quiet>0</quiet>
      29. <perms>1</perms>
      30. <acls>0</acls>
      31. <xattrs>0</xattrs>
      32. <dryrun>0</dryrun>
      33. <partial>0</partial>
      34. <extraoptions></extraoptions>
      35. <mode>push</mode>
      36. <authentication>password</authentication>
      37. <password></password>
      38. <sshcertificateref></sshcertificateref>
      39. <sshport>22</sshport>
      40. </job>
      41. </jobs>
      Display All
    • Have you enabled the job? First item in the window (not visible in your screen shot)
      Did you press "save" and "apply"? (Not sure if the "apply" windows opens)

      If both is the case, try to disable "every N minute" to see if it then runs every hour,
      Odroid HC2 - armbian - Seagate ST4000DM004 - OMV4.x
      Asrock Q1900DC-ITX - 16GB - 2x Seagate ST3000VN000 - Intenso SSD 120GB - OMV4.x
      :!: Backup - Solutions to common problems - OMV setup videos - OMV4 Documentation - user guide :!:
    • Yup. The job is in enabled state. I first saved and then applied. I have already tried to disable "every N minute" and checked but same. Its not running automatically. I am now trying a workaround. I will create the rsync command myself and try put it in scheduled jobs.