"Communication Error" when clicking on "File Systems" or "Raid Management", raid the cause?

    • "Communication Error" on filsystem, raid the cause?

      To start, I should mention that everything was working just a few hours ago.

      My system consists of a single SSD, and 3 relatively new HDDs in a linear raid.

      Just an hour before reformatting my SSD, my omv configuaration was stable. Navigating through "File Systems" and "RAID management" worked just fine.

      I reformatted my SSD, installed debian jessie, and installed omv 3.

      Whenever I click on "Raid Management" or "File Systems" in the web ui I get a "Communication Error". After reading on these forums about the issue, it seems that the likely cause is that the drives don't respond in time, indicating failure. My drives all detect under "Physical Disks", and SMART tests where run without any cause for concern. Furthermore, when ANY combination of 2/3 disks in my system is hooked up, clicking on "File Systems" or "RAID Management" doesn't give an error, the raid config simply isn't there.

      I've done this once before a while back and it was simple. I reformatted OMV, I then went to file systems and it auto-detected my raid, and I mounted it without problems.

      Does anyone know what's going on? SMART tests show no problems with the drives, and having AB, BC, or AC drives physically plugged in, two at a time, results in no error when clicking "File Systems" or "Raid Management".

      One final thing I should note is that when I have all 3 drives hooked up and get the communication error, I hear each individual drive spinning away heavily for several minutes, making me think some huge process is started behind the scenes.

      Server has an i7 and 8gb of ram, so should be able to handle this, and has handled reformats in the past.

      Any advice on troubleshooting would be appreciated. If there are any logs I can track down please don't hesitate to let me know!
    • clunkyfunkymonkey wrote:

      I'm also have issues with 3.0.90, communication error, slow formatting, bad gateway.
      It's a new install over the top of an existing.
      I'm convinced whatever is happening is a result of the new update, since I did this very recently on 3.0.8x and everything worked fine.

      Just incase anyone can be of help, my FSTAB looks like this:

      # /etc/fstab: static file system information.
      # Use 'blkid' to print the universally unique identifier for a
      # device; this may be used with UUID= as a more robust way to name devices
      # that works even if disks are added and removed. See fstab(5).
      # <file system> <mount point> <type> <options> <dump> <pass>
      # / was on /dev/sda2 during installation
      UUID=15b9af40-ae12-4838-8269-b4a840a298e4 / ext4 errors=remount-ro 0 1
      # /boot/efi was on /dev/sda1 during installation
      UUID=9BF0-EAFD /boot/efi vfat umask=0077 0 1
      # swap was on /dev/sda3 during installation
      UUID=36ec0439-7d33-4718-b951-902337f4e536 none swap sw 0 0
      tmpfs /tmp tmpfs defaults 0 0

      Running blkid:

      /dev/sda1: UUID="9BF0-EAFD" TYPE="vfat" PARTUUID="6d1f21a8-32f9-4b52-9c37-b913a143dac0"
      /dev/sda2: UUID="15b9af40-ae12-4838-8269-b4a840a298e4" TYPE="ext4" PARTUUID="158bee58-b76a-401d-a5fa-19a52ba5be6f"
      /dev/sda3: UUID="36ec0439-7d33-4718-b951-902337f4e536" TYPE="swap" PARTUUID="0e142d10-fc45-4246-a3aa-e659b78e83b2"
      /dev/sdb: UUID="dbb02370-7606-7bea-c611-bcd5c3280cf0" UUID_SUB="2b7a0686-051b-8d2f-1966-5366cba919cf" LABEL="openmediavault:MediaDrive" TYPE="linux_raid_member"
      /dev/sdd: UUID="dbb02370-7606-7bea-c611-bcd5c3280cf0" UUID_SUB="9aae5675-b8ec-eaf2-ce5f-750886b1baa4" LABEL="openmediavault:MediaDrive" TYPE="linux_raid_member"
      /dev/md127: LABEL="NASDRIVE" UUID="6e93c264-fbad-48e3-bebc-7958f68a9572" UUID_SUB="2c69394f-5cef-4714-81ee-b1320437fe3c" TYPE="btrfs"
      /dev/sdc: UUID="dbb02370-7606-7bea-c611-bcd5c3280cf0" UUID_SUB="42b71329-e10a-e6bf-1e6b-5850aeee6ac8" LABEL="openmediavault:MediaDrive" TYPE="linux_raid_member"

      Interestingly, my raid drives don't appear anywhere in the fstab. Is this normal?
      If anyone has any tips on how I can get these disks mounted in OMV, or maybe even mount them myself and update the omv config to reflect this?

      Thanks all!
    • Update: After re-installing debian jessie again and giving OMV 3 a shot, I still received the communication error.

      Downloaded debian stretch + OMV4 in the exact same way, and everything works.

      I'm convinced this is related to some change that was made in the most recent OMV3 update.

      Regardless, moving to OMV4 fixed the error and my raid appeared and mounted immediately without issue.
    • Users Online 1

      1 Guest