OMV auto connect through WiFi

    • OMV 3.x
    • OMV auto connect through WiFi

      I have setup OMV 3.0 with RPI 3. I have connected RPI wireless to Router no LAN cable attached. Whenever I restart my Router RPI loses its wireless connection from Router. I have to just switch off the RPI without shutdown and need to switch on again to get it connected. Setup is headless so I havent attached keyboard/mouse and monitor with RPI. Is there anyway I can get RPI connected automatically when it loses wireless connection from Router ?
    • kuleen wrote:

      I have connected RPI wireless to Router no LAN cable attached
      No idea if you used the 'standard' methods (fiddling around with wpa_supplicant and /etc/network/interfaces files -- at least this would need the 'allow-hotplug $interface' setting there). If you used latest official OMV image for Raspberries then using 'nmtui-connect' via a SSH shell should work while ignoring network settings in the web UI.

      kuleen wrote:

      I have to just switch off the RPI without shutdown and need to switch on again to get it connected
      Good luck since your installation will be bricked soon anyway if you do this all the time.

      kuleen wrote:

      ... same behavior with eth0. Once I restart my router PI is not getting registered until I manually restart it.
      So maybe it's just a DHCP issue with your router if even wired connections show these problems. Obvious solution is to switch from DHCP to a static configuration then (or to replace both RPi and the router with something that works)
      'OMV problems' with XU4 and Cloudshell 2? Nope, read this first. 'OMV problems' with Cloudshell 1? Nope, just Ohm's law or queue size.

      The post was edited 1 time, last by tkaiser ().