smb access from mac

    • OMV 3.x
    • smb access from mac

      Hi, I'm, Czarlji and i'm a omv user since few months and basically works flawlessly since then.
      use as a file server and plex media and is works nicely.
      recently i try to set up smb/cifs to get access from my imac and problems begins.
      i set up shares, add a user permissions to read/write to those shares ,start smb and thats all.
      i dont know why i have two entries on shared panel(screen1), trying to connect to first one(vault) connection is failed every time
      and connecting to the second one (vault-SMB/CIFS) mount on my desktop every folder (which i set up as a share) as a single mount.
      My question is:
      how to automatically mount those shares as a one folder in finder?
      im using mac os sierra and is connected to vpn,
      thx.
      Czarlji,
      omv3x
      mac os sierra
    • Why are you not using openmediavault-netatalk 3.2.10?

      I'm on Mac High-Seirra and use the Open Media Vault plugin for Apple Shares - no issues. I upload all my video files to a mounted share through Apple Filing (NetaTalk) and it is selected as my Share /Movies for Plex Media server.

      I did not go with SMB because I wanted the Share to simply appear in my finder and not have to use Go - Connect to Server - Server Address : smb://0.0.0.0 (Your Servers IP)
      OMV 3.0.90 (Erasmus) IBM/Lenovo ThinkServer TS140 - Intel® Xeon® Processor E3-1225 v3
      8M Cache, 3.20 GHz (Quad Core). 32GB PNY Dual Channel 1600MHz DDR3 Memory. PNY CS1311 120GB SSD on OWC Accelsior S PCIe to SSD. 2, 4 Terrabyte Western Digital Reds 2, 8 Terrabyte Western Digital Reds. Intel Gigabyte LAN.

      The post was edited 2 times, last by sjdaniels ().

    • New

      thx for your replay sjdaniels, any chance that can help me with set it up?
      i try to log in to my server via netatalk but still nothing ,i'm missing something.
      how to add a user to log in ? i try user which i log in to omv and error ,i add another user on omv and still nothing.
      and one thing more . recently ,i don't now why , my plex stopped responding ,i getting message "Please check that the file exists and the necessary drive is mounted", drive is mounted (filezilla access w/o problems) plex shows all my files but cannot play them at all.
      thx
      Czarlji,
      omv3x
      mac os sierra
    • New

      In finder you select "Go" and drop down to "Connect to Server".

      I can tell you manual instructions, i.e. afp://000.000.000.000, but you should be able to click "Browse" button and see the server. If not... there is a problem.

      1. Make sure your connected to the same network as your server... this is not an internet service.

      2. Relaunch your Finder.

      Those are the easiest and first two things to check. On OS High-Sierra I often need to "alt command esc" and Relaunch Finder. It's a bit quirky sometimes.

      If it asks for your Username and Password it is asking for a user you created with OMV WebUI or via SSH and the adduser command. As long as the group "user" has read and write access to the share you should be good.

      Go to "Shared Folders" click the share and select "Privileges". Make sure that user has read and write permissions.

      Let me know how you make out.
      OMV 3.0.90 (Erasmus) IBM/Lenovo ThinkServer TS140 - Intel® Xeon® Processor E3-1225 v3
      8M Cache, 3.20 GHz (Quad Core). 32GB PNY Dual Channel 1600MHz DDR3 Memory. PNY CS1311 120GB SSD on OWC Accelsior S PCIe to SSD. 2, 4 Terrabyte Western Digital Reds 2, 8 Terrabyte Western Digital Reds. Intel Gigabyte LAN.
    • New

      hi,thx,i manage to connect to one of the files,but:
      i see all the time on finder my server but when i try to connect via that its not work,
      manage to connect via go to-servers-afp...,but when i put login details new window pop out
      asking for password for the file but i cannot write anything on that,i manage to copy/paste password and log in to file.
      but finder mount a drive on desktop instead looks like in you pic in finder.
      Czarlji,
      omv3x
      mac os sierra
    • New

      That's permissions on your drive. You're seeing an error from your Mac that says something like "User attempting to make changes in Finder..." The drive permissions are off.

      I can't get into specifics... in the middle of a server crash from Bios update... here's a free hint, if it aint broke, don't fix it.

      You can work around this by chmod 777 the drive or folder and it will work.
      OMV 3.0.90 (Erasmus) IBM/Lenovo ThinkServer TS140 - Intel® Xeon® Processor E3-1225 v3
      8M Cache, 3.20 GHz (Quad Core). 32GB PNY Dual Channel 1600MHz DDR3 Memory. PNY CS1311 120GB SSD on OWC Accelsior S PCIe to SSD. 2, 4 Terrabyte Western Digital Reds 2, 8 Terrabyte Western Digital Reds. Intel Gigabyte LAN.