MDADM Error Messages

    • OMV 3.x
    • MDADM Error Messages

      I'm a Linux newbie, lLooking for help on OpenMediaVault install. Instructions recommend disconnecting all data drives, installing to a USB flash drive to boot from (boots completely to RAM), then reconnecting and formatting data drives. It installs perfectly to the flash drive, boots perfectly, no problems. However, ONLY after I reconnect the data drives do I start getting errors, an "MDADM no arrays found in config file or automatically" message. It is apparently related to a RAID system, but this system has never been configured for RAID, doesn't have a RAID set up, nothing like that. I've tried completely removing all existing partitions and reformatting the drives, nothing works, the same error message scrolls repeatedly on the screen. Could use assistance in diagnosing problem, maybe disabling the MDADM system via GRUB boot command? Have seen others online with same issue, but no solutions.
    • Assuming your OMV USB thumbdrive build was done form scratch:

      At times RAID, LVM, GPT, Root Kits and others, may write things to a drive's boot sector that are persistent. These settings may survive reformatting and may refuse attempts to repartition the drive.

      If you're experiencing something like this, try Darik's Boot and Nuke. --> DBAN will erase anything, and the first place it runs is on the boot sector. It will only take a few minutes to clean up the boot sector - there's no need to do a full pass. Afterward, you'll have a clean drive.


      **The only caution is, make sure you run it on the right disk(s).**
      Good backup takes the "drama" out of computing
      ____________________________________
      Primary: OMV 3.0.99, ThinkServer TS140, 12GB ECC, 32GB USB boot, 4TB+4TB zmirror, 3TB client backup.
      Backup: OMV 4.1.9, Acer RC-111, 4GB, 32GB USB boot, 3TB+3TB zmirror, 4TB Rsync'ed disk
      2nd Data Backup: OMV 3.0.99, R-PI 2B, 16GB boot, 4TB WD USB MyPassport - direct connect (no hub)
    • kaufmanj1973 wrote:

      an "MDADM no arrays found in config file or automatically" message. It is apparently related to a RAID system
      It's exactly the opposite. This message is telling you that there's no RAID involved AT ALL (neither exists a config nor are there RAID structures on your disks -- that's what the message is telling you).

      A different questions is why the message continually appears and this needs some investigation as @Sc0rp already explained.