Openvpn plugin on OVM4 ?

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Been waiting for this release a while. However, after installation of the plugin I get the following error.

      Error #0:OMV\Rpc\Exception: Failed to connect to socket: No such file or directory in /usr/share/php/openmediavault/rpc/rpc.inc:140Stack trace:#0 /usr/share/php/openmediavault/rpc/proxy/json.inc(95): OMV\Rpc\Rpc::call('UserMgmt', 'getSettings', NULL, Array, 3)
      #1 /var/www/openmediavault/rpc.php(45): OMV\Rpc\Proxy\Json->handle()
      #2 {main}

      How do I solve this?
      "Goats are like mushrooms, if you shoot a duck, I'm scared of toasters."
    • Zwei wrote:

      Been waiting for this release a while. However, after installation of the plugin I get the following error.

      Error #0:OMV\Rpc\Exception: Failed to connect to socket: No such file or directory in /usr/share/php/openmediavault/rpc/rpc.inc:140Stack trace:#0 /usr/share/php/openmediavault/rpc/proxy/json.inc(95): OMV\Rpc\Rpc::call('UserMgmt', 'getSettings', NULL, Array, 3)
      #1 /var/www/openmediavault/rpc.php(45): OMV\Rpc\Proxy\Json->handle()
      #2 {main}

      How do I solve this?
      How did you install it? Did you do it through the OMV-Extras repo or using my instructions from my earlier post?
    • David B wrote:

      Zwei wrote:

      Been waiting for this release a while. However, after installation of the plugin I get the following error.

      Error #0:OMV\Rpc\Exception: Failed to connect to socket: No such file or directory in /usr/share/php/openmediavault/rpc/rpc.inc:140Stack trace:#0 /usr/share/php/openmediavault/rpc/proxy/json.inc(95): OMV\Rpc\Rpc::call('UserMgmt', 'getSettings', NULL, Array, 3)
      #1 /var/www/openmediavault/rpc.php(45): OMV\Rpc\Proxy\Json->handle()
      #2 {main}

      How do I solve this?
      How did you install it? Did you do it through the OMV-Extras repo or using my instructions from my earlier post?
      I managed to install it with your instructions. Pulling it from the repo caused the above mentioned error, but installing it by pulling it directly seemed to work. Thanks!
      "Goats are like mushrooms, if you shoot a duck, I'm scared of toasters."

      The post was edited 1 time, last by Zwei ().

    • Zwei wrote:

      Pulling it from the repo caused the above mentioned error, but installing it by pulling it directly seemed to work.
      It shouldn't. It is the exact same code.
      omv 4.1.14 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Zwei wrote:

      It shouldn't. But it did. Don't know why.
      I think you had an apt issue and the second installation fix it. I don't think getting the code from git did it.
      omv 4.1.14 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • David B wrote:

      Are you sure that you put the new version in the repo? I didn't see it listed.
      Yes - bintray.com/openmediavault-plu…penmediavault-openvpn/4.0 - do you have the omv-extras testing repo enabled?

      I even checked my local copy of the git repo and it is update to date. I just pushed 4.0.1 to the regular omv-extras repo with updated translations.
      omv 4.1.14 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • ryecoaaron wrote:

      David B wrote:

      Are you sure that you put the new version in the repo? I didn't see it listed.
      Yes - bintray.com/openmediavault-plu…penmediavault-openvpn/4.0 - do you have the omv-extras testing repo enabled?
      I even checked my local copy of the git repo and it is update to date. I just pushed 4.0.1 to the regular omv-extras repo with updated translations.
      I have the testing repo enabled, but it still did not show up. And I just checked for updates, but 4.0.1 is not showing up. It also worth noting that although 4.0 installed properly my way, I am having issues with connecting to the VPN.
    • David B wrote:

      And I just checked for updates, but 4.0.1 is not showing up
      Something is wrong with your system then. Try the apt clean button.
      $ apt-cache policy openmediavault-openvpn
      E: Opening configuration file /etc/apt/apt.conf.d/99openmediavault-proxy - ifstream::ifstream (13: Permission denied)
      aaron@qnapomv:~$ sudo apt-cache policy openmediavault-openvpn
      openmediavault-openvpn:
      Installed: (none)
      Candidate: 4.0.1
      Version table:
      4.0.1 500
      500 dl.bintray.com/openmediavault-plugin-developers/arrakis stretch/main amd64 Packages

      David B wrote:

      It also worth noting that although 4.0 installed properly my way, I am having issues with connecting to the VPN.
      I know nothing about this plugin and don't use vpn. So, not much I can do to help with that.
      omv 4.1.14 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • TechnoDadLife wrote:

      Is there still Openvpn-as version of this?
      Nope.

      TechnoDadLife wrote:

      Is it not maintained?
      Nope. Tekkb was the maintainer.

      TechnoDadLife wrote:

      I can go a head and install it on the command line, to get the web ui?
      That should work. The plugin was very simple and just allowed the service to be enabled/disabled.
      omv 4.1.14 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • This is the one plug-in that is stopping me from moving over to OMV 4.

      I have tried a few times to get the openvpn plugin working, and it installs fine. I download a certificate and I try to connect, but it won't connect.

      In OMV 3 this was very straightforward, so I am surprised to be struggling so much.

      I will be sticking to OMV 3 for now as this is a necessary plugin for me unfortunately.
    • rwattstci wrote:

      This is the one plug-in that is stopping me from moving over to OMV 4.
      Unfortunately, there is no maintainer. So, I don't know how it is ever going to work on OMV 4 and almost no chance of being ported to OMV 5. Maybe @TechnoDadLife will make a video of his experiences with openvpn-as??
      omv 4.1.14 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • ryecoaaron wrote:

      rwattstci wrote:

      This is the one plug-in that is stopping me from moving over to OMV 4.
      Unfortunately, there is no maintainer. So, I don't know how it is ever going to work on OMV 4 and almost no chance of being ported to OMV 5. Maybe @TechnoDadLife will make a video of his experiences with openvpn-as??
      It has been modified to work on OMV4. I posted instructions for users that wanted to build and install it somewhere on here. I am not sure where they are though. If anyone wants to look through my post history (I don't have time to do so right now), you should be able to find it.