Unable to start Xen VM since upgrade to OMV4

    • OMV 4.x
    • Unable to start Xen VM since upgrade to OMV4

      Hello Community,

      i was running OMV3 with Xen-Hypervisor 4.3 (or 4.4, don't remember xD) for some months and all worked like a charm.
      But since i upgraded to OMV4 with Xen-Hypervisor 4.8 i can't boot Xen-VM's.
      I've got the following Errormessage in Virt-Manager: "Libxenlight failed to create Domain "xxxx".
      And in the logs i've got: "Unable to find partition containing kernel".

      I tried to clean install with OMV4.0.9 ISO but that changed nothing.
      Doesn't matter if i try to boot a VM per Virt-Manager (SSH) or directly on the Server.

      I'm really going to despair...also couldn't find anything in google for this issue, so i hope that you guys can help me! :thumbsup:

      Hardware:
      ASUS Mainboard
      Intel Xeon X3440
      4GB ECC RAM
      60GB Kingston SSD
      3TB WD NAS-Storage
    • I also can not boot KVM/Qemu-VM's, same error.

      I installed now a basic Debian 9 and the Xen-Packages. Same error appears :(

      Virt-Manager errormessage:
      Installation konnte nicht fertiggestellt werden: «internal error: libxenlight failed to create new domain 'ubuntu16.04'»
      Traceback (most recent call last):
      File "/usr/share/virt-manager/virtManager/asyncjob.py", line 90, in cb_wrapper
      callback(asyncjob, *args, **kwargs)
      File "/usr/share/virt-manager/virtManager/create.py", line 2273, in _do_async_install
      guest.start_install(meter=meter)
      File "/usr/share/virt-manager/virtinst/guest.py", line 501, in start_install
      noboot)
      File "/usr/share/virt-manager/virtinst/guest.py", line 416, in _create_guest
      dom = self.conn.createLinux(start_xml or final_xml, 0)
      File "/usr/lib/python2.7/dist-packages/libvirt.py", line 3606, in createLinux
      if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
      libvirtError: internal error: libxenlight failed to create new domain 'ubuntu16.04'

      libxl.log:

      2017-11-29 19:23:05.124+0000: libxl: libxl_bootloader.c:635:bootloader_finished: bootloader failed - consult logfile /var/log/xen/bootloader.1.log
      2017-11-29 19:23:05.124+0000: libxl: libxl_exec.c:118:libxl_report_child_exitstatus: bootloader [1202] exited with error status 1
      2017-11-29 19:23:05.124+0000: libxl: libxl_create.c:1223:domcreate_rebuild_done: cannot (re-)build domain: -3

      bootloader.1.log:

      Traceback (most recent call last):
      File "/usr/lib/xen-4.8/bin/pygrub", line 882, in <module>
      raise RuntimeError, "Unable to find partition containing kernel"
      RuntimeError: Unable to find partition containing kernel


      maybe someone here is using Xen and can help me... :whistling: