Can't See Files on Drive

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Can't See Files on Drive

      Hi guys!
      I had an error when I started one of my servers and it turned out to be something wrong with the file system...I ran fsck and it ran for a bit and then came up Clean...

      The problem is I don't see it in Windows?

      I tried checking from a live Debian cd and I can open the drive but not the section that has the files the directory is showing empty...

      From the live cd I ran:

      Source Code

      1. $ sudo fschk /dev/sda1
      2. fsck from util-linux 2.27.1
      3. e2fsck 1.42.13 (17-May-2015)
      4. MEDIA1: clean 196871/61054976 files, 167910086/244190385 block


      If I run the same for sda it comes up errors...in Swedish so not posting...

      What options have I to save my files?

      bookie56
    • bookie56 wrote:

      The problem is I don't see it in Windows?
      ?(

      Not sure, what you mean. Do you use WinSCP? With WinSCP you can connect to your server over SSH and browse through the directories and search for your data files. The drives should be mounted (mostly) under /srv.
      OMV 3.0.90 (Gray style)
      ASRock Rack C2550D4I - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1)- Fractal Design Node 304
    • OK...I have never had this happen to me before....

      If I show the hidden files on a live cd then it shows "lost+found" and in that folder a new folder had been created called #59768833....in that folder all my files are....weird!!
      I have now connected a new drive externally and backing up files to that....
      I will then reformat the old drive and double check it is OK before putting my files back....

      This is the strangest thing I have been apart of in all the years working with Linux...


      bookie56
    • Hi Again!
      Well, the exact same thing has happened to another drive on the same server....getting really fed up with this....
      Going to reinstall OMV and start over..

      OMV has relisted my one of my drives by disk-id and now it isn't available...
      It is one thing if I want to use disk-by id but why has OMV done it for me and then that disk isn't available...?

      bookie56

      The post was edited 1 time, last by bookie56 ().