Duplicati time out error on delete

    • OMV 3.x (stable)
    • Resolved
    • Duplicati time out error on delete

      Hi guys,

      I'm having a problem with Duplicati. Here is the problem and resolution:

      forum.duplicati.com/t/file-delete-fails-on-google-drive/1271

      I've added the mono repository to my system and tried updating the packages. But now I'm getting dependency issues. See here:

      Display Spoiler
      >>> *************** Error ***************
      Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; export DEBIAN_FRONTEND=noninteractive; apt-get --yes --force-yes --fix-missing --auto-remove --allow-unauthenticated --show-upgraded --option DPkg::Options::="--force-confold" install binutils cli-common curl duplicati smbclient samba-vfs-modules samba-libs samba-dsdb-modules samba-common-bin samba-common samba python-samba openssl openmediavault-duplicati openmediavault-backup openmediavault openjdk-7-jre-headless monodoc-manual monodoc-gtk2.0-manual gtk-sharp2-examples gtk-sharp2-gapi imagemagick-common libappindicator0.1-cil libcurl3 libcurl3-gnutls libglade2.0-cil libglade2.0-cil-dev libglib2.0-cil libglib2.0-cil-dev libgtk2.0-cil libgtk2.0-cil-dev libjs-xmlextras libmagickcore-6.q16-2 libmagickwand-6.q16-2 libmono-2.0-1 libmono-cecil-private-cil libmono-csharp4.0c-cil libmono-data-tds4.0-cil libmono-messaging4.0-cil libmono-microsoft-csharp4.0-cil libmono-posix2.0-cil libmono-posix4.0-cil libmono-security2.0-cil libmono-sharpzip4.84-cil libmono-sqlite4.0-cil libmono-system-configuration-install4.0-cil libmono-system-core4.0-cil libmono-system-data4.0-cil libmono-system-drawing4.0-cil libmono-system-enterpriseservices4.0-cil libmono-system-identitymodel-selectors4.0-cil libmono-system-identitymodel4.0-cil libmono-system-messaging4.0-cil libmono-system-net-http-webrequest4.0-cil libmono-system-net-http4.0-cil libmono-system-net4.0-cil libmono-system-runtime-serialization-formatters-soap4.0-cil libmono-system-runtime-serialization4.0-cil libmono-system-servicemodel-activation4.0-cil libmono-system-servicemodel-discovery4.0-cil libmono-system-servicemodel4.0a-cil libmono-system-serviceprocess4.0-cil libmono-system-transactions4.0-cil libmono-system-web-applicationservices4.0-cil libmono-system-web-services4.0-cil libmono-system-web4.0-cil libmono-system-windows-forms4.0-cil libmono-system-xml-linq4.0-cil libmono-system2.0-cil libmono-web4.0-cil libmono-webbrowser4.0-cil libmonoboehm-2.0-1 libmonosgen-2.0-1 libpq5 libsmbclient libssl1.0.0 libwbclient0 libwebkit1.1-cil libxml-libxml-perl linux-image-4.9.0-0.bpo.4-amd64 linux-image-amd64 monodoc-base monodoc-browser gtk-sharp2 2>&1' with exit code '100': Reading package lists...

      Building dependency tree...

      Reading state information...

      libappindicator0.1-cil is already the newest version.
      libappindicator0.1-cil set to manually installed.
      libmono-posix2.0-cil is already the newest version.
      libmono-posix2.0-cil set to manually installed.
      libmono-security2.0-cil is already the newest version.
      libmono-security2.0-cil set to manually installed.
      libmono-web4.0-cil is already the newest version.
      libmono-web4.0-cil set to manually installed.
      libwebkit1.1-cil is already the newest version.
      libwebkit1.1-cil set to manually installed.
      duplicati is already the newest version.
      duplicati set to manually installed.
      openmediavault-duplicati is already the newest version.
      Some packages could not be installed. This may mean that you have
      requested an impossible situation or if you are using the unstable
      distribution that some required packages have not yet been created
      or been moved out of Incoming.
      The following information may help to resolve the situation:

      The following packages have unmet dependencies:
      gtk-sharp2-examples : Depends: libmono-corlib4.5-cil (>= 4.0.0~alpha1) but 3.2.8+dfsg-10 is to be installed
      gtk-sharp2-gapi : Depends: libc6 (>= 2.24) but 2.19-18+deb8u10 is to be installed or
      libc6.1 (>= 2.24) but it is not installable or
      libc0.1 (>= 2.24) but it is not installable
      Depends: libmono-corlib4.5-cil (>= 4.0.0~alpha1) but 3.2.8+dfsg-10 is to be installed
      Depends: libmono-system-xml4.0-cil (>= 3.12.0) but 3.2.8+dfsg-10 is to be installed
      libglade2.0-cil : Depends: libmono-corlib4.5-cil (>= 4.0.0~alpha1) but 3.2.8+dfsg-10 is to be installed
      libglib2.0-cil : Depends: libglib2.0-0 (>= 2.50.3) but 2.42.1-1+b1 is to be installed
      Depends: libmono-corlib4.5-cil (>= 4.0.0~alpha1) but 3.2.8+dfsg-10 is to be installed
      Depends: libmono-system4.0-cil (>= 4.0.0~alpha1) but 3.2.8+dfsg-10 is to be installed
      libgtk2.0-cil : Depends: libatk1.0-0 (>= 2.22.0) but 2.14.0-1 is to be installed
      Depends: libgdk-pixbuf2.0-0 (>= 2.36.5) but 2.31.1-2+deb8u6 is to be installed
      Depends: libglib2.0-0 (>= 2.50.3) but 2.42.1-1+b1 is to be installed
      Depends: libmono-corlib4.5-cil (>= 4.0.0~alpha1) but 3.2.8+dfsg-10 is to be installed
      Depends: libpango-1.0-0 (>= 1.40.5) but 1.36.8-3 is to be installed
      Depends: libpangocairo-1.0-0 (>= 1.40.5) but 1.36.8-3 is to be installed
      libmono-cecil-private-cil : Depends: libmono-corlib4.5-cil (>= 4.0.0~alpha1) but 3.2.8+dfsg-10 is to be installed
      Depends: libmono-system4.0-cil (>= 4.0.0~alpha1) but 3.2.8+dfsg-10 is to be installed
      libmono-csharp4.0c-cil : Depends: libc6 (>= 2.24) but 2.19-18+deb8u10 is to be installed or
      libc6.1 (>= 2.24) but it is not installable or
      libc0.1 (>= 2.24) but it is not installable
      ....


      I need to remove mono and re-install the new version, but I'm not comfortable with this and the dependency problems.

      Can you give me any advice?
    • mono is a pain to remove due to the number of packages and the number of ways it can be installed. I would look at the list of packages that might be mono with: dpkg -l | grep mono and remove the packages that look like mono with apt-get purge replace_me_with_package_name

      Installing a plugin that needs mono will reinstall the packages you need.
      omv 4.0.16 arrakis | 64 bit | 4.14 backports kernel | omvextrasorg 4.1.2
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • ryecoaaron wrote:

      mono is a pain to remove due to the number of packages and the number of ways it can be installed. I would look at the list of packages that might be mono with: dpkg -l | grep mono and remove the packages that look like mono with apt-get purge replace_me_with_package_name

      Installing a plugin that needs mono will reinstall the packages you need.
      Thanks, ryecoaaron! I think I will make a backup and have a go at it.
    • ryecoaaron wrote:

      Installing a plugin that needs mono will reinstall the packages you need.
      But that's one of the problems. On the Duplicati wiki they say that it is best to use the Mono supplied Debian packages instead of the ones in APT. The old packages of APT are probably the cause of my problems with my backups.

      github.com/duplicati/duplicati/wiki/SSL-TLS-support-in-Mono


      So I need to uninstall all mono packages and install those supplied by Mono.

      Do you foresee any problems with that?

      Can you maybe integrate this in the plugin?


      Thanks.

      The post was edited 1 time, last by RHCPNG ().

    • RHCPNG wrote:

      So I need to uninstall all mono packages and install those supplied by Mono.
      Uninstall, yes. Install manually, no. You just need to enable the mono-project repo and installing the plugin will use the packages from that repo because they are a higher version.

      RHCPNG wrote:

      Do you foresee any problems with that?
      Nope

      RHCPNG wrote:

      Can you maybe integrate this in the plugin?
      Nope. Not possible. All the plugin can do is set a dependency on duplicati which has a dependency on mono. If the mono project repo isn't enabled before installing the plugin, it will use the Debian packages. If it is enabled, then it will use the mono packages from there.
      omv 4.0.16 arrakis | 64 bit | 4.14 backports kernel | omvextrasorg 4.1.2
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • ryecoaaron wrote:

      RHCPNG wrote:

      So I need to uninstall all mono packages and install those supplied by Mono.
      Uninstall, yes. Install manually, no. You just need to enable the mono-project repo and installing the plugin will use the packages from that repo because they are a higher version.

      RHCPNG wrote:

      Do you foresee any problems with that?
      Nope

      RHCPNG wrote:

      Can you maybe integrate this in the plugin?
      Nope. Not possible. All the plugin can do is set a dependency on duplicati which has a dependency on mono. If the mono project repo isn't enabled before installing the plugin, it will use the Debian packages. If it is enabled, then it will use the mono packages from there.
      OK, thanks a lot! I hope this will work.
    • RHCPNG wrote:

      I'm not sure it is already stable enough.
      I think using OMV 4.x is the equivalent of using the mono project repo. The nice thing about OMV 4.x is that the mono packages are probably new enough that you don't need the mono project repos.
      omv 4.0.16 arrakis | 64 bit | 4.14 backports kernel | omvextrasorg 4.1.2
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!