Need help setting up.

    • OMV 3.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Need help setting up.

      Hello, I have downloaded the OMV image on to my raspberry pi. Everything is working, but I need a help as I'm a newbie with computing.

      1. How do I use my raspberry pi 2 with a dongle without Ethernet cable?
      I tried this out, I enabled wifi in networking and I put in the ssid and password of my wifi. Is that all I need to do? If so, I removed the Ethernet cable and it won't work.

      2. How do I upload items as a user from iPad, iPhone, etc.

      When I try logging on my Mac to upload somethings from there, it accepts it but says there is something wrong with the server and I can't access it.

      3. How would I setup the OMV so that I could access from anywhere such as away from local network.

      Thanks. :D :thumbup:
      Raspberry Pi 2 and 3, Quad-core processor, 1 GB of RAM.
    • Welcome to OMV :thumbsup:
      Your questions cover a wide range of topics. Might be worth to split the thread in three seperate threads.
      Before that it might be a good idea to search the forum. You might find answers there already. At least the search might help you to be a bit more specific on the quesitons.

      A good starting point are also these videos: OMV Setup Videos


      Darkplatinum wrote:

      2. How do I upload items as a user from iPad, iPhone, etc.

      When I try logging on my Mac to upload somethings from there, it accepts it but says there is something wrong with the server and I can't access it.
      There are plenty of ways to do this.
      1. on Windows you would use SMB/CIFS. Not sure if you can use the same on iDings
      2. FTP client like Filezilla or WinSCP (probably there is something similar for Apple)
      3. WebDAV
      4. Cloud solution like Nextcloud, Owncloud or Pydio
      5. Backupsolutions like Duplicati or Urbackup


      Darkplatinum wrote:

      3. How would I setup the OMV so that I could access from anywhere such as away from local network.

      VPN
      Odroid HC2 - armbian - Seagate ST4000DM004 - OMV4.x
      Asrock Q1900DC-ITX - 16GB - 2x Seagate ST3000VN000 - Intenso SSD 120GB - OMV4.x
      :!: Backup - Solutions to common problems - OMV setup videos - OMV4 Documentation - user guide :!:
    • macom wrote:

      First have a look at the videos for a general introduction on how to set up OMV.
      Then take it one by one.

      We are here to help you (if we can)!!!!
      Will do, im going to reinstall the image onto my SD card ( for some reason doesn't want to reconnect back to my router, was working earlier.)
      Raspberry Pi 2 and 3, Quad-core processor, 1 GB of RAM.
    • Ok i followed the videos, but i cant get past the step to install emby-server. I would like to get emby. I am using raspberry pi 2. When trying to install this is what i get:

      Reading package lists...
      Building dependency tree...
      >>> *************** Error ***************
      Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; export DEBIAN_FRONTEND=noninteractive; apt-get --yes --force-yes --fix-missing --allow-unauthenticated --reinstall install emby-server 2>&1': Reading package lists...

      Building dependency tree...

      Reading state information...

      Some packages could not be installed. This may mean that you have
      requested an impossible situation or if you are using the unstable
      distribution that some required packages have not yet been created
      or been moved out of Incoming.
      The following information may help to resolve the situation:

      The following packages have unmet dependencies:
      emby-server : Depends: mono-runtime (>= 3.0~) but it is not going to be installed
      Depends: libmono-corlib4.5-cil (>= 4.0.0~alpha1) but it is not going to be installed
      Depends: libmono-microsoft-csharp4.0-cil (>= 1.0) but it is not going to be installed
      Depends: libmono-posix4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
      Depends: libmono-system-configuration4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
      Depends: libmono-system-core4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
      Depends: libmono-system-io-compression4.0-cil (>= 3.2.1) but it is not going to be installed
      Depends: libmono-system-net-http4.0-cil (>= 1.0) but it is not going to be installed
      Depends: libmono-system-runtime-serialization4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
      Depends: libmono-system-xml4.0-cil (>= 3.12.0) but it is not going to be installed
      Depends: libmono-system4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
      Depends: libembysqlite3-0 but it is not installable
      Depends: embymagick but it is not installable
      Depends: mono-devel (>= 4.6) but it is not going to be installed
      E: Unable to correct problems, you have held broken packages.
      <<< *************************************

      >>> *************** Error ***************
      Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; export DEBIAN_FRONTEND=noninteractive; apt-get --yes --force-yes --fix-missing --allow-unauthenticated --reinstall install emby-server 2>&1': Reading package lists...

      Building dependency tree...

      Reading state information...

      Some packages could not be installed. This may mean that you have
      requested an impossible situation or if you are using the unstable
      distribution that some required packages have not yet been created
      or been moved out of Incoming.
      The following information may help to resolve the situation:

      The following packages have unmet dependencies:
      emby-server : Depends: mono-runtime (>= 3.0~) but it is not going to be installed
      Depends: libmono-corlib4.5-cil (>= 4.0.0~alpha1) but it is not going to be installed
      Depends: libmono-microsoft-csharp4.0-cil (>= 1.0) but it is not going to be installed
      Depends: libmono-posix4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
      Depends: libmono-system-configuration4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
      Depends: libmono-system-core4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
      Depends: libmono-system-io-compression4.0-cil (>= 3.2.1) but it is not going to be installed
      Depends: libmono-system-net-http4.0-cil (>= 1.0) but it is not going to be installed
      Depends: libmono-system-runtime-serialization4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
      Depends: libmono-system-xml4.0-cil (>= 3.12.0) but it is not going to be installed
      Depends: libmono-system4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
      Depends: libembysqlite3-0 but it is not installable
      Depends: embymagick but it is not installable
      Depends: mono-devel (>= 4.6) but it is not going to be installed
      E: Unable to correct problems, you have held broken packages.
      <<< *************************************

      >>> *************** Error ***************
      Raspberry Pi 2 and 3, Quad-core processor, 1 GB of RAM.
    • Not the best idea to change a post (no 6) after it has been replied to. Now the sequence does not make sense any more.

      @ryecoaaron can you help with emby? See post no. 6
      Odroid HC2 - armbian - Seagate ST4000DM004 - OMV4.x
      Asrock Q1900DC-ITX - 16GB - 2x Seagate ST3000VN000 - Intenso SSD 120GB - OMV4.x
      :!: Backup - Solutions to common problems - OMV setup videos - OMV4 Documentation - user guide :!:
    • macom wrote:

      can you help with emby? See post no. 6
      All I can think is it is caused by using the mono-project repos instead of the Debian versions.
      omv 4.1.12 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • ryecoaaron wrote:

      macom wrote:

      can you help with emby? See post no. 6
      All I can think is it is caused by using the mono-project repos instead of the Debian versions.
      Technically i don't really need emby, i could just upload videos, pics or whatever straight to the folders. I would like to upload items with an ipad, but i don't know how to do that. Also i would like to make the OMV accessible from anywhere (Including R/W in folders).
      Raspberry Pi 2 and 3, Quad-core processor, 1 GB of RAM.
    • Darkplatinum wrote:

      Technically i don't really need emby, i could just upload videos, pics or whatever straight to the folders.
      SMB should also work with Appel. That should be the easiest way. It is also shown in the videos. No additional installation needed, just configuration.
      Odroid HC2 - armbian - Seagate ST4000DM004 - OMV4.x
      Asrock Q1900DC-ITX - 16GB - 2x Seagate ST3000VN000 - Intenso SSD 120GB - OMV4.x
      :!: Backup - Solutions to common problems - OMV setup videos - OMV4 Documentation - user guide :!:
    • macom wrote:

      Darkplatinum wrote:

      Just found out that plex only allows 1 minute recordings.
      Where did you find this limitation?
      Sorry need to rephrase that. I can upload videos to OMV via a folder i use for plex, but if i try streaming through my ipad, it says you must buy the premiere account to watch videos longer than 1 min. Read the last paragraph in free section: support.plex.tv/hc/en-us/artic…2526943-Plex-Free-vs-Paid .

      EDIT: I found a way around this, I had a browser tat i had downloaded earlier on my ipad. Instead of using the mobile app/ website, i used the Deskop website on the browser. 8o Works perfectly. :D Would be nice to be able to stream media without paying though. :cursing:
      Raspberry Pi 2 and 3, Quad-core processor, 1 GB of RAM.

      The post was edited 1 time, last by Darkplatinum ().