rsync over ssh with shell command ok but NOK on omv3.0.94

    • OMV 3.x
    • Resolved
    • rsync over ssh with shell command ok but NOK on omv3.0.94

      Hi,

      1/my shell commande of rsync over ssh is OK and work well:
      root@serveur:/# rsync -r -a -v -e ssh --delete /srv/dev-disk-by-label-data160G/Logiciels pi@192.168.1.13:/HDD/Logiciels
      pi@192.168.1.13's password:......
      sending incremental file list
      created directory /HDD/Logiciels
      Logiciels/
      Logiciels/.DS_Store
      Logiciels/._.DS_Store
      Logiciels/.recycle/
      Logiciels/.recycle/delphine/
      Logiciels/Logiciels/
      Logiciels/Logiciels/ALARME DSC/
      Logiciels/Logiciels/ALARME DSC/DLS-Auto-Updater-(IV-NA)-Release.exe
      Logiciels/Logiciels/ALARME DSC/DLS5-NA.exe
      ....


      2/can't do the same in Webui OMV3.0.94 in rsync plugin, doesn't work:







      Thank you for your help
    • rsync over ssh in the ui is passwordless. This means you have to use public key authentication. Create a ssh key pair in the cert section and add the public key in the rpi server for the user pi. Then in the job select the public key as authentication and select the ssh cert you just created.

      The password that prompts there is to use it against a pure rsyncd server.
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10
      telegram.me/openmediavault broadcast channel
      openmediavault discord server
    • i must understand

      option 1: if using ssh server on destination (port 22)
      I must create a key ssh
      then on source (my OMV), webui rsync, just put the key ssh

      option 2: enable rsync server on destination (port 879)
      then on source (my OMV), webui rsync, just put the password of rsync destination server

      right?

      thank you

      The post was edited 1 time, last by vikeq ().

    • Users Online 2

      2 Guests

    • Tags