Transmission doesnt download torrents

    • OMV 3.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Transmission doesnt download torrents

      This is really pisses me off. I installed OMV recently and i have minor or major problems with almost every thing i want to setup. Now i have with transmission. It just doesnt download files. Heres my config. I added INPUT rule for my private tracker because it demands it and it works. But not sure should i add OUTPUT rule as well. Anyway this Ubuntu i downloaded from public tracker so it should download it anyway.



      //EDIT
      OK, i just made 777 permisions and redownloaded torrent and it works. I dont know which one of those two actually did the job but its working.

      The post was edited 1 time, last by doman18 ().

    • doman18 wrote:

      This is really pisses me off. I installed OMV recently and i have minor or major problems with almost every thing i want to setup. Now i have with transmission. It just doesnt download files. Heres my config. I added INPUT rule for my private tracker because it demands it and it works. But not sure should i add OUTPUT rule as well. Anyway this Ubuntu i downloaded from public tracker so it should download it anyway.



      //EDIT
      OK, i just made 777 permisions and redownloaded torrent and it works. I dont know which one of those two actually did the job but its working.

      You shouldn’t use 777, this allow every single user/group to read/write the folder. This is not a good practice. What you can do is change the group owner of your download folder for example by “debian-transmission” or even easier, add the “debian-transmission” user to the “users” group. Then you keep the “775” permission in the folder.

      Have some patience and will get it little by little. OMV is great, the difference with other tools is it’s full open, meaning sometimes you need to go in CLI to compensate the fact everything is allowed :)
    • jollyrogr wrote:

      You don't show what your user1 privileges are.
      Read/Write for share offcourse. I didnt put that because its quite obvious thing and you can upload 10 screenshots only. So i ommited it.


      siulman wrote:

      You shouldn’t use 777, this allow every single user/group to read/write the folder. This is not a good practice.
      I know, i know, i used similar "lazy" setup on my previous machine - pure Debian at Fx160 for over a year. I planned to change it but i it was one of those "ill do it later" things which will never be done. I wanted to do it right way on my new machin and 777 was my "last resort" solution for this if anything else fails.


      siulman wrote:

      What you can do is change the group owner of your download folder for example by “debian-transmission” or even easier, add the “debian-transmission” user to the “users” group. Then you keep the “775” permission in the folder.
      I used to do similar thing for www folders in my company when i setup apache server. And it kind of pisses me off that you can add your new user to some system group in WebGUI but you cant do opposite. Or can you? Because in FreeNAS or Xpenology you can do it in very easy way.


      siulman wrote:

      OMV is great, the difference with other tools is it’s full open, meaning sometimes you need to go in CLI to compensate the fact everything is allowed
      I dont mind going to CLI when i do some "hipsterish" things. I had extroot and extswap setup on OpenWRT+Gargoyle with transmission and samba in the times when they werent plugins yet. extroot mean that i had root folder on external device (USB disk). And offcourse i didnt mind that all of those i had to do in terminal because i knew these are not standard things you do on router. But setting up shares, using torrent client or changing permissions and ownership are very standard things (especially for NAS os), like setting up PPPoE or Wifi on routers. So they should be the easiest and most straightforward things in NAS WebGUI.

      The post was edited 2 times, last by doman18 ().