The session timeout set to 0 does *not* disable automatic logout in general preferences

    • OMV 3.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • The session timeout set to 0 does *not* disable automatic logout in general preferences

      Hi there,
      in the section "General Preferences" I set session timeout to 0 expecting the the automatic logut to be disabled. In/etc/openmediavault/config.xml I find this section:

      Source Code

      1. <!-- Web administration configuration - Do not add any configuration here -->
      2. <webadmin>
      3. <port>80</port>
      4. <enablessl>0</enablessl>
      5. <sslport>443</sslport>
      6. <forcesslonly>0</forcesslonly>
      7. <sslcertificateref></sslcertificateref>
      8. <timeout>0</timeout>
      9. </webadmin>
      So it seems ok for me. However, after a few minutes (I did not count it) of inactivity I am getting logged out from the OMV GUI. After rebooting the OMV system the situation does not change.
      Has someone a hint for me how to disable automatic logout?
      Thanks in advance,
      topi
      OpenMediaVault 3.x (most recent stable version) -- 64 bit -- OMV-Extras 3.x (most recent stable version) -- Default Kernel
    • DId you have applied the settings? Pressing the 'Save' button is not enough.
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • thanks @Wolf2000 and @votdev for your hints.
      I emptied the browser cache several times and I applied the settings change after pressing the save button. I even moved to a PC which has not had any contact to my OMV Erasmus system before. Unfortunately the issue remains. Meanwhile I could count the minutes after the OMV session in the web GUI times out: it is 5 minutes.
      It seems to me that value <timeout>0</timeout> in the config.xml is not taken in account. However, you may have some more hints for me?
      Thanks,
      topi
      OpenMediaVault 3.x (most recent stable version) -- 64 bit -- OMV-Extras 3.x (most recent stable version) -- Default Kernel
    • Hi there,
      meanwhile I realized that "5 minutes" is the default value for the timeout. However, I still have not found a solution for the issue. Perhaps someone wants to share a solution or a hint on how to disable the automatic session timeout?
      Thanks in advance,
      topi
      OpenMediaVault 3.x (most recent stable version) -- 64 bit -- OMV-Extras 3.x (most recent stable version) -- Default Kernel
    • Please post the output of

      Shell-Script

      1. # omv-confdbadm read --prettify "conf.webadmin"

      I can not confirm this behaviour, nor the code looks incorrect.
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • Thanks votdev for the instructions. Here the output of the command:

      Shell-Script

      1. # omv-confdbadm read --prettify "conf.webadmin"
      2. {
      3. "enablessl": false,
      4. "forcesslonly": false,
      5. "port": 80,
      6. "sslcertificateref": "",
      7. "sslport": 443,
      8. "timeout": 0
      9. }
      I hope this helps to track down the issue.
      Thanks,
      topi
      OpenMediaVault 3.x (most recent stable version) -- 64 bit -- OMV-Extras 3.x (most recent stable version) -- Default Kernel
    • Is your root file system full? I really can not reproduce this behaviour. The only possibility now is that PHP can not create the session file. This is my last idea.
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • Did you have checked /var/log/nginx/openmediavault-webgui_error.log for any hints?
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • Thanks votdev for diving into this issue.
      52% of my root file system are used. Following your suggestion, I took a look into /var/log/nginx/openmediavault-webgui_error.log and yes, I find several, repeating error messages there (see below).
      The permissions are:

      Shell-Script

      1. -rw-r--r-- 1 root root 1167 May 5 2017 configdirtyexception.inc
      2. -rw-r--r-- 1 root root 15279 May 5 2017 configobject.inc
      3. -rw-r--r-- 1 root root 18383 May 5 2017 databasebackend.inc
      4. -rw-r--r-- 1 root root 9297 Dec 1 15:32 databasebackendquerybuilder.inc
      5. -rw-r--r-- 1 root root 1036 May 5 2017 databaseexception.inc
      6. -rw-r--r-- 1 root root 16513 May 5 2017 database.inc
      7. -rw-r--r-- 1 root root 11730 May 5 2017 datamodel.inc

      How would I fix the permission (?) issue which is mentioned there?
      Thanks in advance,
      topi

      Source Code

      1. 2017/12/13 17:54:58 [error] 30089#0: *1759 FastCGI sent in stderr: "PHP message: PHP Warning: DOMDocument::load(/etc/openmediavault/config.xml): failed to open stream: Permission denied in /usr/share/php/openmediavault/config/databasebackend.inc on line 114
      2. PHP message: PHP Warning: DOMDocument::load(/etc/openmediavault/config.xml): failed to open stream: Permission denied in /usr/share/php/openmediavault/config/databasebackend.inc on line 114" while reading response header from upstream, client: 192.168.1.AAA, server: openmediavault-webgui, request: "POST /rpc.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm-openmediavault-webgui.sock:", host: "192.168.1.XX", referrer: "http://192.168.1.XX/"
      3. 2017/12/13 17:54:59 [error] 12724#0: *1 FastCGI sent in stderr: "PHP message: PHP Warning: DOMDocument::load(/etc/openmediavault/config.xml): failed to open stream: Permission denied in /usr/share/php/openmediavault/config/databasebackend.inc on line 114
      4. PHP message: PHP Warning: DOMDocument::load(/etc/openmediavault/config.xml): failed to open stream: Permission denied in /usr/share/php/openmediavault/config/databasebackend.inc on line 114" while reading response header from upstream, client: 192.168.1.AAA, server: openmediavault-webgui, request: "POST /rpc.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm-openmediavault-webgui.sock:", host: "192.168.1.XX", referrer: "http://192.168.1.XX/"
      5. 2017/12/13 17:55:00 [error] 12724#0: *1 FastCGI sent in stderr: "PHP message: PHP Warning: DOMDocument::load(/etc/openmediavault/config.xml): failed to open stream: Permission denied in /usr/share/php/openmediavault/config/databasebackend.inc on line 114
      6. PHP message: PHP Warning: DOMDocument::load(/etc/openmediavault/config.xml): failed to open stream: Permission denied in /usr/share/php/openmediavault/config/databasebackend.inc on line 114" while reading response header from upstream, client: 192.168.1.AAA, server: openmediavault-webgui, request: "POST /rpc.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm-openmediavault-webgui.sock:", host: "192.168.1.XX", referrer: "http://192.168.1.XX/"
      OpenMediaVault 3.x (most recent stable version) -- 64 bit -- OMV-Extras 3.x (most recent stable version) -- Default Kernel

      The post was edited 2 times, last by topi ().

    • Update the database permissions

      Shell-Script

      1. # chmod 660 /etc/openmediavault/config.xml
      2. # chown :openmediavault-config /etc/openmediavault/config.xml
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • Dear votdev,
      thank you very much for getting in this issue and finally fix it.
      It was:

      Shell-Script

      1. -rw-r----- 1 root root 55419 Dec 10 11:42 config.xml

      After applying your fixes (updating database permissions) it is:

      Shell-Script

      1. -rw-rw---- 1 root openmediavault-config 66344 Dec 14 15:16 config.xml
      No more error messages in /var/log/nginx/openmediavault-webgui_error.log and setting the session timeout to 0 disables the timeout now as intended :)
      OpenMediaVault 3.x (most recent stable version) -- 64 bit -- OMV-Extras 3.x (most recent stable version) -- Default Kernel
    • With openmediavault 4.0.15 the file permission of the database are updated on each package installation/update. This should prevent situations like yours. See github.com/openmediavault/open…c454034b55a7c4cbd493e6970.
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • topi wrote:

      Dear votdev,
      thank you very much for getting in this issue and finally fix it.
      It was:

      Shell-Script

      1. -rw-r----- 1 root root 55419 Dec 10 11:42 config.xml
      After applying your fixes (updating database permissions) it is:

      Shell-Script

      1. -rw-rw---- 1 root openmediavault-config 66344 Dec 14 15:16 config.xml
      Hi topi - I can see that I need to fix permissions of config.xml, but do you remember the exact command you used as I can't figure it out (sorry but a Windows person).
    • vinntec wrote:

      I can see that I need to fix permissions of config.xml, but do you remember the exact command you used as I can't figure it out (sorry but a Windows person).
      chown root:openmediavault-config /etc/openmediavault/config.xml
      chmod 660 /etc/openmediavault/config.xml
      omv 4.1.6 arrakis | 64 bit | 4.16 backports kernel | omvextrasorg 4.1.7
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please read this before posting a question.
      Please don't PM for support... Too many PMs!
    • Users Online 1

      1 Guest