Remoteplugin mountpoint is not empty fuse

    • OMV 2.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Remoteplugin mountpoint is not empty fuse

      Okay so im trying to add 2 remove ftpfs shares to my OMV

      Backups and Space

      If I add backups first works fine when I add a Space I get this error


      Source Code

      1. Failed to execute command 'omv-mkconf remoteshare 2>&1': fuse: mountpoint is not empty fuse: if you are sure this is safe, use the 'nonempty' mount option


      Source Code

      1. Error #4000:
      2. exception 'OMVException' with message 'Failed to execute command 'omv-mkconf remoteshare 2>&1': fuse: mountpoint is not empty
      3. fuse: if you are sure this is safe, use the 'nonempty' mount option' in /usr/share/openmediavault/engined/module/remoteshare.inc:101
      4. Stack trace:
      5. #0 /usr/share/openmediavault/engined/rpc/config.inc(180): OMVModuleRemoteShare->applyConfig()
      6. #1 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)
      7. #2 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      8. #3 /usr/share/php/openmediavault/rpcservice.inc(158): OMVRpcServiceAbstract->callMethod('applyChanges', Array, Array)
      9. #4 /usr/share/openmediavault/engined/rpc/config.inc(224): OMVRpcServiceAbstract->callMethodBg('applyChanges', Array, Array)
      10. #5 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array)
      11. #6 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      12. #7 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('applyChangesBg', Array, Array)
      13. #8 /usr/sbin/omv-engined(500): OMVRpc::exec('Config', 'applyChangesBg', Array, Array, 1)
      14. #9 {main}
      Display All
      But

      If I add Space first its works and if I than add Backups same error.

      So why does only one work no matter which order I add them and why is the second one allways giving me this error.
    • A couple of things...

      1 - The remoteshare plugin is bad. That is why I rewrote it for OMV 3.x but ftpfs isn't working in that version.
      2 - If the shared folder you are selecting to mount with is at the root of the drive (path = /) then it will never be empty. Also check for hidden files.
      omv 4.1.15 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!