Samba shares not accessible by enigma2-boxes after getting Win10 setup right

    • OMV 3.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Samba shares not accessible by enigma2-boxes after getting Win10 setup right

      I had a lot of problems having Windows 10 being able to see and access the samba shares. That is fine right now - using smb2...

      But this creates trouble with my enigma2-boxes. The shares are mounted and can be listed etc. But by the time a file is to be read (config-file or movie) there is not even a single bit reaching my boxes from the OMV-NAS samba share!?


      my smb.conf

      Source Code

      1. #======================= Global Settings =======================
      2. [global]
      3. workgroup = WORKGROUP
      4. server string = %h server
      5. dns proxy = no
      6. log level = 0
      7. syslog = 0
      8. log file = /var/log/samba/log.%m
      9. max log size = 1000
      10. syslog only = yes
      11. panic action = /usr/share/samba/panic-action %d
      12. encrypt passwords = true
      13. passdb backend = tdbsam
      14. obey pam restrictions = no
      15. unix password sync = no
      16. passwd program = /usr/bin/passwd %u
      17. passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
      18. pam password change = yes
      19. socket options = TCP_NODELAY IPTOS_LOWDELAY
      20. guest account = nobody
      21. load printers = no
      22. disable spoolss = yes
      23. printing = bsd
      24. printcap name = /dev/null
      25. unix extensions = yes
      26. wide links = no
      27. create mask = 0777
      28. directory mask = 0777
      29. use sendfile = yes
      30. aio read size = 16384
      31. aio write size = 16384
      32. null passwords = no
      33. local master = yes
      34. time server = no
      35. wins support = no
      36. client min protocol = SMB2
      37. client max protocol = SMB3
      38. server min protocol = SMB2
      39. #======================= Share Definitions =======================
      40. [Multimedia]
      41. path = /srv/dev-disk-by-label-HalutNASData/@Multimedia
      42. guest ok = no
      43. read only = no
      44. browseable = yes
      45. inherit acls = yes
      46. inherit permissions = no
      47. ea support = no
      48. store dos attributes = no
      49. vfs objects = recycle
      50. recycle:repository = .recycle/%U
      51. recycle:keeptree = yes
      52. recycle:versions = yes
      53. recycle:touch = yes
      54. recycle:directory_mode = 0777
      55. recycle:subdir_mode = 0700
      56. recycle:exclude =
      57. recycle:exclude_dir =
      58. recycle:maxsize = 0
      59. printable = no
      60. create mask = 0664
      61. force create mode = 0664
      62. directory mask = 0775
      63. force directory mode = 0775
      64. hide special files = yes
      65. follow symlinks = yes
      66. hide dot files = yes
      67. valid users = " 'user' "
      68. invalid users =
      69. read list =
      70. write list =
      Display All



      This is my fstab-entry for one share (enigma2-box):


      Source Code

      1. //192.168.0.23/Multimedia /srv/net-smb/movie/Multimedia cifs user='user',pass='passwd',_netdev,vers=2.1,rw,iocharset=utf8 0 0

      and this is what 'mount' shows me (enigma2-box):


      Source Code

      1. //192.168.0.23/Multimedia on /srv/net-smb/movie/Multimedia type cifs (rw,relatime,vers=2.1,sec=ntlmssp,cache=strict,unc=\\192.168.0.23\Multimedia,username='user',domain=NAS-OMV,uid=0,noforceuid,gid=0,noforcegid,addr=192.168.0.23,file_mode=0755,dir_mode=0755,nounix,serverino,rsize=65536,wsize=65536,actimeo=1)


      Help is deeply appreciated...