Jdownloader

    • OMV 4.x
    • No, didn't know this thread. Thanks for pointing me to this. Will have a closer look to it.
      OMV-Server-HW: MoBo Fujitsu D3417-B2 (Intel-LAN), Intel Pentium G4600 Kaby Lake, 8GB-Ram ECC UDIMM, 1x512GB SSD Samsung 850 Pro (sda2 - 25GB system, 4GB swap, sda5/rest - for work), 4x3TB WD Red's Snapraid w/ mergerfs, 2x DVB-S2 card DVBSky s952v3,

      OMV-Server-SW: Debian Stretch with 4.15.x-Backports-Kernel (always up-to-date), OMV 4.1.x (always latest), omv-extras-plugin (always latests), AutoShutdown-Plugin, Docker, Downloader (via Docker), PlexMediaServer (via Docker), SMB-Shares, TVHeadendServer (unstable release/via Docker)

      BackupServer: Synology DS1010+ with 4GB Ram, 9TB@SHR (different hdd's), DSM 5.2-5967-2
    • JDownloader works also without Docker!

      You can do this:

      cd /tmp
      apt-get install -t jessie-backports ca-certificates-java openjdk-8-jre-headless
      mkdir -p /opt/jdownloader
      cd /opt/jdownloader
      wget installer.jdownloader.org/JDownloader.jar
      java -jar JDownloader.jar -norestart

      You must restart JD 2-3 Times. When JD runs, CRTL-C

      Copy thist Start Script to /etc/systemd/system/ and Name it "jdownloader.service" You must change the User that uses JD!



      Source Code

      1. [Unit]
      2. Description=jdownloader
      3. After=network.target
      4. [Service]
      5. User=User
      6. Group=root
      7. CPUQuota=100%
      8. Type=simple
      9. UMask=000
      10. ExecStart=/usr/bin/java -Djava.awt.headless=true -jar /opt/jdownloader/JDownloader.jar
      11. Restart=always
      12. [Install]
      13. WantedBy=multi-user.target
      Display All

      Then:

      systemctl enable jdownloader.service
      systemctl start jdownloader.service


      Thats it. After restart the Server. JD works.
      Sorry for my bad English!!