Shares not showing up in Windows 10

    • OMV 3.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Shares not showing up in Windows 10

      Hello,
      my samba share is not showing up on windows 10 at all, i am running windows 10 build 17017.rs_prerelease.171010-1400. is there any configs i need to provide at all?
      when i try \\192.168.0.15 in windows explorer and i goto troubleshooting when it says it fails it reports back this error The device or resource (192.168.0.15) is not set up to accept connections on port "The File and printer sharing (SMB)".
      Thank You.

      UPDATE: i just downloaded and and now in the process of installing omv 4.0.14
      Dell Optiplex 755
      NAS Drive: WD Black Scorpio 230GB
      OS Drive: Toshiba 16GB USB
      CPU: Core 2 Duo E6550
      RAM: 2x 1GB Samsung DDR2, 1x 1GB Corsair XMS2 DDR2. Total: 3GB DDR2

      The post was edited 1 time, last by sudosudoo ().

    • revise SMB MaxServer & Client on OMV, NTLM is not supported anymore by SAMBA/CIFS
      OMV 4.1.11 x64 on a HP T510, 16GB CF as Boot Disk & 32GB SSD 2,5" disk for Data, 4 GB RAM, CPU VIA EDEN X2 U4200 is x64 at 1GHz

      Post: HPT510 SlimNAS ; HOWTO Install Pi-Hole ; HOWTO install MLDonkey ; HOHTO Install ZFS-Plugin ; OMV_OldGUI ; ShellinaBOX ;
      Dockers: MLDonkey ; PiHole ; weTTY
      Videos: @TechnoDadLife
    • perhaps your win10 try to use NTLM1 that is not supported by SAMBA, so you need to instruct Windows to use SMB3 that is more efficient , this can be done using " Client max protocol":

      see smb.conf rules: samba.org/samba/docs/man/manpages-3/smb.conf.5.html


      eg: copy & paste from smb.conf rules:

      Display Spoiler

      client max protocol (G)


      The value of the parameter (a string) is the highest protocol level that will be supported by the client.
      Possible values are :
      [*]CORE: Earliest version. No concept of user names.
      [*]COREPLUS: Slight improvements on CORE for efficiency.
      [*]LANMAN1: First modern version of the protocol. Long filename support.
      [*]LANMAN2: Updates to Lanman1 protocol.
      [*]NT1: Current up to date version of the protocol. Used by Windows NT. Known as CIFS.
      [*]SMB2: Re-implementation of the SMB protocol. Used by Windows Vista and later versions of Windows. SMB2 has sub protocols available.
      [*]SMB2_02: The earliest SMB2 version.
      [*]SMB2_10: Windows 7 SMB2 version.
      [*]SMB2_22: Early Windows 8 SMB2 version.
      [*]SMB2_24: Windows 8 beta SMB2 version.
      By default SMB2 selects the SMB2_10 variant.
      [*]SMB3: The same as SMB2. Used by Windows 8. SMB3 has sub protocols available.
      • SMB3_00: Windows 8 SMB3 version. (mostly the same as SMB2_24)
      By default SMB3 selects the SMB3_00 variant.
      Normally this option should not be set as the automatic negotiation phase in the SMB protocol takes care of choosing the appropriate protocol.
      Default: [i]client max protocol = SMB3[/i]
      Example: [i]client max protocol = LANMAN1[/i]
      client min protocol (G)


      This setting controls the minimum protocol version that the client will attempt to use.
      Normally this option should not be set as the automatic negotiation phase in the SMB protocol takes care of choosing the appropriate protocol.
      Default: [i]client min protocol = CORE[/i]
      Example: [i]client min protocol = NT1[/i]
      client NTLMv2 auth (G)


      This parameter determines whether or not smbclient(8) will attempt to authenticate itself to servers using the NTLMv2 encrypted password response.
      If enabled, only an NTLMv2 and LMv2 response (both much more secure than earlier versions) will be sent. Older servers (including NT4 < SP4, Win9x and Samba 2.2) are not compatible with NTLMv2 when not in an NTLMv2 supporting domain
      Similarly, if enabled, NTLMv1, client lanman auth and client plaintext auth authentication will be disabled. This also disables share-level authentication.
      If disabled, an NTLM response (and possibly a LANMAN response) will be sent by the client, depending on the value of client lanman auth.
      Note that Windows Vista and later versions already use NTLMv2 by default, and some sites (particularly those following 'best practice' security polices) only allow NTLMv2 responses, and not the weaker LM or NTLM.
      Default: [i]client NTLMv2 auth = yes[/i]
      client plaintext auth (G)


      Specifies whether a client should send a plaintext password if the server does not support encrypted passwords.
      Default: [i]client plaintext auth = no[/i]
      OMV 4.1.11 x64 on a HP T510, 16GB CF as Boot Disk & 32GB SSD 2,5" disk for Data, 4 GB RAM, CPU VIA EDEN X2 U4200 is x64 at 1GHz

      Post: HPT510 SlimNAS ; HOWTO Install Pi-Hole ; HOWTO install MLDonkey ; HOHTO Install ZFS-Plugin ; OMV_OldGUI ; ShellinaBOX ;
      Dockers: MLDonkey ; PiHole ; weTTY
      Videos: @TechnoDadLife
    • Edit: 18 March 2018:
      For help with seeing OMV shares with Windows 10, see this -> HOW TO.

      ___________________________________________________________________________________________________________

      The Samba protocol does an auto-negotiate that works most of the time but, as it is with anything "auto", there can be problems.
      Win10 can be problematic in that its' preferred protocol (depending on the installation) can be at the top end of the 3.XX range.

      The client "max" and "min" protocol settings restrict the negotiation process on the OMV side. Hopefully, you can find something to "bracket" what you need, with the info @raulfg3 provided to you, above.

      For instance:
      client min protocol = SMB2
      client max protocol = SMB2
      might work for you.

      You can try these parameters here:


      On the Win10 end of it, as it seems, there are command lines for power shell to turn SMB levels on and off. Since I don't have a Win10 client, I can't test them but I image they work. Nailing it down to SMB2 only, on both ends (OMV and Windows), would be an approach I might try.
      Good backup takes the "drama" out of computing
      ____________________________________
      Primary: OMV 3.0.99, ThinkServer TS140, 12GB ECC, 32GB USB boot, 4TB+4TB zmirror, 3TB client backup.
      Backup: OMV 4.1.9, Acer RC-111, 4GB, 32GB USB boot, 3TB+3TB zmirror, 4TB Rsync'ed disk
      2nd Data Backup: OMV 3.0.99, R-PI 2B, 16GB boot, 4TB WD USB MyPassport - direct connect (no hub)

      The post was edited 2 times, last by flmaxey: edit2 ().

    • raulfg3 wrote:

      perhaps your win10 try to use NTLM1 that is not supported by SAMBA, so you need to instruct Windows to use SMB3 that is more efficient , this can be done using " Client max protocol":

      see smb.conf rules: samba.org/samba/docs/man/manpages-3/smb.conf.5.html


      eg: copy & paste from smb.conf rules:

      Display Spoiler

      client max protocol (G)


      The value of the parameter (a string) is the highest protocol level that will be supported by the client.
      Possible values are :
      CORE: Earliest version. No concept of user names.
      COREPLUS: Slight improvements on CORE for efficiency.
      LANMAN1: First modern version of the protocol. Long filename support.
      LANMAN2: Updates to Lanman1 protocol.
      NT1: Current up to date version of the protocol. Used by Windows NT. Known as CIFS.
      SMB2: Re-implementation of the SMB protocol. Used by Windows Vista and later versions of Windows. SMB2 has sub protocols available.
      SMB2_02: The earliest SMB2 version.
      SMB2_10: Windows 7 SMB2 version.
      SMB2_22: Early Windows 8 SMB2 version.
      SMB2_24: Windows 8 beta SMB2 version.
      By default SMB2 selects the SMB2_10 variant.
      SMB3: The same as SMB2. Used by Windows 8. SMB3 has sub protocols available.
      • SMB3_00: Windows 8 SMB3 version. (mostly the same as SMB2_24)
      By default SMB3 selects the SMB3_00 variant.
      Normally this option should not be set as the automatic negotiation phase in the SMB protocol takes care of choosing the appropriate protocol.
      Default: client max protocol = SMB3[/i]
      Example: client max protocol = LANMAN1[/i]
      client min protocol (G)


      This setting controls the minimum protocol version that the client will attempt to use.
      Normally this option should not be set as the automatic negotiation phase in the SMB protocol takes care of choosing the appropriate protocol.
      Default: client min protocol = CORE[/i]
      Example: client min protocol = NT1[/i]
      client NTLMv2 auth (G)


      This parameter determines whether or not smbclient(8) will attempt to authenticate itself to servers using the NTLMv2 encrypted password response.
      If enabled, only an NTLMv2 and LMv2 response (both much more secure than earlier versions) will be sent. Older servers (including NT4 < SP4, Win9x and Samba 2.2) are not compatible with NTLMv2 when not in an NTLMv2 supporting domain
      Similarly, if enabled, NTLMv1, client lanman auth and client plaintext auth authentication will be disabled. This also disables share-level authentication.
      If disabled, an NTLM response (and possibly a LANMAN response) will be sent by the client, depending on the value of client lanman auth.
      Note that Windows Vista and later versions already use NTLMv2 by default, and some sites (particularly those following 'best practice' security polices) only allow NTLMv2 responses, and not the weaker LM or NTLM.
      Default: client NTLMv2 auth = yes[/i]
      client plaintext auth (G)


      Specifies whether a client should send a plaintext password if the server does not support encrypted passwords.
      Default: client plaintext auth = no[/i]

      flmaxey wrote:

      The Samba protocol does an auto-negotiate that works most of the time but, as it is with anything "auto", there can be problems.
      Win10 can be problematic in that its' preferred protocol (depending on the installation) can be at the top end of the 3.XX range.

      The client "max" and "min" protocol settings restrict the negotiation process on the OMV side. Hopefully, you can find something to "bracket" what you need, with the info @raulfg3 provided to you, above.

      For instance:
      client min protocol = SMB2
      client max protocol = SMB2
      might work for you.

      You can try these parameters here:


      On the Win10 end of it, as it seems, there are command lines for power shell to turn SMB levels on and off. Since I don't have a Win10 client, I can't test them but I image they work. Nailing it down to SMB2 only, on both ends (OMV and Windows), would be an approach I might try.
      i did get the shares to work, having users set to not being able to access the share at all caused it to not show up, users needed to have read only access. also i think i had a currupt install of omv because the usb i was using had heaps of water damage and it works like only 10% of the time.
      Dell Optiplex 755
      NAS Drive: WD Black Scorpio 230GB
      OS Drive: Toshiba 16GB USB
      CPU: Core 2 Duo E6550
      RAM: 2x 1GB Samsung DDR2, 1x 1GB Corsair XMS2 DDR2. Total: 3GB DDR2
    • sudosudoo wrote:

      i did get the shares to work, having users set to not being able to access the share at all caused it to not show up, users needed to have read only access. also i think i had a currupt install of omv because the usb i was using had heaps of water damage and it works like only 10% of the time.
      Well, from a support point of view (as in trying to provide it) I didn't see that one coming. :) I have to ask, why did you think shares would show up for users who don't have access to them?

      And as a rule of thumb, electronics don't like water. Building on storage media that has been damaged is, generally, not a good idea.
      Good backup takes the "drama" out of computing
      ____________________________________
      Primary: OMV 3.0.99, ThinkServer TS140, 12GB ECC, 32GB USB boot, 4TB+4TB zmirror, 3TB client backup.
      Backup: OMV 4.1.9, Acer RC-111, 4GB, 32GB USB boot, 3TB+3TB zmirror, 4TB Rsync'ed disk
      2nd Data Backup: OMV 3.0.99, R-PI 2B, 16GB boot, 4TB WD USB MyPassport - direct connect (no hub)
    • flmaxey wrote:

      sudosudoo wrote:

      i did get the shares to work, having users set to not being able to access the share at all caused it to not show up, users needed to have read only access. also i think i had a currupt install of omv because the usb i was using had heaps of water damage and it works like only 10% of the time.
      Well, from a support point of view (as in trying to provide it) I didn't see that one coming. :) I have to ask, why did you think shares would show up for users who don't have access to them?
      And as a rule of thumb, electronics don't like water. Building on storage media that has been damaged is, generally, not a good idea.
      i didnt think the shares themselves would show up for users who cant access them but i did think the nas would show up in Network but it would ask for a password to view the shares. it asks for a password to view the shares as long as users and other is set to read only.
      Dell Optiplex 755
      NAS Drive: WD Black Scorpio 230GB
      OS Drive: Toshiba 16GB USB
      CPU: Core 2 Duo E6550
      RAM: 2x 1GB Samsung DDR2, 1x 1GB Corsair XMS2 DDR2. Total: 3GB DDR2
    • Hi,

      I just reinstalled my WIN 10 desktop and I cannot see any of my shares on my OMV server (v3.2.0-6-amd64). I tried:
      - same workgroup, also changed from my own to WIN default.
      - ping to server still works fine
      - my linux mint laptop CAN see all shares properly
      - in OMV SMB/CIFS I added Extra Options:
      client min protocol = SMB2
      client max protocol = SMB3
      - in WIN 10 samba entries was added to registers according thread "HOW-TO-Connect-to-OMV-SMB-shares-with-Windows-10..."
      - in WIN 10, I use MSA credential (this was not in previous WIN 10 install) - I tried also add my OMV users to local win credentials for server IP and separately for server name
      - when I try to connect manually to server I receive error reffering that connection is not safe and uses SMB1, see picture. Why windows thinks of that? Do I do something wrong?

      Do you have any ideas what else should I try? I spent many hours with this and I'm confused. I just used brand new install of win 10 pro, activated by original key, iso image was from microsoft.

      Thanks a lot for suggestions.

      EDIT:
      I just find, that I used wrong string: "server min protocol = SMB2". I tried as mentioned above "client min protocol = SMB2", but I get result in Diagnostics>Services>SMB/CIFS:
      Ignoring unknown parameter "client min protocol"
      Unknown parameter encountered: "client max protocol"
      Ignoring unknown parameter "client max protocol"
      I just added this to shares as well, but result is still unknown parameters

      EDIT2:
      Only one thing helped - enable SMB1 in WIN 10, but this is not what I'm looking for due to safety reasons. How can I force SMB2 on both sides? Why does OMV's samba ignore my client min protocol value?


      Source Code

      1. # cat /etc/samba/smb.conf
      2. #======================= Global Settings =======================
      3. [global]
      4. workgroup = WORKGROUP
      5. server string = %h server
      6. dns proxy = no
      7. log level = 2
      8. syslog = 2
      9. log file = /var/log/samba/log.%m
      10. max log size = 1000
      11. syslog only = yes
      12. panic action = /usr/share/samba/panic-action %d
      13. encrypt passwords = true
      14. passdb backend = tdbsam
      15. obey pam restrictions = yes
      16. unix password sync = no
      17. passwd program = /usr/bin/passwd %u
      18. passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
      19. pam password change = yes
      20. socket options = TCP_NODELAY IPTOS_LOWDELAY
      21. guest account = nobody
      22. load printers = no
      23. disable spoolss = yes
      24. printing = bsd
      25. printcap name = /dev/null
      26. unix extensions = yes
      27. wide links = no
      28. create mask = 0777
      29. directory mask = 0777
      30. use sendfile = yes
      31. aio read size = 16384
      32. aio write size = 16384
      33. null passwords = no
      34. local master = yes
      35. time server = no
      36. wins support = yes
      37. client min protocol = SMB2
      38. client max protocol = SMB3
      39. #======================= Share Definitions =======================
      40. [Foto]
      41. path = /media/307C1DF37C1DB516/02 - Foto/
      42. guest ok = no
      43. read only = no
      44. browseable = yes
      45. inherit acls = yes
      46. inherit permissions = no
      47. ea support = no
      48. store dos attributes = no
      49. printable = no
      50. create mask = 0755
      51. force create mode = 0644
      52. directory mask = 0755
      53. force directory mode = 0755
      54. hide dot files = yes
      55. valid users = "user1","user0"
      56. invalid users =
      57. read list = "user1"
      58. write list = "user0"
      Display All
      Images
      • Capture.PNG

        5.52 kB, 493×73, viewed 115 times

      The post was edited 4 times, last by Steuko: I just find, that I used wrong string: "server min protocol = SMB2". I tried as mentioned above "client min protocol = SMB2", but I get result in Diagnostics>Services>SMB/CIFS: Ignoring unknown parameter "client min protocol" Unknown parameter encountered: "client max protocol" Ignoring unknown parameter "client max protocol" I just added this to shares as well, but result is still unknown parameters ().

    • If you have an Internet connected client, enabling SMB1 in Win10 is not a good idea. The only scenario where I'd consider it, along with running older clients like Win XP, would be in a business network with no outside connection to the Net.

      Samba (SMB) protocols are automatically negotiated. Win10 clients (and others down to Win7 for that matter) will no longer connect to SMB1 shares if their security patches are up-to-date. Similarly, if a Windows machine is hosting a Network share (as a server), Windows Clients or Servers they won't accept remote SMB1 connections to their shares.
      _________________________________________________________________________________

      As a note - the HOW-TO is geared toward shares being on the OMV server. Further, the How-To is for simple peer-to-peer, networking. Along those lines, I noted the following with interest:

      Steuko wrote:

      - in WIN 10, I use MSA credential (this was not in previous WIN 10 install) - I tried also add my OMV users to local win credentials for server IP and separately for server name

      MSA accounts/credentials are stored on external M$ servers and require synchronization. They are an entirely different approach to network client machine access which is, as far as I know, Proprietary. ((I have no idea of how using this sign-on method would affect network share access and authentication. It may, require/force a higher level SMB3 protocol.))
      If you can figure out a way to get MSA accounts/credentials to work with OMV, please share it on the forum in a How-To.

      Going back the scenario with Network shares on OMV, being accessed by a Win10 client in peer to peer networking:
      Setting SMB parameters in OMV is not required. Until the access problems are fixed, I'd remove them.
      _______________________________________________________________________________________\

      I looked over you Samba config's and noted both read and write lists on the network share. Without knowing what the permissions are on the underlying shared folder, all that could be done is idle speculation.

      In the bottom line, I suspect that the access problems are due to a combination of settings and permissions issues.

      - First, if you want OMV to work with Windows 10, use only local log-on accounts. (Dump the MSA account.)
      (And while it's not the most secure approach, I duplicate Windows usernames and passwords on OMV. This allows the Windows user to transparently access OMV network shares with the same access as the OMV user.)
      - Next, I'd reduce the permissions complexity, using only Owner, Group and Others on my shared folders (No ACL's).
      - Until the problems are sorted out, I'd drop the SMB share read / write lists, "valid users", etc..
      - The Client/Server min/max protocol settings in OMV's Extra Options are not required. If the registry settings in Windows 10 are set to force SMB2 (see the How-To), OMV will accept the connection.

      Lastly, run through the How-To again. I have yet to hear from anyone who, after running through the settings, couldn't map a shared drive to OMV and create a working short cut.

      (Note, for follow up, that I'm only home on weekends.)
      Good backup takes the "drama" out of computing
      ____________________________________
      Primary: OMV 3.0.99, ThinkServer TS140, 12GB ECC, 32GB USB boot, 4TB+4TB zmirror, 3TB client backup.
      Backup: OMV 4.1.9, Acer RC-111, 4GB, 32GB USB boot, 3TB+3TB zmirror, 4TB Rsync'ed disk
      2nd Data Backup: OMV 3.0.99, R-PI 2B, 16GB boot, 4TB WD USB MyPassport - direct connect (no hub)
    • Steuko wrote:

      Hi,

      I just reinstalled my WIN 10 desktop and I cannot see any of my shares on my OMV server (v3.2.0-6-amd64). I tried:
      - same workgroup, also changed from my own to WIN default.
      - ping to server still works fine
      - my linux mint laptop CAN see all shares properly
      - in OMV SMB/CIFS I added Extra Options:
      client min protocol = SMB2
      client max protocol = SMB3
      - in WIN 10 samba entries was added to registers according thread "HOW-TO-Connect-to-OMV-SMB-shares-with-Windows-10..."
      - in WIN 10, I use MSA credential (this was not in previous WIN 10 install) - I tried also add my OMV users to local win credentials for server IP and separately for server name
      - when I try to connect manually to server I receive error reffering that connection is not safe and uses SMB1, see picture. Why windows thinks of that? Do I do something wrong?

      Do you have any ideas what else should I try? I spent many hours with this and I'm confused. I just used brand new install of win 10 pro, activated by original key, iso image was from microsoft.

      Thanks a lot for suggestions.

      EDIT:
      I just find, that I used wrong string: "server min protocol = SMB2". I tried as mentioned above "client min protocol = SMB2", but I get result in Diagnostics>Services>SMB/CIFS:
      Ignoring unknown parameter "client min protocol"
      Unknown parameter encountered: "client max protocol"
      Ignoring unknown parameter "client max protocol"
      I just added this to shares as well, but result is still unknown parameters

      EDIT2:
      Only one thing helped - enable SMB1 in WIN 10, but this is not what I'm looking for due to safety reasons. How can I force SMB2 on both sides? Why does OMV's samba ignore my client min protocol value?


      Source Code

      1. # cat /etc/samba/smb.conf
      2. #======================= Global Settings =======================
      3. [global]
      4. workgroup = WORKGROUP
      5. server string = %h server
      6. dns proxy = no
      7. log level = 2
      8. syslog = 2
      9. log file = /var/log/samba/log.%m
      10. max log size = 1000
      11. syslog only = yes
      12. panic action = /usr/share/samba/panic-action %d
      13. encrypt passwords = true
      14. passdb backend = tdbsam
      15. obey pam restrictions = yes
      16. unix password sync = no
      17. passwd program = /usr/bin/passwd %u
      18. passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
      19. pam password change = yes
      20. socket options = TCP_NODELAY IPTOS_LOWDELAY
      21. guest account = nobody
      22. load printers = no
      23. disable spoolss = yes
      24. printing = bsd
      25. printcap name = /dev/null
      26. unix extensions = yes
      27. wide links = no
      28. create mask = 0777
      29. directory mask = 0777
      30. use sendfile = yes
      31. aio read size = 16384
      32. aio write size = 16384
      33. null passwords = no
      34. local master = yes
      35. time server = no
      36. wins support = yes
      37. client min protocol = SMB2
      38. client max protocol = SMB3
      39. #======================= Share Definitions =======================
      40. [Foto]
      41. path = /media/307C1DF37C1DB516/02 - Foto/
      42. guest ok = no
      43. read only = no
      44. browseable = yes
      45. inherit acls = yes
      46. inherit permissions = no
      47. ea support = no
      48. store dos attributes = no
      49. printable = no
      50. create mask = 0755
      51. force create mode = 0644
      52. directory mask = 0755
      53. force directory mode = 0755
      54. hide dot files = yes
      55. valid users = "user1","user0"
      56. invalid users =
      57. read list = "user1"
      58. write list = "user0"
      Display All
      its been a while but i only fixed it by upgrading to OMV 4.x
      Dell Optiplex 755
      NAS Drive: WD Black Scorpio 230GB
      OS Drive: Toshiba 16GB USB
      CPU: Core 2 Duo E6550
      RAM: 2x 1GB Samsung DDR2, 1x 1GB Corsair XMS2 DDR2. Total: 3GB DDR2