Error: openmediavault-update-smart-drivedb

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Error: openmediavault-update-smart-drivedb

      I receive the following error message by mail:

      /etc/cron.weekly/openmediavault-update-smart-drivedb:
      mesg: ttyname failed: Unpassender IOCTL (I/O-Control) fürdas Gerät


      A query with smartctl provides the following information for only a drive:
      === START OF INFORMATION SECTION ===
      Device Model: WDC WD800AAJB-00J3A0
      Serial Number: WD-.................
      LU WWN Device Id: 5 0014ee 206df06af
      Firmware Version: 01.03E01
      User Capacity: 80.026.361.856 bytes [80,0 GB]
      Sector Size: 512 bytes logical/physical
      Device is: Not in smartctl database [for details use: -P showall]
      ATA Version is: ATA8-ACS (minor revision not indicated)
      Transport Type: Parallel, ATA8-APT
      Local Time is: Wed Dec 27 23:28:51 2017 CET
      SMART support is: Available - device has SMART capability.
      SMART support is: Enabled

      All other drives have: Device is: In smartctl database

      How can I update the database?
    • Error: openmediavault-update-smart-drivedb

      The database thing is new to me. I also saw the first part of the message:

      mesg: ttyname failed: Inappropriate ioctl for device

      I think this won’t help you.

      Greetings Hoppel
      ---------------------------------------------------------------------------------------------------------------
      frontend software - android tv | libreelec | win10 | kodi krypton
      frontend hardware - nvidia shield tv | odroid c2 | yamaha rx-a1020 | quadral chromium style 5.1 | samsung le40-a789r2 | harmony smart control
      -------------------------------------------
      backend software - debian | kernel 4.4 lts | proxmox | openmediavault | zfs raid-z2 | docker | emby | vdr | vnsi | fhem
      backend hardware - supermicro x11ssh-ctf | xeon E3-1240L-v5 | 64gb ecc | 8x4tb wd red | digital devices max s8
      ---------------------------------------------------------------------------------------------------------------------------------------

      The post was edited 1 time, last by hoppel118 ().

    • You may need to update your database:

      Source: manpages.debian.org/stretch/sm…e-smart-drivedb.8.en.html
      ---------------------------------------------------------------------------------------------------------------------
      French, so forgive my english
      Personal Rig: valid.x86.fr/v72uek as a test bench with Oracle VM.
      And YES, my avatar is real, i am flying "parapentes" in St Hilaire du Touvet and at la coupe icare.
    • I get similar Error Messages every night. Something seems strange with the cron and anacron jobs.


      Some examples:
      I w mails at the same time
      Mail1, everthing fine:

      Source Code

      1. CRON-APT RUN [/etc/cron-apt/config]: Sun Jan 7 00:07:38 CET 2018 CRON-APT SLEEP: 653, Sun Jan 7 00:18:31 CET 2018 CRON-APT ACTION: 3-download CRON-APT LINE: /usr/bin/apt-get -o Acquire::http::Dl-Limit=25 dist-upgrade -d -y -o APT::Get::Show-Upgraded=true Reading package lists...
      2. Building dependency tree...
      3. Reading state information...
      4. Calculating upgrade...
      5. The following NEW packages will be installed:
      6. linux-image-4.14.0-0.bpo.2-amd64
      7. The following packages will be upgraded:
      8. linux-image-amd64
      9. 1 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
      10. Need to get 0 B/41.0 MB of archives.
      11. After this operation, 198 MB of additional disk space will be used.
      12. Download complete and in download only mode
      Display All

      Mail2, stating error:

      Source Code

      1. /etc/cron.daily/openmediavault-cron-apt:
      2. mesg: ttyname failed: Unpassender IOCTL (I/O-Control) für das Gerät
      Corresponding Log-Entrys:

      Source Code

      1. Jan 7 00:09:01 OpenMediaVaultServer CRON[27313]: (root) CMD ( [ -x /usr/lib/php/sessionclean ] && if [ ! -d /run/systemd/system ]; then /usr/lib/php/sessionclean; fi)
      2. Jan 7 00:09:08 OpenMediaVaultServer systemd[1]: Starting Clean php session files...
      3. Jan 7 00:09:08 OpenMediaVaultServer systemd[1]: Started Clean php session files.
      4. Jan 7 00:15:01 OpenMediaVaultServer CRON[27439]: (root) CMD (/usr/sbin/omv-mkrrdgraph >/dev/null 2>&1)
      5. Jan 7 00:15:01 OpenMediaVaultServer CRON[27440]: (root) CMD (command -v debian-sa1 > /dev/null && debian-sa1 1 1)
      6. Jan 7 00:17:01 OpenMediaVaultServer CRON[27554]: (root) CMD ( cd / && run-parts --report /etc/cron.hourly)
      7. Jan 7 00:18:55 OpenMediaVaultServer cron-apt: CRON-APT RUN [/etc/cron-apt/config]: Sun Jan 7 00:07:38 CET 2018
      8. Jan 7 00:18:55 OpenMediaVaultServer cron-apt: CRON-APT SLEEP: 653, Sun Jan 7 00:18:31 CET 2018
      9. Jan 7 00:18:55 OpenMediaVaultServer cron-apt: CRON-APT ACTION: 0-update
      10. Jan 7 00:18:55 OpenMediaVaultServer cron-apt: CRON-APT LINE: /usr/bin/apt-get -o Acquire::http::Dl-Limit=25 update -o quiet=2
      11. Jan 7 00:18:55 OpenMediaVaultServer cron-apt: Exception ignored in: <function WeakValueDictionary.__init__.<locals>.remove at 0x7fa1c50476a8>
      12. Jan 7 00:18:55 OpenMediaVaultServer cron-apt: Traceback (most recent call last):
      13. Jan 7 00:18:55 OpenMediaVaultServer cron-apt: File "/usr/lib/python3.5/weakref.py", line 117, in remove
      14. Jan 7 00:18:55 OpenMediaVaultServer cron-apt: TypeError: 'NoneType' object is not callable
      15. Jan 7 00:18:55 OpenMediaVaultServer cron-apt: Exception ignored in: <function WeakValueDictionary.__init__.<locals>.remove at 0x7fa1c50476a8>
      16. Jan 7 00:18:55 OpenMediaVaultServer cron-apt: Traceback (most recent call last):
      17. Jan 7 00:18:55 OpenMediaVaultServer cron-apt: File "/usr/lib/python3.5/weakref.py", line 117, in remove
      18. Jan 7 00:18:55 OpenMediaVaultServer cron-apt: TypeError: 'NoneType' object is not callable
      19. Jan 7 00:18:55 OpenMediaVaultServer cron-apt: W: Failed to fetch https://openmediavault.github.io/packages/dists/arrakis/InRelease Could not resolve host: openmediavault.github.io
      20. Jan 7 00:18:55 OpenMediaVaultServer cron-apt: W: Some index files failed to download. They have been ignored, or old ones used instead.
      21. Jan 7 00:18:55 OpenMediaVaultServer cron-apt: CRON-APT ACTION: 3-download
      22. Jan 7 00:18:55 OpenMediaVaultServer cron-apt: CRON-APT LINE: /usr/bin/apt-get -o Acquire::http::Dl-Limit=25 autoclean -y
      23. Jan 7 00:18:55 OpenMediaVaultServer cron-apt: Reading package lists...
      24. Jan 7 00:18:55 OpenMediaVaultServer cron-apt: Building dependency tree...
      25. Jan 7 00:18:55 OpenMediaVaultServer cron-apt: Reading state information...
      26. Jan 7 00:18:56 OpenMediaVaultServer cron-apt: CRON-APT LINE: /usr/bin/apt-get -o Acquire::http::Dl-Limit=25 dist-upgrade -d -y -o APT::Get::Show-Upgraded=true
      27. Jan 7 00:18:56 OpenMediaVaultServer cron-apt: Reading package lists...
      28. Jan 7 00:18:56 OpenMediaVaultServer cron-apt: Building dependency tree...
      29. Jan 7 00:18:56 OpenMediaVaultServer cron-apt: Reading state information...
      30. Jan 7 00:18:56 OpenMediaVaultServer cron-apt: Calculating upgrade...
      31. Jan 7 00:18:56 OpenMediaVaultServer cron-apt: The following NEW packages will be installed:
      32. Jan 7 00:18:56 OpenMediaVaultServer cron-apt: linux-image-4.14.0-0.bpo.2-amd64
      33. Jan 7 00:18:56 OpenMediaVaultServer cron-apt: The following packages will be upgraded:
      34. Jan 7 00:18:56 OpenMediaVaultServer cron-apt: linux-image-amd64
      35. Jan 7 00:18:56 OpenMediaVaultServer cron-apt: 1 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
      36. Jan 7 00:18:56 OpenMediaVaultServer cron-apt: Need to get 0 B/41.0 MB of archives.
      37. Jan 7 00:18:56 OpenMediaVaultServer cron-apt: After this operation, 198 MB of additional disk space will be used.
      38. Jan 7 00:18:56 OpenMediaVaultServer cron-apt: Download complete and in download only mode
      39. Jan 7 00:18:56 OpenMediaVaultServer postfix/pickup[24297]: 176E1C13E8: uid=0 from=<root>
      40. Jan 7 00:18:56 OpenMediaVaultServer postfix/cleanup[28350]: 176E1C13E8: message-id=<20180106231856.176E1C13E8@OpenMediaVaultServer.localdomain>
      41. Jan 7 00:18:56 OpenMediaVaultServer postfix/qmgr[2133]: 176E1C13E8: from=<Hotzenasstatus@gmail.com>, size=1126, nrcpt=2 (queue active)
      42. Jan 7 00:18:56 OpenMediaVaultServer postfix/pipe[28369]: 176E1C13E8: to=<openmediavault-notification@localhost.localdomain>, relay=omvnotificationfilter, delay=0.03, delays=0.02/0/0/0.01, dsn=2.0.0, status=sent (delivered via omvnotificationfilter service)
      43. Jan 7 00:18:56 OpenMediaVaultServer anacron[27115]: Job `cron.daily' terminated (mailing output)
      44. Jan 7 00:18:56 OpenMediaVaultServer postfix/pickup[24297]: 2064EC13ED: uid=0 from=<root>
      45. Jan 7 00:18:56 OpenMediaVaultServer postfix/cleanup[28350]: 2064EC13ED: message-id=<20180106231856.2064EC13ED@OpenMediaVaultServer.localdomain>
      46. Jan 7 00:18:56 OpenMediaVaultServer anacron[27115]: Normal exit (1 job run)
      47. Jan 7 00:18:56 OpenMediaVaultServer systemd[1]: anacron.timer: Adding 3min 357.388ms random time.
      48. Jan 7 00:18:56 OpenMediaVaultServer postfix/qmgr[2133]: 2064EC13ED: from=<XXX@gmail.com>, size=534, nrcpt=2 (queue active)
      49. Jan 7 00:18:56 OpenMediaVaultServer postfix/pipe[28369]: 2064EC13ED: to=<openmediavault-notification@localhost.localdomain>, relay=omvnotificationfilter, delay=0.01, delays=0/0/0/0.01, dsn=2.0.0, status=sent (delivered via omvnotificationfilter service)
      50. Jan 7 00:18:56 OpenMediaVaultServer postfix/smtp[28368]: connect to smtp.googlemail.com[2a00:1450:4013:c05::10]:587: Network is unreachable
      51. Jan 7 00:18:57 OpenMediaVaultServer postfix/smtp[28368]: 176E1C13E8: replace: header Subject: CRON-APT completed on OpenMediaVaultServer [/etc/cr: Subject: [OpenMediaVaultServer] CRON-APT completed on OpenMediaVaultServer [/etc/cron-apt/config]
      52. Jan 7 00:18:57 OpenMediaVaultServer postfix/smtp[28395]: 2064EC13ED: replace: header Subject: Anacron job 'cron.daily' on OpenMediaVaultServer: Subject: [OpenMediaVaultServer] Anacron job 'cron.daily' on OpenMediaVaultServer
      53. Then theres only Postfix lines generating the mails above.....
      Display All

      Bottomline:

      I get a lot of "mesg: ttyname failed: Unpassender IOCTL (I/O-Control) für das Gerät" Error messages related to anacron (even if not activated) and I aswell don't know where to start.
    • Error: openmediavault-update-smart-drivedb

      @Hotzenplotz78

      Have a look at the link I posted above. Some other guys and I had the same error as you.

      Greetings Hoppel
      ---------------------------------------------------------------------------------------------------------------
      frontend software - android tv | libreelec | win10 | kodi krypton
      frontend hardware - nvidia shield tv | odroid c2 | yamaha rx-a1020 | quadral chromium style 5.1 | samsung le40-a789r2 | harmony smart control
      -------------------------------------------
      backend software - debian | kernel 4.4 lts | proxmox | openmediavault | zfs raid-z2 | docker | emby | vdr | vnsi | fhem
      backend hardware - supermicro x11ssh-ctf | xeon E3-1240L-v5 | 64gb ecc | 8x4tb wd red | digital devices max s8
      ---------------------------------------------------------------------------------------------------------------------------------------
    • Error: openmediavault-update-smart-drivedb

      For me it works as expected. So it should also work for you. ;)

      Greetings Hoppel
      ---------------------------------------------------------------------------------------------------------------
      frontend software - android tv | libreelec | win10 | kodi krypton
      frontend hardware - nvidia shield tv | odroid c2 | yamaha rx-a1020 | quadral chromium style 5.1 | samsung le40-a789r2 | harmony smart control
      -------------------------------------------
      backend software - debian | kernel 4.4 lts | proxmox | openmediavault | zfs raid-z2 | docker | emby | vdr | vnsi | fhem
      backend hardware - supermicro x11ssh-ctf | xeon E3-1240L-v5 | 64gb ecc | 8x4tb wd red | digital devices max s8
      ---------------------------------------------------------------------------------------------------------------------------------------
    • @daniel.971 The fix he meant was that:

      votdev wrote:

      The issue is explained here and here and is no problem, it simply creates an annoying output, nothing more.

      A simple fix may be to edit /root/.profile and replace

      Shell-Script

      1. mesg n || true
      with

      Shell-Script

      1. test -t 0 && mesg n || true

      @hoppel118

      It worked for me, the message is gone, only valid messages got through.
      But just to get me smarter than before: What did I do with that? I don't understand all parts of the command......
    • Users Online 1

      1 Guest