Zoneminder

    • ZoneMinder is a free video camera security application suite, I want to install this in OMV.
      There's is upport for Debian you can install it with the following command: apt-get install zoneminder
      But after finishing the setup you can access the management page from IP/zm, but then I recieve an 404 error.
      Does anybody else has experience with this software?
    • Re: Zoneminder

      I have no experience with this, but I imagine that you would could use the website plugin to help. You would probably define the web files as a share and then point the website plugin to them. Port redirection would get you to the web files (ip:1234). The Opencloud forum might provide enough clues for you.
    • Re: Zoneminder

      This piqued my interest (I have an old IP camera) so I had a go.

      Steps to install
      1) Login and get root
      2) apt-get install zoneminder
      3) cd /etc/apache2/sites-available
      4) cat > zoneminder (and cut/paste the following)

      <VirtualHost *:8282>
      UseCanonicalName Off
      DirectoryIndex index.html index.htm index.php index.cgi index.pl
      ServerSignature Off
      DocumentRoot /usr/share/zoneminder
      ErrorLog ${APACHE_LOG_DIR}/zoneminder-vhost_error.log
      CustomLog ${APACHE_LOG_DIR}/zoneminder-vhost_access.log combined
      Alias /zm /usr/share/zoneminder
      <Directory /usr/share/zoneminder>
      php_flag register_globals off
      Options Indexes FollowSymLinks
      <IfModule mod_dir.c>
      DirectoryIndex index.php
      </IfModule>
      </Directory>
      </VirtualHost>

      5) Append the following line to /etc/apache2/ports.conf

      Listen 8282

      6) cd /etc/apache2/sites-enabled
      7) ln -s ../sites-available/zoneminder zoneminder
      8) service apache2 restart

      Then open your_OMV_ip:8282

      Behold, Zoneminder :)
    • Re: Zoneminder

      Another problem I found...

      Barring the fact Zoneminder installs "everything" (check the apt-get dependency list), when I removed it, I started getting CRON errors for some reason.
      To solve those, I apparently screwed up the apache2/pam-auth mod.

      The fix (if you find you can't login the webgui after removing zoneminder and trying to cure log errors) is here :

      forums.openmediavault.org/view…hp?f=3&t=350&p=1078#p1078
    • Re: Zoneminder

      Hi....

      I have installed zoneminder. Now I see the problems with the web gui. I can not change the setings.

      I see @ptruman find the reason for it. Have someone try to change the fault ?
      In ubuntu runs zoneminder 1.25 without any problems. Is there a chance to do it in omv too ?
      I need zoneminder for my ip cams. Also zfs file system will be a nice way to include in omv.
      To build a raid system with it.

      Greetings

      drnorton.
    • Re: Zoneminder

      Having the same problems with the settings as drnorton and ptruman above: you can click on the Settings tab, but nothing happens (the main page of zoneminder does load, but see JS errors below). I've tried downloading mootools 1.4.0 as per bugs.debian.org/cgi-bin/bugreport.cgi?bug=643300#25. Also tried with mootools 1.2.5:

      Source Code

      1. wget http://mootools.net/download/get/mootools-core-1.2.5-core-nc.js
      2. mv mootools-core-1.2.5-full-nocompat.js /usr/share/javascript/mootools/mootools-core-nc.js

      but no luck.

      The browser's JS console does show upon loading the main zoneminder page this set of errors:

      Source Code

      1. GET http://192.168.0.217/javascript/mootools/mootools.js 404 (Not Found) 192.168.0.217:10
      2. GET http://192.168.0.217/javascript/mootools/mootools-more.js 404 (Not Found) 192.168.0.217:10
      3. Uncaught TypeError: Object [object Window] has no method 'addEvent' console.js:65

      The files themselves *are* present in /usr/share/zoneminder/javascript/mootools, but it appears the server doesn't send them to the browser. So I'm guessing there's either a permissions problem, or a config problem of Apache that it can't find mootools. I have no clue on how to address apache problems though. I've made sure the video user is in the www-data group (was suggested in the bug report linked at the start of this post):

      Source Code

      1. usermod -a -G video www-data

      But this did not help. I've also given everyone read rights to the mootools directory:

      Source Code

      1. chmod -R a+r /usr/share/javascript/mootools

      again to no avail.

      I'm guessing there should somewhere be some rule instructing apache that it can get files from /usr/share/javascript.

      (I have this stuff on a virtual machine so I can mess around with it at will, it's just that I have no clue what to do.)
    • Re: Zoneminder

      Update (if I try Edit on my previous post, the forum system decides it's spam, hence new message): I've changed /etc/apache2/modes-enabled/alias.conf to include this:

      Source Code

      1. Alias /javascript/mootools "/usr/share/javascript/mootools/"
      2. <Directory "/usr/share/javascript/mootools">
      3. Order allow,deny
      4. Allow from all
      5. </Directory>

      (based on this: httpd.apache.org/docs/2.2/mod/mod_alias.html)
      This got rid of the 404 errors, but he JS console still has errors when loading the main ZoneMinder page:

      Source Code

      1. Uncaught ReferenceError: MooTools is not defined mootools-more.js:25
      2. Uncaught TypeError: Object [object Window] has no method 'addEvent'
    • Re: Zoneminder

      Hurrah! After reverting to the original mootools coming from the debian repositories (so forget what the bug report on debian.org is saying), this did the trick. The Source tab is accessible.

      I assume the only change necessary is the Alias thing, everything else is probably not needed. Possibly also the chmod -R.

      Unfortunately, after configuring my IP camera and trying to view it, it doesn't load the video stream. The JS console comes up with regular new mootools-related 404 errors looking like this:

      Source Code

      1. GET http://192.168.0.217/cgi-bin/nph-zms?mode=single&monitor=1&scale=100&connkey=13727&rand=1355867774&1355867857016 404 (Not Found) mootools.js:1769
      2. GET http://192.168.0.217/cgi-bin/nph-zms?mode=single&monitor=1&scale=100&connkey=13727&rand=1355867774&1355867862016 404 (Not Found)

      Tried following the instructions from zoneminder.com/wiki/index.php/…in_the_Zone_window_etc.3F and modifying /etc/apache2/httpd.conf to include:

      Source Code

      1. ScriptAlias /cgi-bin/ "/usr/lib/cgi-bin/"

      but now it just fails without any HTTP error code. Excellent.
    • Re: Zoneminder

      (This spam detection function of the forum is really nowhere near accurate.)

      Turns out from "tail /tmp/zmwatch.log" that it can't get shared memory (no such file or directory). Fortunately other people have encountered this too:
      ubuntuforums.org/showthread.php?t=1775337
      zoneminder.com/wiki/index.php/Debian_Squeeze#Inadequate_Memory_Allocation

      The solution with setting shmall and shmmax does not lead to a working setup and the log file still shows it can't get shared memory.
    • Re: Zoneminder

      Hi,

      I try to install zone minder but now i have some problem with apache2
      when i try to restart the service i have

      Source Code

      1. Syntax error on line 15 of /etc/apache2/openmediavault-webgui.d/default.conf:
      2. Wrapper /var/www/openmediavault/php-fcgi cannot be accessed: (2)No such file or directory
      3. Action 'configtest' failed.
      4. The Apache error log may have more information.
      5. failed!
      OMV Erasmus (always the last version) - version:AMD64 - noyau:4.7.0 - CPU:AMD II X2 250 - RAM:8Gb - RAID1 and RAID5