updating from 2 to 3: 502 error

    • OMV 3.x
    • Upgrade 2.x -> 3.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • updating from 2 to 3: 502 error

      I finally got around to updating using ovm-release-upgrade from 2 to 3.
      I have a 502 error on the GUI page (nginx). I do not have a monitor connected directly to my server. I am trying to access the gui from my personal browser on my home network

      I have searched to forum and tried some things but no solution. Maybe it's a plugin problem. Not sure. I don't know how to check for incompatible ones. Appreciate the help!

      I get the following errors:

      root@openmediavault:/# service php5-fpm restart
      Error: No space left on device
      Job for php5-fpm.service failed. See 'systemctl status php5-fpm.service' and 'journalctl -xn' for details.

      root@openmediavault:/# systemctl status php5-fpm.service
      php5-fpm.service - The PHP FastCGI Process Manager
      Loaded: loaded (/lib/systemd/system/php5-fpm.service; enabled)
      Active: failed (Result: exit-code) since Sat 2018-01-06 17:05:29 PST; 15min ago
      Process: 2572 ExecStart=/usr/sbin/php5-fpm --nodaemonize --fpm-config /etc/php5/fpm/php-fpm.conf (code=exited, status=78)
      Process: 2566 ExecStartPre=/usr/lib/php5/php5-fpm-checkconf (code=exited, status=0/SUCCESS)
      Main PID: 2572 (code=exited, status=78)

      Jan 06 17:05:29 openmediavault php5-fpm[2572]: [06-Jan-2018 17:05:29] ERROR: [pool openmediavault-webgui] cannot get uid for user 'openmediavault-webgui'
      Jan 06 17:05:29 openmediavault php5-fpm[2572]: [06-Jan-2018 17:05:29] ERROR: FPM initialization failed
      Jan 06 17:05:29 openmediavault systemd[1]: php5-fpm.service: main process exited, code=exited, status=78/n/a
      Jan 06 17:05:29 openmediavault systemd[1]: Failed to start The PHP FastCGI Process Manager.
      Jan 06 17:05:29 openmediavault systemd[1]: Unit php5-fpm.service entered failed state.

      root@openmediavault:/# journalctl -xn
      -- Logs begin at Sat 2018-01-06 16:56:28 PST, end at Sat 2018-01-06 17:21:16 PST. --
      Jan 06 17:20:16 openmediavault monit[1101]: 'fs_media_83b3d27b-8c1c-4520-96e0-34cc2a5fc488' space usage 93.9% matches resource limit [space usage>80.0%]
      Jan 06 17:20:16 openmediavault monit[1101]: 'omv-engined' process is not running
      Jan 06 17:20:16 openmediavault monit[1101]: 'omv-engined' trying to restart
      Jan 06 17:20:16 openmediavault monit[1101]: 'omv-engined' start: /etc/init.d/openmediavault-engined
      Jan 06 17:20:16 openmediavault omv-engined[3239]: Failed to set file group to 'openmediavault-engined' for '/var/lib/openmediavault/engined.sock'
      Jan 06 17:20:46 openmediavault monit[1101]: 'omv-engined' failed to start (exit status 0) -- /etc/init.d/openmediavault-engined: Starting OpenMediaVault engine daem
      on: ERROR.
      Jan 06 17:20:46 openmediavault monit[1101]: 'apache2' process is not running
      Jan 06 17:20:46 openmediavault monit[1101]: 'apache2' trying to restart
      Jan 06 17:20:46 openmediavault monit[1101]: 'apache2' start: /etc/init.d/apache2
      Jan 06 17:21:16 openmediavault monit[1101]: 'apache2' failed to start (exit status -1) -- Program /etc/init.d/apache2 failed: File '/etc/init.d/apache2' does not ex

      ist

      Here is output from dpkg -l | grep -E "php|openm" that others have asked for to help diagnose:

      The post was edited 4 times, last by egizzi ().

    • I've run it several times. Here is the output:

      I got this error:

      chown: invalid group: ':openmediavault-config'
      ERROR: Failed to create the default configuration: Command '['/usr/share/openmediavault/confdb/create.d/conf.sh']' returned non-zero exit status 1

      Then I read this post and did this from ssh:

      groupadd openmediavault-config

      And now it works.

      Thanks for the nudge.