Can't use SSH or CLI to update software.

    • OMV 3.x (stable)
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Can't use SSH or CLI to update software.

      Hello, I just started building my Pi NAS last night using OMV and my first time installing it went fine, I could SSH into it and everything seemed to work great but I messed up naming a drive and the software wouldn't let me delete or change it so I decided to reinstall OMV for a fresh slate.

      After re-installation, I went to bed and coming back today I realised I had a lot of packages to upgrade in the Update Manager. When ticking all of them and clicking upgrade I get the same error message constantly appearing, ending with 'dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.'.

      So I figure that's an easy fix, just SSH into my Pi and run 'dpkg --configure -a' and commands like it until I can seem to fix it, but running 'ssh -p 2987 192.168.1.185' just returns 'Connection reset by 192.168.1.185 port 2987' whereas yesterday it would successfully SSH into the pi with that command.
      Seeing as I couldn't SSH into it, I got out a monitor and keyboard and manually signed into my Pi, but after successfully entering my details it briefly shows me my Pi's CPU usage and so on but doesn't allow me to use CLI commands, just prompts me to sign in again, saying 'No directory, logging in with HOME=/. This account is currently not available.'

      I checked the FAQ here and saw:
      I cannot execute a program/script via SSH/CLI.
      You can't execute anything that lies on your data drives (/media/UUID/...). Those drives are mounted with 'noexec'. Move your program/script to the OS Disk instead.

      but I have no idea what that means essentially, nor how to do what it says.

      I don't know what to do at this point other than trying to reinstall the OS yet again and hope it works this time, but that's not a fix, nor do I want to have to do it.
      Does anybody know how I can solve my issues? I'll recap below.

      - Can't upgrade packages in the Update Manager due to dpkg being interrupted.
      - Can't SSH into Pi, the command just resets it.
      - Can't remain signed into Pi because there is no directory.

      Running OMV 3.0.79 on a Raspberry Pi 2B
      OS installed on a 16gb SD card
      Has working wired internet connection

      I hope somebody can help me with this because I am clueless as to what I can do.
      Many thanks.
    • Are you sure about the port for SSH? Standard port is 22. Have you changed it?

      Where did you get the image? There is a newer one here: sourceforge.net/projects/openm…/Raspberry%20Pi%20images/
      Make sure to follow the instructions exactly. It is also recommended to test the SD card before using is. For this you can use H2testw or f3
      Odroid HC2 - armbian - OMV4.x | Asrock Q1900DC-ITX - 16GB - 2x Seagate ST3000VN000 (rsnapshot) - 1x Intenso SSD 120GB - OMV4.x 64bit
      :!: Backup - Solutions to common problems in OMV - Must see OMV setup videos - OMV4 Documentation :!:
    • Yes, I changed the port from the original 22 for security, but even changing it back still returns the same issue of it just resetting the address.

      I confirmed that the image I have is the same as the one you posted and up to date.
      What's confusing is that I reinstalled it the exact same way as I did the first time, which was just using Etch.io to mount the file to the SD card, then booting the Pi off it until it prompts me to sign in for the first time.
      So if it worked the first time, I don't see how the SD card would become defective since then? But if you insist I will do the test. it's just that I'm not sure if the test wipes the card or not.
    • I appear to have found the solution.

      Unfortunately I was entirely at fault and kept trying to use SSH/CLI as Admin instead of Root.
      After signing in I did 'sudo apt-get update', then 'sudo dpkg --configure -a', then sudo apt-get update again, which worked successfully this time.

      Hope this helps anybody else.