ata1: COMRESET failed (errno=-16)

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • ata1: COMRESET failed (errno=-16)

      Hi!

      Just installed my first OpenmediaVault box, and see something not right in the logfiles when booting, causing slow boots.

      What I see repeatedly are messages like:
      ACPI _SDD failed (AE 0x5)
      ata1: link is slow to respond, please be patient (ready=0)
      ACPI: failed the second time, disabled
      ata1: COMRESET failed (errno=-16)

      Any ideas on what I am doing wrong/could do to remedy/fix the issues?
      Are these HW compatibility issues, or kernel bugs?

      Syslog snippet:

      Source Code

      1. Jun 12 11:32:45 openmediavault kernel: [ 6.185593] ata1: link is slow to respond, please be patient (ready=0)
      2. Jun 12 11:32:45 openmediavault kernel: [ 6.457326] ata6: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
      3. Jun 12 11:32:45 openmediavault kernel: [ 6.457344] ata4: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
      4. Jun 12 11:32:45 openmediavault kernel: [ 6.457358] ata3: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
      5. Jun 12 11:32:45 openmediavault kernel: [ 6.457706] ata6.00: ACPI _SDD failed (AE 0x5)
      6. Jun 12 11:32:45 openmediavault kernel: [ 6.457709] ata6.00: ACPI: failed the second time, disabled
      7. Jun 12 11:32:45 openmediavault kernel: [ 6.457729] ata4.00: ACPI _SDD failed (AE 0x5)
      8. Jun 12 11:32:45 openmediavault kernel: [ 6.457732] ata4.00: ACPI: failed the second time, disabled
      9. Jun 12 11:32:45 openmediavault kernel: [ 6.457734] ata5: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
      10. Jun 12 11:32:45 openmediavault kernel: [ 6.457757] ata3.00: ACPI _SDD failed (AE 0x5)
      11. Jun 12 11:32:45 openmediavault kernel: [ 6.457759] ata3.00: ACPI: failed the second time, disabled
      12. Jun 12 11:32:45 openmediavault kernel: [ 6.458098] ata5.00: ACPI _SDD failed (AE 0x5)
      13. Jun 12 11:32:45 openmediavault kernel: [ 6.458100] ata5.00: ACPI: failed the second time, disabled
      14. Jun 12 11:32:45 openmediavault kernel: [ 6.458109] ata6.00: ATA-8: ST3000DM001-1CH166, CC24, max UDMA/133
      15. Jun 12 11:32:45 openmediavault kernel: [ 6.458113] ata6.00: 5860533168 sectors, multi 16: LBA48 NCQ (depth 31/32), AA
      16. Jun 12 11:32:45 openmediavault kernel: [ 6.458122] ata4.00: ATA-8: ST3000DM001-1CH166, CC24, max UDMA/133
      17. Jun 12 11:32:45 openmediavault kernel: [ 6.458125] ata4.00: 5860533168 sectors, multi 16: LBA48 NCQ (depth 31/32), AA
      18. Jun 12 11:32:45 openmediavault kernel: [ 6.458168] ata3.00: ATA-8: ST3000DM001-1CH166, CC24, max UDMA/133
      19. Jun 12 11:32:45 openmediavault kernel: [ 6.458180] ata3.00: 5860533168 sectors, multi 16: LBA48 NCQ (depth 31/32), AA
      20. Jun 12 11:32:45 openmediavault kernel: [ 6.458579] ata5.00: ATA-8: ST3000DM001-1CH166, CC24, max UDMA/133
      21. Jun 12 11:32:45 openmediavault kernel: [ 6.458581] ata5.00: 5860533168 sectors, multi 16: LBA48 NCQ (depth 31/32), AA
      22. Jun 12 11:32:45 openmediavault kernel: [ 6.459067] ata3.00: configured for UDMA/133
      23. Jun 12 11:32:45 openmediavault kernel: [ 6.459106] ata6.00: configured for UDMA/133
      24. Jun 12 11:32:45 openmediavault kernel: [ 6.459144] ata4.00: configured for UDMA/133
      25. Jun 12 11:32:45 openmediavault kernel: [ 6.459489] ata5.00: configured for UDMA/133
      26. Jun 12 11:32:45 openmediavault kernel: [ 6.469314] ata2: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
      27. Jun 12 11:32:45 openmediavault kernel: [ 6.469675] ata2.00: ACPI _SDD failed (AE 0x5)
      28. Jun 12 11:32:45 openmediavault kernel: [ 6.469677] ata2.00: ACPI: failed the second time, disabled
      29. Jun 12 11:32:45 openmediavault kernel: [ 6.470077] ata2.00: ATA-8: ST3000DM001-1CH166, CC24, max UDMA/133
      30. Jun 12 11:32:45 openmediavault kernel: [ 6.470079] ata2.00: 5860533168 sectors, multi 16: LBA48 NCQ (depth 31/32), AA
      31. Jun 12 11:32:45 openmediavault kernel: [ 6.470984] ata2.00: configured for UDMA/133
      32. Jun 12 11:32:45 openmediavault kernel: [ 10.828872] ata1: COMRESET failed (errno=-16)
      33. Jun 12 11:32:45 openmediavault kernel: [ 16.191419] ata1: link is slow to respond, please be patient (ready=0)
      34. Jun 12 11:32:45 openmediavault kernel: [ 20.834707] ata1: COMRESET failed (errno=-16)
      35. Jun 12 11:32:45 openmediavault kernel: [ 26.189256] ata1: link is slow to respond, please be patient (ready=0)
      36. Jun 12 11:32:45 openmediavault kernel: [ 55.851096] ata1: COMRESET failed (errno=-16)
      37. Jun 12 11:32:45 openmediavault kernel: [ 55.851142] ata1: limiting SATA link speed to 1.5 Gbps
      38. Jun 12 11:32:45 openmediavault kernel: [ 56.170780] ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
      39. Jun 12 11:32:45 openmediavault kernel: [ 56.170948] ata1.00: ACPI _SDD failed (AE 0x5)
      40. Jun 12 11:32:45 openmediavault kernel: [ 61.494367] ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
      41. Jun 12 11:32:45 openmediavault kernel: [ 61.494534] ata1.00: ACPI _SDD failed (AE 0x5)
      42. Jun 12 11:32:45 openmediavault kernel: [ 61.494536] ata1.00: ACPI: failed the second time, disabled
      43. Jun 12 11:32:45 openmediavault kernel: [ 61.494562] ata1.00: ATA-7: SSDSA2SH032G1SB INTEL, 845C8855, max UDMA/133
      44. Jun 12 11:32:45 openmediavault kernel: [ 61.494565] ata1.00: 62500000 sectors, multi 16: LBA48 NCQ (depth 31)
      45. Jun 12 11:32:45 openmediavault kernel: [ 61.494823] ata1.00: configured for UDMA/133
      46. Jun 12 11:32:45 openmediavault kernel: [ 61.494916] scsi 0:0:0:0: Direct-Access ATA SSDSA2SH032G1SB 845C PQ: 0 ANSI: 5
      47. Jun 12 11:32:45 openmediavault kernel: [ 61.495027] scsi 1:0:0:0: Direct-Access ATA ST3000DM001-1CH1 CC24 PQ: 0 ANSI: 5
      48. Jun 12 11:32:45 openmediavault kernel: [ 61.495138] scsi 2:0:0:0: Direct-Access ATA ST3000DM001-1CH1 CC24 PQ: 0 ANSI: 5
      49. Jun 12 11:32:45 openmediavault kernel: [ 61.495230] scsi 3:0:0:0: Direct-Access ATA ST3000DM001-1CH1 CC24 PQ: 0 ANSI: 5
      50. Jun 12 11:32:45 openmediavault kernel: [ 61.495324] scsi 4:0:0:0: Direct-Access ATA ST3000DM001-1CH1 CC24 PQ: 0 ANSI: 5
      51. Jun 12 11:32:45 openmediavault kernel: [ 61.495406] scsi 5:0:0:0: Direct-Access ATA ST3000DM001-1CH1 CC24 PQ: 0 ANSI: 5
      Display All
    • Re: ata1: COMRESET failed (errno=-16)

      Already tried disconnecting all drives except the boot drive, same error. Changing to Legacy/IDE, Openmediavault no longer boots. Changing back to AHCI, and it boots again.

      Will try swapping the SATA cable for the boot disk once the raid has synced (building right now), and also try a different SATA port.

      Googling the error "COMRESET failed (errno=-16)" tells me it is most likely a BIOS issue:
      ask.fedoraproject.org/question…-failed-error-at-startup/
      bugs.launchpad.net/ubuntu/+sou…a/+bug/150259/comments/27
    • Re: ata1: COMRESET failed (errno=-16)

      Asus responded with:

      "I am afraid to say this board doesn't formally support the linux, so we can't ensure the compatibility.
      Sorry for the inconvenience.
      If you continue to experience issues in the future, please do not hesitate to contact us."

      Wonder if they will support Linux if I continue having issues with their MB..... ;)

      So in other words, they gave me the middle finger, damn Micro$haft to have such a tight grip on HW...

      This is why I wanted a Gigabyte MB, but they did not have a Mini ITX with 6 SATA ports...
    • same problem on my sytem: reason, wrong Settings (power on ring=enabled)
      Server:
      BitFenix Phenom M - ASRock B75 Pro3-M - 8GB Crucial B.S. - Intel G2140 - Corsair CX430M - 1x 64GB SanDisk SDSSDP (system) - 2x 2TB WD20EARX (data) - 1x 3TB WD30EFRX (Snapraid) - TBS6981 DVB-S2 - OMV 0.5x